Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Форум 1С: Одинэс.Ру

Найти!

Как быстро программно изменить родителя n-го числа элементов ? в 7.7

ronsel
12.02.2009 - 09:59
Собственно есть справочник в нем n-ое число элементов и две папки "Четные" и "Нечетные" и соответственно нужно элементы с четными кодами поместить в папку "Четные", а не четные в "Нечетные". Проблема в том, что после присвоения первому элементу родителя, Цикл - Пока Спр.ПолучитьЭлемент()=1 Цикл ..... КонцеЦикла - прекращается. Т.е. дальнейший перебор элементов уже происходить в папке-родителя ?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
27.10.2021 - 22:48
Смотри также:
помогите отловить "Ошибка при выполнении команды"
Отчет о прибылях и убытках Бухгалтерия 7.7
Зарплата КАМИН 1.2. Как выполнить переход с УСН на общее налогообложение в середине года?

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

PIP
32 - 13.02.2009 - 08:24
на форму обработки сразу выбрать нужных родителей

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

PIP
33 - 13.02.2009 - 08:33
виноват, не в тему, плохо прочел задачу (выбор по родителю это мимо).
А использовать ТЗ, и определять кого куда по коду

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Uho
34 - 13.02.2009 - 08:42
(31) о, кстати, с 1c++ или без пробовал?

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Гуня
35 - 13.02.2009 - 09:16
Я бы через запрос попробывал.

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

ronsel
36 - 13.02.2009 - 09:39
+(29) Изменил НайтиОбъект на НайтиЭлемент - Спр5.НайтиЭлемент(Спр.ТекущийЭлемент()); - результат тот же - обрабатывает 1 элемент и выходит из цикла

Интересные темы

odines.ru
27.10.2021 - 22:48
Смотри также:
ТиС 949. Отчёт по продажам ТМЦ. 100 % прибыль при списании ?!
Не записывается файл в формате XLS
Журнал регистрации

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Uho
37 - 13.02.2009 - 09:59
(36) ну да, да - элемент... но вот это уже совсем странно...
ЗЫ. транзакцию убери

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

ronsel
38 - 13.02.2009 - 10:13
(37) Транзакцию убрал - та же картина ...  

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Cthulhu
39 - 13.02.2009 - 15:03
тСпрТЗ=СоздатьОбъект("ТаблицаЗначений"); тСпрТЗ.НоваяКолонка("Элемент","Справочник.ТМЦ"); тСпрТЗ.НоваяКолонка("НовыйРодитель","Справочник.ТМЦ");
тСпр=СоздатьОбъект("Справочник.ТМЦ"); тСпр.ВыбратьЭлементы(0);
Пока тСпр.ПолучитьЭлемент()=1 Цикл
Если (тСпр.Уровень()>1)И(тСпр.ТекущийЭлемент().ЭтоГруппа()=0) Тогда
тСпрТЗ.НоваяСтрока(); тСпрТЗ.ПолучитьСтрокуПоНомеру(тСпрТЗ.КоличествоСтрок());
тСпрТЗ.Элемент=тСпр.ТекущийЭлемент(); тСпрТЗ.НовыйРодитель=?(тСпр.Код%2=0,Чет,Нечет);
КонецЕсли;
КонецЦикла;
тСпрТЗ.ВыбратьСтроки();
НачатьТранзакцию();
Пока тСпрТЗ.ПолучитьСтроку()=1 Цикл тСпр.НайтиЭлемент(тСпрТЗ.Элемент); тСпр.Родитель=тСпрТЗ.НовыйРодитель; тСпр.Записать(); КонецЦикла;
ЗафиксироватьТранзакцию();

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

LuckyIzja
40 - 13.02.2009 - 15:33
Сколько элементов в справочнике?
Если в пределах 10 000, то я бы воспользовался стандартной обработкой UChoice.ert.
Проще и нагляднее.
(Если конечно, это разовая операция...)

Re: Как быстро программно изменить родителя n-го числа элементов ? в 7.7

Onegsky
41 - 13.02.2009 - 16:00
ronsel
Товарищ! Пишите на SQL с использованием 1C++ :
|UPDATE
|  СпрКонтр
|SET
|  СпрКонтр.ParentID= "' АЙДИШНИК '"
|FROM
|  $Справочник.Контрагенты as СпрКонтр
|
|WHERE
|  СпрКонтр.IsFolder = 2 AND
|  СпрКонтр.IsMark = 0";
К списку тем 1 > К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений? Транзакция по OLE »
© 2009 Форум 1С: Одинэс.Ру