Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Форум 1С: Одинэс.Ру

Найти!

Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

АйЯяйТи
12.04.2009 - 15:23
Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?
В смысле, пусть надо передать p1, p2, тогда формируем Список Значений p из p1, p2 и предаем p как параметр?
По другому никак?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
25.10.2020 - 18:42
Смотри также:
ПУБ: Можно ли на 20й отнести затраты без расшифровки по ГП
Открыть диалог нового документа через расшифровку ячейки возможно?
Хочу вот такой такую табличную часть документа.

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

КонецЦикла
1 - 12.04.2009 - 15:31
Как угодно: ТЗ, массив, таблица, ...
Обычно юзаю список

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

АйЯяйТи
2 - 12.04.2009 - 15:44
А в 7.7 и массивы есть??? Грандиозно!!! )))

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Дятeл
3 - 12.04.2009 - 15:59
ыыыыы,  переходите на 8-ку, там это реализовано :)

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

КонецЦикла
4 - 12.04.2009 - 17:01
2(2) Не совсем понятно что так рассмешило...
Есть и курсоры, но это для избранных :)

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Друзья зовут меня Курулай
5 - 12.04.2009 - 17:30
(0) а зачем тебе по-другому?
(кстати, "по-другому" пишется через дефис).
Что тебя не устраивает в передаче через список значений? Ты столкнулся с каким-то случаем, когда этот способ не позволяет реализовать какую-то задачу?
Или просто собрался проехаться насчёт "убожества" движка? Типа, что за хрень такая, даже массивов нет, ну как тут работать!
 
P.S. Просто обожаю участнегов, которые всячески хают семёрочный движок, а на деле оказывается, просто не умеют его готовить, и показывают такой уровень знаний, что хоть святых выноси.

Интересные темы

odines.ru
25.10.2020 - 18:42
Смотри также:
Бюджетька 630 релиз - глюки с заявкой на кассовый расход
подчиненные справочники
Сравнение баз

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

АйЯяйТи
6 - 12.04.2009 - 18:58
4,ну, не сердитесь, дурацкая привычка к дурацким шуткам.
5,конкретные знания у меня по 7.7 только те, что успел за месяц с небольшим интенсивного освоения при решении конкретной задачи накопить. Про это я как-то честно написал, где-то месяц назад.
В принципе, я про список и сам нашел, только засомневался - вдруг есть ещё более простое решение.
Т.е. - ни в коем случае не собирался хаять семёрочный движок.
Наоборот, чем дальше - тем больше мне нравиться, доставляет удовольствие находить всякие фенечки.
Логично, наверно, было бы сейчас прямо с 8-ки начинать, но - ситуёвен конкретная - пока надо конкретно освоить 7-ку.

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

АйЯяйТи
7 - 12.04.2009 - 19:08
+6, с учетом того, что на Мисте прочитал, что для освоения разработки под 7.7 надо 2-4 месяца, оцениваю свой прогресс вполне удовлетворительно. (Сам себя не похвалишь - кто ж ещё похвалит )))

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

КонецЦикла
8 - 12.04.2009 - 20:05
Для адаптации к коду (ну типа чтобы синтаксических ошибок не было) - да, возможно 2 месяца хватит
В остальном... вернись к своим теперешним творениям лет через 5-10 :)

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Ctrl P
9 - 12.04.2009 - 20:11
иногда смотрю на свои творения полугодовой давности и диву даюсь как они вообще работают, а иногда попадаю на 4-5 летней давности и ничего до сих пор работают без сбоев - быстро и качественно...  :)

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Reaper
10 - 12.04.2009 - 21:33
Мну училсся писать года 1,5. Потом еще 0.5 года в 1С++, и толко после этого стал довольствоваться  своим кодом на клюшках. Таким темпом мне для счастья снеговика еще года 3-4 учить...

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

VZ
11 - 12.04.2009 - 21:58
Список - наиболее удобный способ передачи множества параметров. Можно, разумеется массив - но тогда вызываемая обработка должна знать размерность этого массива (параметр-то только один для передачи данных). Можно ТЗ - но ТЗ несколько неуклюжа для этого, по моему мнению. У ТЗ нет такого замечательного метода, как Получить()...
 
И вообще, СЗ содержить три колонки ;) А в значениях может содержать практически что угодно...

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Друзья зовут меня Курулай
12 - 13.04.2009 - 03:14
(11) +100
список - абсолютно достаточная штука для решения любых задач по передаче какого-либо набора данных в форму.

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

АйЯяйТи
13 - 13.04.2009 - 15:18
А как вы думаете, для полного новичка в 1с:
полезно перед изучением 8-ки хорошенько "прочуствовать" 7 или только мешать будет?
Ведь, как я понимаю, в обозримом будующем - все на 8-ке будем?

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Друзья зовут меня Курулай
14 - 13.04.2009 - 15:31
нет

Re: Передать больше одного парметра в ОткрытьФорму(обработка,p,) - только через Список Значений?

Чучундер
15 - 13.04.2009 - 16:44
ага, только при юзании СЗ.Получить("тралала") - надо внимание на регистр этого самого тралала смотреть...
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« МХ-1 Как быстро программно изменить родителя n-го числа элементов ? в 7.7 »
© 2009 Форум 1С: Одинэс.Ру