не получается написать обработку

Форум 1С: Одинэс.Ру

Найти!

не получается написать обработку

Bio Frode
15.07.2009 - 09:22
бюджетная бухгалтерия 7.7, задача стоит следующая: сделать обработку, которая на основании косгу будет заполнять счет дебета в документе Кассовое выбытие, вроде все просто, только вот в документе есть процедура "привыбореСчДт" которая при выборе счета подставляет значение субконто контрагенты и субконто договора, исходя из реквизитов шапки, если же обработка выбирает счет то это не происходит. как описать это действие в обработке, чтобы подставлял согласно процедуре "привыбореСчДт"
. вот код обработки:
 
Процедура Сформировать()
    Док = СоздатьоБЪЕКТ("Документ.КассовоеВыбытие");
НачатьТранзакцию();
Док.ВыбратьДокументы(НачДата,КонДата);
Пока Док.ПолучитьДокумент() = 1 Цикл
    Док.ТекущийДокумент();
Док.ВыбратьСтроки();
Пока док.ПолучитьСтроку()= 1 Цикл
    
Если док.КОСГУНазначениеПлатежа.Код="221" Тогда
Док.УстановитьАтрибут("СчетДт",счетпокоду("302.04.1"));
     иначеЕсли док.КОСГУНазначениеПлатежа.Код="222" Тогда
Док.УстановитьАтрибут("СчетДт",счетпокоду("302.05.1"));
  иначеЕсли док.КОСГУНазначениеПлатежа.Код="223" Тогда
Док.УстановитьАтрибут("СчетДт",счетпокоду("302.06.1"));
конецесли;
   Док.Записать();
//Док.Провести();
    КонецЦикла;
КонецЦикла;     
   ЗафиксироватьТранзакцию();
Сообщить("Готово");
КонецПроцедуры
 
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
27.10.2020 - 17:57
Смотри также:
1С для КПК?
Печать отчета многолистового
Выделить колонку цветом

Re: не получается написать обработку

Bio Frode
32 - 17.07.2009 - 12:50
(30) отсекеаю пробелы с лева и права, на тот случай, если нечайно начнут не сначала

Re: не получается написать обработку

roma n
33 - 17.07.2009 - 12:53
(32) ммм... кто случайно начнет не с начала?
"и всё - обработка будет работать" - ага, конечно

Re: не получается написать обработку

Bio Frode
34 - 17.07.2009 - 12:56
а какие варианты можно ещё использовать, подскажите, по поводу Авансов?

Re: не получается написать обработку

Uho
35 - 17.07.2009 - 13:05
32-Bio Frode > ты хоть понимаешь, что ты отсекаешь пробелы слева и справа не от комментария, а от ПОСТОЯННОЙ строки "Авансы", в которой НЕТ пробелов и которую написал ТЫ САМ.
ЗЫ.
34-Bio Frode > если уж все так плохо и можно опираться только на комментарий, то тогда уж хотя бы так:
 
Если ВРег(СокрЛП(Док.Комментарий))="АВАНСЫ"

Re: не получается написать обработку

Bio Frode
36 - 17.07.2009 - 13:23
я понял, что на косячил, спасибо.

Интересные темы

odines.ru
27.10.2020 - 17:57
Смотри также:
Почему проверка в списке на принадлежность первый раз тормозит а потом нет?
Выгрузка из 1С в ЕГАИС в формате xml
Перевод строки! Как бороться?

Re: не получается написать обработку

Has
37 - 18.07.2009 - 04:23
надеюсь что формирование комментария автоматизировано, иначе в нем запросто напишут "Аванс" и проверка пролетает

Re: не получается написать обработку

Блондинка в шок
38 - 18.07.2009 - 07:24
хм... это где ж Пенсионный Фонд такой, любопытно?
в нашем Отделении Пенсионного Фонда все конфы/обновления (и бюджетка и ЗИК) спускаются сверху централизованно из регионального Управления ПФ РФ, никакие фра и фри не допускаются в принципе. А в свете недавней компании по IT-безопасности тем более.
 
нарушает ваше Отделение ПФ их же внутренний регламент по IT-безопасности, однако настучат им по башке за это.
 
зы: а потом на радиорынках всплывают разные базы данных...

Re: не получается написать обработку

Пудель
39 - 18.07.2009 - 13:19
;)

Re: не получается написать обработку

Bio Frode
40 - 21.07.2009 - 15:31
(38) все изменения, которые делаются нашей фирмой в ПФ согласованы и Управлением ПФ РФ, и с фирмой "1С". Так что, по башке им точно не настучат, обработка в итоге заработала как надо, если кому интересно, что за кривую и косую обработку я написал могу выложить

Re: не получается написать обработку

МимохожийОднако
41 - 21.07.2009 - 16:30
40-Bio Frode > Кидай на инфостарт. Там подобного добрища до...
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« V7: Вы будете смеяться, но юзер скопировал МД вместо объединения По ОЛЕ запустить отчет можно ? »
© 2009 Форум 1С: Одинэс.Ру