КомпонентаСХК.Инициализация().Ошибка создания файла.

Форум 1С: Одинэс.Ру

Найти!

КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
25.05.2009 - 16:58
Сельскохозяйственное предприятие (разработка фирмы Рарус) стоит на серваке. Когда запускаешь базу через десктоп под правами админа все нормально, ошибок нет. Но когда заходит бух с ограниченными правами, то выходит такая ошибка. Вот код:
//сх+
Состояние("Инициализация конфигурации ...");
// Загружаем компоненту защиты
Если ЗагрузитьВнешнююКомпоненту("SHK3.dll")=0 Тогда
Предупреждение("Не обнаружен ключ защиты программы!", 30);
СтатусВозврата(0); Возврат;
Иначе
КомпонентаСХК = СоздатьОбъект("AddIn.SHK3");
КомпонентаСХК.Инициализация();
КонецЕсли;
//сх+ конец
 
Никто не сталкивался с таким явлением?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
24.10.2020 - 15:26
Смотри также:
Печать отчета многолистового
В одной базе разный результат одного кода на разных движках 25 и 27
платежки в 1с выгружаются неправильно

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

buh
1 - 25.05.2009 - 17:07
Нет, не сталкивался.
Ищите, в какую папку компонента пишет свои файлы, и дайте на нее права буху.
Пора уже организовывать общество защиты прав бухов, по-моему :)

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
2 - 25.05.2009 - 17:14
Это понятно, но как найти ее. Возможно что такой папки для буха и не существует и прав нет чтобы создать. А DLL наверно не посмотришь...

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

buh
3 - 25.05.2009 - 17:26
Зайди под админом.
Попробуй переставить дату вперед.
Запусти.
А потом виндоузным поиском найди файлы измененные новой датой.
Это просто идея, я понятия не имею, найдется ли что-то.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
4 - 25.05.2009 - 17:37
Идея интересная. Можно попробовать.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

VZ
5 - 25.05.2009 - 20:07
vkloader.dll
regsrvex.exe
 
Эти инструменты для запуска ВК под ограниченными правами пробовал?

Интересные темы

odines.ru
24.10.2020 - 15:26
Смотри также:
Как настроить два ключа на одну компоненту.
Как перебрать табличную часть подченённого подчинённому справочнику справочника
1Cv7.7 на Windows server 2008 std sp1 x64

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

МимохожийОднако
6 - 26.05.2009 - 03:14
Дай права админа для бухгалтера на первое время. После успешного запуска верни обратно.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

MrDen
7 - 28.05.2009 - 13:21
если файла нет закоментировать строки
http://www.forum.mista.ru/topic.php?id=180165
переменная КомпонентаСХК вообще используется где нибудь?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
8 - 28.05.2009 - 17:27
vkloader.dll
regsrvex.exe  не пробовал. КомпонентаСХК не знаю используется ли. Когда в сельхозконфигурации вообще ключ защиты не обнаруживается, то некоторые доки не проводятся. А тут вроде все проводится, все работает, только вот эта ошибка не приведет ли потом к каким-нибудь последствиям. У меня мысль такая что SHK3.dll пытается создать временный файл для пользователя.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Партизан
9 - 29.05.2009 - 04:31
Ну а по тексту конфы вызываются у данного объекта методы какие?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
10 - 29.05.2009 - 06:13
В модуле проведения документов идет проверка по защите конфы. Если ключ не обнаружен, то документ не проводится. У нас ключ обнаруживается, только инициализация не происходит. Документы проводятся нормально, ни на что больше не ругается (только в начале запуска программы).

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Партизан
11 - 29.05.2009 - 13:34
Если не в лом какой нибудь фрагментик кода по проверке в модуле документа?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
12 - 29.05.2009 - 15:48
(0) А у меня такого нет, что делаю не так, не понимаю?
(11) Если глДопПроведение(Контекст, спПарам) = 0 Тогда
глНеПроводить(ТекущийДокумент());
Возврат;
КонецЕсли;
 
............
// глДопПроведение()
//
Функция глДопПроведение(Конт, спПарам="") Экспорт
Если ТипЗначенияСтр(спПарам) <> "СписокЗначений" Тогда спПарам = СоздатьОбъект("СписокЗначений"); КонецЕсли;
Попытка КомпонентаСХК.ДопПроведение(Конт, спПарам);
Исключение Возврат 0; КонецПопытки;
Возврат 1;
КонецФункции // глДопПроведение()

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
13 - 29.05.2009 - 18:02
Вот собственно и код привели.
bvk, чего нет?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
14 - 29.05.2009 - 18:06
(13) Ошибки

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
15 - 29.05.2009 - 18:08
У меня ошибка лезет только при урезанных правах пользователя (бухгалтера), а если права дать админа то все нормально.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
16 - 29.05.2009 - 18:26
Не знаю, но у меня работает с урезаными правами, поэтому чесно скажу - не сталкивался.
.
ЗЫ: Устал сегодня, кирпич привёз по 3,60! СЛАВА КРИЗИСУ!

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
17 - 30.05.2009 - 05:37
Понятно.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Маус
18 - 30.05.2009 - 09:25
16-bvk >красный или белый?
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« ПУБ. Исправление в текущем периоде поступления и отгрузки прошлых периодов предприниматель 3 ндфл »
© 2009 Форум 1С: Одинэс.Ру