КомпонентаСХК.Инициализация().Ошибка создания файла.

Форум 1С: Одинэс.Ру

Найти!

КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
25.05.2009 - 16:58
Сельскохозяйственное предприятие (разработка фирмы Рарус) стоит на серваке. Когда запускаешь базу через десктоп под правами админа все нормально, ошибок нет. Но когда заходит бух с ограниченными правами, то выходит такая ошибка. Вот код:
//сх+
Состояние("Инициализация конфигурации ...");
// Загружаем компоненту защиты
Если ЗагрузитьВнешнююКомпоненту("SHK3.dll")=0 Тогда
Предупреждение("Не обнаружен ключ защиты программы!", 30);
СтатусВозврата(0); Возврат;
Иначе
КомпонентаСХК = СоздатьОбъект("AddIn.SHK3");
КомпонентаСХК.Инициализация();
КонецЕсли;
//сх+ конец
 
Никто не сталкивался с таким явлением?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 03:46
Смотри также:
Камин ЗП не пойму как задать экр для начислений
После обновления до 7.70.027 перестала работать обработка
выгрузка в txt файл

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Партизан
9 - 29.05.2009 - 04:31
Ну а по тексту конфы вызываются у данного объекта методы какие?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
10 - 29.05.2009 - 06:13
В модуле проведения документов идет проверка по защите конфы. Если ключ не обнаружен, то документ не проводится. У нас ключ обнаруживается, только инициализация не происходит. Документы проводятся нормально, ни на что больше не ругается (только в начале запуска программы).

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Партизан
11 - 29.05.2009 - 13:34
Если не в лом какой нибудь фрагментик кода по проверке в модуле документа?

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
12 - 29.05.2009 - 15:48
(0) А у меня такого нет, что делаю не так, не понимаю?
(11) Если глДопПроведение(Контекст, спПарам) = 0 Тогда
глНеПроводить(ТекущийДокумент());
Возврат;
КонецЕсли;
 
............
// глДопПроведение()
//
Функция глДопПроведение(Конт, спПарам="") Экспорт
Если ТипЗначенияСтр(спПарам) <> "СписокЗначений" Тогда спПарам = СоздатьОбъект("СписокЗначений"); КонецЕсли;
Попытка КомпонентаСХК.ДопПроведение(Конт, спПарам);
Исключение Возврат 0; КонецПопытки;
Возврат 1;
КонецФункции // глДопПроведение()

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
13 - 29.05.2009 - 18:02
Вот собственно и код привели.
bvk, чего нет?

Интересные темы

odines.ru
20.10.2020 - 03:46
Смотри также:
"Повисшая" проводка.
Как должны выписываться СФ на аванс в 2009 в ПУБ или Комплексной?
не показывает СНД по сумме

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
14 - 29.05.2009 - 18:06
(13) Ошибки

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
15 - 29.05.2009 - 18:08
У меня ошибка лезет только при урезанных правах пользователя (бухгалтера), а если права дать админа то все нормально.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

bvk
16 - 29.05.2009 - 18:26
Не знаю, но у меня работает с урезаными правами, поэтому чесно скажу - не сталкивался.
.
ЗЫ: Устал сегодня, кирпич привёз по 3,60! СЛАВА КРИЗИСУ!

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Klinov
17 - 30.05.2009 - 05:37
Понятно.

Re: КомпонентаСХК.Инициализация().Ошибка создания файла.

Маус
18 - 30.05.2009 - 09:25
16-bvk >красный или белый?
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« ПУБ. Исправление в текущем периоде поступления и отгрузки прошлых периодов предприниматель 3 ндфл »
© 2009 Форум 1С: Одинэс.Ру