Помогите разобраться с метаданными

Форум 1С: Одинэс.Ру

Найти!

Помогите разобраться с метаданными

Apollo
04.03.2009 - 09:06
Коллеги, помогите.
 
в отдалчике
Метаданные.Справочник("Клиенты") = Метаданные
Метаданные.Справочник("Клиенты").Реквизит() - ошибка в выражении!
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
19.09.2021 - 19:23
Смотри также:
ОС приобретено за счет целевых средств, как начислять износ, а не аммортизацию.
Простой Запрос
Помогите обновить древнюю измененную конфигурацию...

Re: Помогите разобраться с метаданными

Apollo
1 - 04.03.2009 - 09:08
Моя задача выгрузить названия, типы и значения всех реквизитов элемента справочника в файл.

Re: Помогите разобраться с метаданными

lalex23
2 - 04.03.2009 - 09:55
МетаданныеСправочник = Метаданные.Справочник(ТекущийСправочник);
Для СчМ = 1 По МетаданныеСправочник.Реквизит()  Цикл
ТекущийРеквизит = МетаданныеСправочник.Реквизит(СчМ);

Re: Помогите разобраться с метаданными

Apollo
3 - 04.03.2009 - 10:18
МетаданныеСправочник = Метаданные.Справочник(СокрЛП(спрТЗ.Вид));
     Для СчМ = 1 По МетаданныеСправочник.Реквизит()  Цикл
 
на второй строке ошибка (((((
отладчик:
МетаданныеСправочник = Метаданные
МетаданныеСправочник.Реквизит() = Ошибка в выражении!
спрТЗ.Вид = "Клиенты                       "

Re: Помогите разобраться с метаданными

Ctrl P
4 - 04.03.2009 - 10:43
не МетаданныеСправочник.Реквизит()  а Метаданные.Справочник.Реквизит()  

Re: Помогите разобраться с метаданными

Apollo
5 - 04.03.2009 - 12:08
все равно та же ошибка
 
Для СчМ = 1 По Метаданные.Справочник(СокрЛП(спрТЗ.Вид)).Реквизит()  Цикл
{Документ.ЭкспортДанных.Форма.Модуль(187)}: Поле агрегатного объекта не обнаружено (Реквизит)

Интересные темы

odines.ru
19.09.2021 - 19:23
Смотри также:
Обмен между платформами 8->7.7
Бюджетка. Прислали файлы из казначейства. Через что их загружать?
Сортировка в справочнике

Re: Помогите разобраться с метаданными

абдулька
6 - 04.03.2009 - 13:38
а Метаданные разве не зарезервированное слово? Вот так не получится:
кфгСправочник = Метаданные.Справочник(СокрЛП(спрТЗ.Вид));
     Для СчМ = 1 По кфгСправочник.Реквизит()  Цикл

Re: Помогите разобраться с метаданными

Arden
7 - 04.03.2009 - 14:04
(5) Метаданные.Справочник("Сотрудники").Реквизит() = 59
все работает.
ИМХО ищи ошибку в СокрЛП(спрТЗ.Вид) какойто у тебя не правильный идентификатор справочника

Re: Помогите разобраться с метаданными

Apollo
8 - 04.03.2009 - 14:06
(7)
СокрЛП(спрТЗ.Вид) = "Клиенты"
в (3) это виидно. А как должно быть???

Re: Помогите разобраться с метаданными

Arden
9 - 04.03.2009 - 14:07
+6 точно не правильный идентификатор
МетаДанные.Справочник("Сотрудники") = Сотрудники
а не  МетаДанные.Справочник("Сотрудники") = Метаданные

Re: Помогите разобраться с метаданными

Arden
10 - 04.03.2009 - 14:08
(8) значит у справочника идентификатор на "Клиенты", а уж какой я не знаю.
ЗЫ пробелов не навставлено там ?

Re: Помогите разобраться с метаданными

Arden
11 - 04.03.2009 - 14:15
торможу. не может быть там пробела.
и вообще
Процедура Сформировать()                                        
Для Сч1 = 1 По МетаДанные.Справочник()  Цикл
Сообщить(МетаДанные.Справочник(Сч1));
Для Сч2 = 1 По МетаДанные.Справочник(Сч1).Реквизит()Цикл
Сообщить(МетаДанные.Справочник(Сч1).Реквизит(Сч2).Идентификатор);
КонецЦикла;                                                  
КонецЦикла
 
КонецПроцедуры

Re: Помогите разобраться с метаданными

Apollo
12 - 04.03.2009 - 14:16
(10) точно... не клиенты ))))  я протупил... "Клиенты" - это в той базе, в которую я передаю, а не в текущей

Re: Помогите разобраться с метаданными

Apollo
13 - 04.03.2009 - 14:25
ТекРеквизит = Метаданные.Справочник(спрТЗ.Эл.Вид()).Реквизит(СчМ).Идентификатор; - это название реквизита
 
А как получить сожержимое реквизита???

Re: Помогите разобраться с метаданными

victuan
14 - 04.03.2009 - 14:44
(13) ты путаешь теплое с мягким.
То же самое что спросить: "Я в справочник Товар внес цену, а как внести остатки в карточку товара?"

Re: Помогите разобраться с метаданными

Den
15 - 04.03.2009 - 14:54
(13)...
Спр = СоздатьОбъект("Справочник."+спрТЗ.Эл.Вид());
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() > 0 Цикл
...
Спр.ПолучитьАтрибут(ТекРеквизит);
...
КонецЦикла;

Re: Помогите разобраться с метаданными

Uho
16 - 04.03.2009 - 14:58
"СокрЛП(спрТЗ.Вид) = "Клиенты"
в (3) это виидно. А как должно быть???"

точно... не клиенты ))))  я протупил...
)))  
 

Re: Помогите разобраться с метаданными

Apollo
17 - 04.03.2009 - 14:59
(14) (15) а я думал, что можно как-то через метаданные... волшебным образом )))

Re: Помогите разобраться с метаданными

Apollo
18 - 04.03.2009 - 15:08
(16) что делать! на тупой работе приходится тупить )
К списку тем 1 > К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Случилось ЧП, все документы пропали из базы формата DBF, как можно восстановить, документы не удаляли. Не проходит стандартный вычет по апрелю »
© 2009 Форум 1С: Одинэс.Ру