Помогите разобраться с метаданными

Форум 1С: Одинэс.Ру

Найти!

Помогите разобраться с метаданными

Apollo
04.03.2009 - 09:06
Коллеги, помогите.
 
в отдалчике
Метаданные.Справочник("Клиенты") = Метаданные
Метаданные.Справочник("Клиенты").Реквизит() - ошибка в выражении!
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
05.12.2020 - 05:02
Смотри также:
Как работать со временем ?
Посреднические услуги или перевыставление услуги ?
Объединение печатных форм

Re: Помогите разобраться с метаданными

Arden
9 - 04.03.2009 - 14:07
+6 точно не правильный идентификатор
МетаДанные.Справочник("Сотрудники") = Сотрудники
а не  МетаДанные.Справочник("Сотрудники") = Метаданные

Re: Помогите разобраться с метаданными

Arden
10 - 04.03.2009 - 14:08
(8) значит у справочника идентификатор на "Клиенты", а уж какой я не знаю.
ЗЫ пробелов не навставлено там ?

Re: Помогите разобраться с метаданными

Arden
11 - 04.03.2009 - 14:15
торможу. не может быть там пробела.
и вообще
Процедура Сформировать()                                        
Для Сч1 = 1 По МетаДанные.Справочник()  Цикл
Сообщить(МетаДанные.Справочник(Сч1));
Для Сч2 = 1 По МетаДанные.Справочник(Сч1).Реквизит()Цикл
Сообщить(МетаДанные.Справочник(Сч1).Реквизит(Сч2).Идентификатор);
КонецЦикла;                                                  
КонецЦикла
 
КонецПроцедуры

Re: Помогите разобраться с метаданными

Apollo
12 - 04.03.2009 - 14:16
(10) точно... не клиенты ))))  я протупил... "Клиенты" - это в той базе, в которую я передаю, а не в текущей

Re: Помогите разобраться с метаданными

Apollo
13 - 04.03.2009 - 14:25
ТекРеквизит = Метаданные.Справочник(спрТЗ.Эл.Вид()).Реквизит(СчМ).Идентификатор; - это название реквизита
 
А как получить сожержимое реквизита???

Интересные темы

odines.ru
05.12.2020 - 05:02
Смотри также:
Печать содержимого документов
504
Сохранить открытый документ

Re: Помогите разобраться с метаданными

victuan
14 - 04.03.2009 - 14:44
(13) ты путаешь теплое с мягким.
То же самое что спросить: "Я в справочник Товар внес цену, а как внести остатки в карточку товара?"

Re: Помогите разобраться с метаданными

Den
15 - 04.03.2009 - 14:54
(13)...
Спр = СоздатьОбъект("Справочник."+спрТЗ.Эл.Вид());
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() > 0 Цикл
...
Спр.ПолучитьАтрибут(ТекРеквизит);
...
КонецЦикла;

Re: Помогите разобраться с метаданными

Uho
16 - 04.03.2009 - 14:58
"СокрЛП(спрТЗ.Вид) = "Клиенты"
в (3) это виидно. А как должно быть???"

точно... не клиенты ))))  я протупил...
)))  
 

Re: Помогите разобраться с метаданными

Apollo
17 - 04.03.2009 - 14:59
(14) (15) а я думал, что можно как-то через метаданные... волшебным образом )))

Re: Помогите разобраться с метаданными

Apollo
18 - 04.03.2009 - 15:08
(16) что делать! на тупой работе приходится тупить )
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Случилось ЧП, все документы пропали из базы формата DBF, как можно восстановить, документы не удаляли. Не проходит стандартный вычет по апрелю »
© 2009 Форум 1С: Одинэс.Ру