Подскажите как вывевти на экран незаписанный документ?

Форум 1С: Одинэс.Ру

Найти!

Подскажите как вывевти на экран незаписанный документ?

noviptr
05.06.2009 - 08:15
Обработкой создается документ, бух должен глянуть в него заполнить пару параметров и сохранить, провести и т.д. при этом возможно, что и вообще передумает записывать...
 

ОткрытьФорму(ДокМт.ТекущийДокумент());
работает только после
ДокМт.Записать();
Как указать на документ без записи?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
03.12.2020 - 08:48
Смотри также:
Пересчет итогов и прочие регламенты, когда и как часто
Документ Недолжен попадать 2 раза
Проблема с запуском 1С: исключение unknown software exception приложении по адресу

Re: Подскажите как вывевти на экран незаписанный документ?

banzay
1 - 05.06.2009 - 08:20
В ГМ:
Функция глВзятьКонтекст(Конт) Экспорт
Возврат Конт;
КонецФункции // глВзятьКонтекст()
 
В обработке:
Процедура ВвестиДокумент()
Перем КонтФормы;
 
КонтФормы = глВзятьКонтекст(Контекст);
 
ОткрытьФорму("Документ.ХХХ",КонтФормы);
 
КонтФормы.ДатаДок = ДатаДок;
КонтФормы.Форма.Обновить();
 
КонецПроцедуры // ВвестиДокумент()

Re: Подскажите как вывевти на экран незаписанный документ?

banzay
2 - 05.06.2009 - 08:21
ПыСы
КонтФормы.ДатаДок = ДатаДок; - не обязательно

Re: Подскажите как вывевти на экран незаписанный документ?

noviptr
3 - 05.06.2009 - 08:40
Спасибо.

Re: Подскажите как вывевти на экран незаписанный документ?

victuan
4 - 05.06.2009 - 09:15
(1) А вот это зачем?
КонтФормы = глВзятьКонтекст(Контекст);
 
ни-па-ни-маю

Re: Подскажите как вывевти на экран незаписанный документ?

roma n
5 - 05.06.2009 - 09:33
(4) если без расширительного толкования - то ни к чему.
А ежели в общем виде - 1с переглючивает при присвоении контекста переменной или при записывании его в список значений. При использовании глоб функции проблема решается

Интересные темы

odines.ru
03.12.2020 - 08:48
Смотри также:
Вышли 504 бухгалтерия и 152 Предприниматель
Работа по OLE
Случилось ЧП, все документы пропали из базы формата DBF, как можно восстановить, документы не удаляли.

Re: Подскажите как вывевти на экран незаписанный документ?

pit
6 - 05.06.2009 - 15:05
бред какой то.....  хотя понятно - дятлы СП не читают, его будут ёжики читать...
 
(0)
"ОткрытьФорму(ДокМт.ТекущийДокумент());
работает только после
ДокМт.Записать();
Как указать на документ без записи?"
 

ДЛЯ СЛЕПЫХ ДЯТЛОВ
 
ОткрытьФорму(<?>,,)
Синтаксис:
ОткрытьФорму(<ОписательОбъекта>,<КонтекстФормы>,<ДокументОснование>)
Назначение:
Открывает визуальную форму ввода нового документа (в т.ч. в режиме ввода на основании).
Возвращает: 1 - если действие выполнено, 0 - иначе.
Параметры:
<ОписательОбъекта> - строка-описатель документа вида:
  'Документ.ХХХХХ', где ХХХХХХ - вид документа;
<КонтекстФормы> - имя переменной, куда можно задать значение любого типа для передачи в открываемую форму. Данное значение будет доступно в открытой форме как атрибут Форма.Параметр. После исполнения данного метода система вернет в данную переменную контекст открытой формы (необязателен);
<ДокументОснование> - документ-основание для открытия формы ввода нового документа в режиме ввода на основании (необязателен).
Замечание:
Пока форма открыта, тип значения параметра <КонтекстФормы> равен 100, когда закрыта - 0.

Re: Подскажите как вывевти на экран незаписанный документ?

МимохожийОднако
7 - 05.06.2009 - 17:12
Слепой дятел - новый развивающийся вид в 1с-орнитологии. Надо бы добавить в классификатор этой популяции

Re: Подскажите как вывевти на экран незаписанный документ?

pit
8 - 05.06.2009 - 18:18
Специально для слепых дятлов - мониторы с выводом текста по модернизированному методу Брайля - линейкой по башке....

Re: Подскажите как вывевти на экран незаписанный документ?

noviptr
9 - 06.06.2009 - 10:53
(6) (8) Спасибо на добром слове. Но СП и ЖКК я прочитал. Проблема не в том, чтобы открыть новый документ, а перехватить в режиме редактирования заполненный из ТЗ, не записывая его перед этим. Из ЖКК не совсем понятно как это сделать. если кто-нибудь на примере (вместо перепечатывания текста из ЖКК) пояснит как это делается, желательно без правки ГМ буду премного благодарен.

Re: Подскажите как вывевти на экран незаписанный документ?

Пацталоцци
10 - 06.06.2009 - 11:52
чтобы понять, о чём тебе говорит pit, ты должен изменить подход к заполнению документа.
ты сейчас как заполняешь документ? что-то типа того:
ДокМт = создатьОбъект("Документ.Траляля")
ДокМт.ДатаДок = НекаяДата;
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
   (тут какие-то действия по заполнению ДокМт)
КонецЦикла;

и так далее
 
тебе нужно делать по-другому
сначала открываем форму нового документа, при этом получаем ссылку на его контекст
 

Конт = "";
ОткрытьФорму("Документ.ТраЛяЛя", Конт, );

 
теперь мы имеем в переменной Конт ссылку на контекст открытого документа.
С помощью этой ссылки заполняем документ, как хотим
Конт.ДатаДок = НекаяДата;
и так далее

Re: Подскажите как вывевти на экран незаписанный документ?

Струнин
11 - 06.06.2009 - 11:53
Насколько я понял...
у вас...
1. Запускается внешняя обработка.
2. создается документ, причем вам приходится его записать (а не хочется).
 
Ответ вам дан в (1). ГМ менять не надо, там функция глВзятьКонтекст должна быть (или ей подобная), в крайнем случае используйте просто Контекст.
 
Можно иначе
Создаёшь новый документ кнопкой Инсерт, попадаешь в его форму естественно.
Документ ещё не записан (т.е. Выбран()=0).
Обработку запускаете ИЗ документа. Типа того как организован Подбор (см в типовых).
После того как она отработает - заполнятся реквизиты формы открытого документа.
Дальше Бух сам смотрит, сохранять док или нет.
 
вот для размышления...
http://www.forum.mista.ru/topic.php?id=121598&t1c=1
 
а вообще используйте поиск с ПРАВИЛЬНО сформулированным вопросом.
в инете есть примеры подобной задачи.

Re: Подскажите как вывевти на экран незаписанный документ?

Струнин
12 - 06.06.2009 - 11:55
(10)
:)

Re: Подскажите как вывевти на экран незаписанный документ?

noviptr
13 - 06.06.2009 - 12:00
Спасибо. теперь разобрался

Re: Подскажите как вывевти на экран незаписанный документ?

VadimB
14 - 06.06.2009 - 12:48
Пришли телепаты и все объяснили. :-))
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Бюджетка, не загружается классификатор доходов Почему бух. баланс форма 2 не выгружается? Код ОКВЭД не соответсвтует классификатору? »
© 2009 Форум 1С: Одинэс.Ру