ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Форум 1С: Одинэс.Ру

Найти!

ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
09.04.2009 - 15:59
Собственно вопрос, как добавить в ТЗ нужное колво пустых строк?
.
Вариант1 - можно так:
ТЗ.КоличествоСтрок(ТЗ.КоличествоСтрок()+N)
.
Вариант2 - а можно так:
Для  ы=1 По N
Цикл ТЗ.НоваяСтрока();
КонецЦикла;
.
Как "правильнее"?
И правда ли, что КоличествоСтрок(M) - работает неустойчиво?
Ну и наконец - что быстрее?
.
всем спсб.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
21.10.2020 - 18:13
Смотри также:
Возможно-ли интерактивно ввести значение в ячейку таблицы значений из справочника ?
Ключ HASP под LTP ...
В SQL база вылетает при открытии документа "Отмена заявок"

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Дятeл
1 - 09.04.2009 - 16:02
Ну и наконец - что быстрее?
а чё, так ломает проверить замером производительности?
И правда ли, что КоличествоСтрок(M) - работает неустойчиво?
какие-то глюки встречались вроде после сортировки ТЗ... но могу ошибаться.

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
2 - 09.04.2009 - 16:03
1-Дятeл > а чё, так ломает проверить замером производительности?
ясен пень, ломает! ;-)

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Друзья зовут меня Курулай
3 - 09.04.2009 - 16:04
какая интереснейшая тема!!!!

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Cthulhu
4 - 09.04.2009 - 16:04
(1): угу, применение ".КоличествоСтрок(..)" после сортировки сбивало порядок строк.. это как минимум..

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

АЛьФ
5 - 09.04.2009 - 16:05
КоличествоСтрок() работает быстрей, естественно. А глючит, насколько я помню, когда им уменьшаешь количество строк, а потом увеличиваешь.

Интересные темы

odines.ru
21.10.2020 - 18:13
Смотри также:
Бух 7.7 и авансы
Как можно сократить время проводок?
Выгрузка из Бух в ТиС в работающих базах

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Sk0rp
6 - 09.04.2009 - 17:18
Сталкивался, что если сначала отсортировать, потом уменьшить через КоличествоСтрок() - удаляются не те, что в конце, а из каких-то других принципов.

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Дятeл
7 - 09.04.2009 - 17:26
опять же, если не изменяет склероз - выгрузка/загрузка через временную ТЗ избавляет от глюков..

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
8 - 09.04.2009 - 19:17
итого: юзать НовуюСТроку - гламурнее...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

user1C
9 - 09.04.2009 - 19:38
(8)
ога, при нынешней производительности компов то))
только НоваяСтрока не умеет в минус работать...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
10 - 09.04.2009 - 20:12
2(0) Зачем понадобилось?
Что-то не припомню когда приходилось забивать пустые строки...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
11 - 09.04.2009 - 20:15
+(10) Ну разве что слияние двух ТЗ...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
12 - 09.04.2009 - 21:32
11-КонецЦикла > именно

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
13 - 09.04.2009 - 21:37
Ну дык кол-во строк конечно, в этом контексте ни разу не глючило

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
14 - 09.04.2009 - 22:35
13-КонецЦикла > да вот фиг его знает.. ;-)

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

reanimator
15 - 10.04.2009 - 03:36
В 7.7 не помню в каком релизе при работе с очень большими ТЗ создалось впечатление, что добавление строки в ТЗ внутри происходит следующим образом - создаётся новая ТЗ-2 на строку большая, чем предыдущая, после чего в неё переносятся все данные из ТЗ, память из под ТЗ освобождается, а указатель перенаправляется на ТЗ-2. Только этим могу объяснить жуткие тормоза при добавлении новой строки в ТЗ большого объёма, чем больше ТЗ, тем больше тормоза.

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

reanimator
16 - 10.04.2009 - 03:38
+(15) Сейчас задумался - а 1с ли это была?... Вроде она :)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« является ли отсутствие ключа защиты нарушением использования лицензионного ПО? Help: Не выводится логотип при печати счета-фактуры »
© 2009 Форум 1С: Одинэс.Ру