ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Форум 1С: Одинэс.Ру

Найти!

ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
09.04.2009 - 15:59
Собственно вопрос, как добавить в ТЗ нужное колво пустых строк?
.
Вариант1 - можно так:
ТЗ.КоличествоСтрок(ТЗ.КоличествоСтрок()+N)
.
Вариант2 - а можно так:
Для  ы=1 По N
Цикл ТЗ.НоваяСтрока();
КонецЦикла;
.
Как "правильнее"?
И правда ли, что КоличествоСтрок(M) - работает неустойчиво?
Ну и наконец - что быстрее?
.
всем спсб.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 17:20
Смотри также:
Как быстро распечатать документы?
прямое обращение к ДБФ-файлу помогите
Спр.НайтиПоНаименованию("Его",1,);

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Дятeл
7 - 09.04.2009 - 17:26
опять же, если не изменяет склероз - выгрузка/загрузка через временную ТЗ избавляет от глюков..

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
8 - 09.04.2009 - 19:17
итого: юзать НовуюСТроку - гламурнее...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

user1C
9 - 09.04.2009 - 19:38
(8)
ога, при нынешней производительности компов то))
только НоваяСтрока не умеет в минус работать...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
10 - 09.04.2009 - 20:12
2(0) Зачем понадобилось?
Что-то не припомню когда приходилось забивать пустые строки...

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
11 - 09.04.2009 - 20:15
+(10) Ну разве что слияние двух ТЗ...

Интересные темы

odines.ru
22.10.2020 - 17:20
Смотри также:
Подскажите конфигурация по управлению погрузками и доставками (под платформу 7.7)
Изменить границу последовательности БЕЗ проведения документов
Подскажите по последовательности в комплексной

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
12 - 09.04.2009 - 21:32
11-КонецЦикла > именно

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

КонецЦикла
13 - 09.04.2009 - 21:37
Ну дык кол-во строк конечно, в этом контексте ни разу не глючило

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

Чучундер
14 - 09.04.2009 - 22:35
13-КонецЦикла > да вот фиг его знает.. ;-)

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

reanimator
15 - 10.04.2009 - 03:36
В 7.7 не помню в каком релизе при работе с очень большими ТЗ создалось впечатление, что добавление строки в ТЗ внутри происходит следующим образом - создаётся новая ТЗ-2 на строку большая, чем предыдущая, после чего в неё переносятся все данные из ТЗ, память из под ТЗ освобождается, а указатель перенаправляется на ТЗ-2. Только этим могу объяснить жуткие тормоза при добавлении новой строки в ТЗ большого объёма, чем больше ТЗ, тем больше тормоза.

Re: ТЗ.КоличествоСтрок(СколькоНадо) vs ТЗраб.НоваяСтрока()

reanimator
16 - 10.04.2009 - 03:38
+(15) Сейчас задумался - а 1с ли это была?... Вроде она :)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« является ли отсутствие ключа защиты нарушением использования лицензионного ПО? Help: Не выводится логотип при печати счета-фактуры »
© 2009 Форум 1С: Одинэс.Ру