Сохранить открытый документ

Форум 1С: Одинэс.Ру

Найти!

Сохранить открытый документ

Anonymous
24.04.2009 - 23:26
Подскажите новичку, пожалуйста.
 
Есть необходимость сохранять вновь созданный и открытый, в течение дня, документ, через определенный промежуток времени. Я делаю в процедуре ВводНового():
Форма.ОбработкаОжидания("ЗаписатьДокумент", 600);
 
Процедура ЗаписатьДокумент();
    Записать();
КонецПроцедуры
 
Выскакивает ошибка "Данная команда не может выполняться в формуле элемента диалога". Как реализовать? Благодарю.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
05.12.2020 - 06:16
Смотри также:
Как программно сделать подчинение одного документа другому
Проблема с уникальностью номеров документов
Прямая запись справочников 1С MS SQL

Re: Сохранить открытый документ

jurii
24 - 27.04.2009 - 01:26
У меня Записать() работатет.
Правда не в обработке ожидания (зачем записывать? ведь документ не изменяется!), а в обработке подбора.
Собственно обработка подбора изменена так, что выбранный товар после запроса количества сразу попадает в накладную, а там:
 
    Если КоличествоСтрок() % 10 = 0 Тогда
        Записать();
    КонецЕсли;
 

Re: Сохранить открытый документ

pit
25 - 27.04.2009 - 04:28
24-jurii > Это (24) будет работать только для новых доков. Немного переделать и будет работать как надо....

Re: Сохранить открытый документ

jurii
26 - 27.04.2009 - 05:06
(25) Нифига!
Засомневался. Открыл в копии уже проведённый документ (даже не сегодняшний) : на 10-й строке записался и перепровёлся!

Re: Сохранить открытый документ

pit
27 - 27.04.2009 - 05:14
если корректируем данные в строках - общее количество строк в документе не меняется и
Если КоличествоСтрок() % 10 = 0 Тогда
        Записать();
    КонецЕсли;
 
срабатывать не будет
 
Значит, у тебя как то по другому записано....

Re: Сохранить открытый документ

drums2004
28 - 27.04.2009 - 05:26
Вот дисскуссию развели ...

Интересные темы

odines.ru
05.12.2020 - 06:16
Смотри также:
отсутствует интерфейс IInitDone.....
Простой Запрос
Обратный порядок периодов

Re: Сохранить открытый документ

Anonymous
29 - 27.04.2009 - 07:14
Документ нужно просто сохранять, без проведения, там ситуация такая, что есть магазин по торговле радиотоварами, они открывают один документ с утра и вносят туда в течение дня все продажи, и типа там винда постоянно слетает, то свет выключают (конечно бесперебойник решает эту проблему) и.т.п. Вообщем они в другом городе, попросили сделать, чтобы по заданному интервалу сохранялся документ в котором к концу дня ~ 5000 позиций.

Re: Сохранить открытый документ

USSR
30 - 27.04.2009 - 08:31
А создавать несколько документов не позволяет какая-то особая религия? Если уж и правда верующие, то сделайте волшебную кнопку, которая в конце дня сольет все документы в один. Любят в нашей стране все делать через ж...

Re: Сохранить открытый документ

pit
31 - 27.04.2009 - 08:35
5000 позиций... клево...
 
когда позиций станет больше 100-300 - при каждом сохранении комп будет впадать в ступор на время 3-10 минут....

Re: Сохранить открытый документ

VZ
32 - 27.04.2009 - 08:43
Учитывая, что движок для записи номеров строк расчитан на число не более 9999 ;)
А еще интересна будет реакция на перепроведение после "ой, я ошиблась в ..." ;)

Re: Сохранить открытый документ

Cthulhu
34 - 27.04.2009 - 19:27
вмемориз!
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Не формирется проводка Д 41,2 К 42. Как исправить? Комплексная, корректировка долга »
© 2009 Форум 1С: Одинэс.Ру