Выделить колонку цветом

Форум 1С: Одинэс.Ру

Найти!

Выделить колонку цветом

vombat
15.06.2009 - 10:24
Можно ли в 1С Предприятие 7.7 выделить цветом колонку?
Знаю что строки можно с помощью V7Plus.dll, а колонку можно?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
21.10.2020 - 15:56
Смотри также:
УСН релиз 160. Как списать товар в производство?
Запрос по Регистр.ОстаткиТМЦ
Отредактировать файл xml

Re: Выделить колонку цветом

vombat
1 - 15.06.2009 - 10:27
Уточнение: речь идет о колонке таблицы значений.

Re: Выделить колонку цветом

roma n
2 - 15.06.2009 - 10:30
V7Plus.dll
??? научи, а...
Может ты про FormEx?

Re: Выделить колонку цветом

USSR
3 - 15.06.2009 - 10:32
Formex и VTOOLS. я юзаю VTOOLS. В свое время формекс для этой цели не понравился, но надо вернуться, еще посмотреть

Re: Выделить колонку цветом

vombat
4 - 15.06.2009 - 10:38
2 roma n
Упс... Обшибся названием dll-ки...
Да, я про FormEx говорил.
 
2 USSR
Можно пример кода?

Re: Выделить колонку цветом

Кибер
5 - 15.06.2009 - 10:52
а в демке с FormEx нет что ли?

Интересные темы

odines.ru
21.10.2020 - 15:56
Смотри также:
1С через Интернет ...
Удаленное рабочее место кассира (v7.7 SQL)
AdoDb.Connection

Re: Выделить колонку цветом

vombat
6 - 15.06.2009 - 10:55
2 Кибер
Нету у меня демки.

Re: Выделить колонку цветом

USSR
7 - 15.06.2009 - 10:55
(4)Там много кода, начиная от инициализации таблицы и кончая ее заполнением и указанием цветов. Ищи методы VTOOLS.DLL

Re: Выделить колонку цветом

Sasha
8 - 15.06.2009 - 10:56
2(4)Колонка аналогично строке. Просто задаешь необходимые параметры
COUNT[<КоличествоКолонок>] - задает количество колонок, на которые распространяется раскраска;
INDENT[<Отступ>] - задает количество колонок, которое необходимо пропустить перед началом раскраски;

Re: Выделить колонку цветом

Reaper
9 - 15.06.2009 - 10:58
//********************************************************************************
 
Функция РаскраситьТаблицу()
 
Если ТаблицаТоваров.Остаток >= ТаблицаТоваров.Количество Тогда
//Возврат "BRUSH["+ПолучитьЦвет(145,215,145)+"]";     //зеленый
Возврат "FONT["+ПолучитьЦвет(75,105,65)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
ИначеЕсли (ТаблицаТоваров.Остаток < ТаблицаТоваров.Количество) И (ЗаказКолво >= ДопКолво) Тогда
//Возврат "BRUSH["+ПолучитьЦвет(215,215,145)+"]";     //желтый  
Возврат "FONT["+ПолучитьЦвет(180,170,65)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
Иначе  
//Возврат "BRUSH["+ПолучитьЦвет(255,100,100)+"]";     //красный ;
Возврат "FONT["+ПолучитьЦвет(255,100,100)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
КонецЕсли;
 

КонецФункции  

Re: Выделить колонку цветом

vombat
10 - 15.06.2009 - 11:04
2 Sasha и Reaper
 
Спасибо БОЛЬШОЕ. :-)

Re: Выделить колонку цветом

vombat
11 - 15.06.2009 - 11:05
2 USSR
 
Меня интересует только инициализация таблицы, цвета я в курсе как делаются и сервис как инициализируетсю тоже помню.

Re: Выделить колонку цветом

USSR
12 - 15.06.2009 - 11:33
// -----------------------------
Процедура ИнициализацияТаблицы()
 
ВыделениеЯчеек = 0;
Сбор           = 1;
Файл           = "VTools.dll";
 
ТЗ = СоздатьОбъект("ТаблицаЗначений");
 
Рез = ЗагрузитьВнешнююКомпоненту(Файл);
Если Рез = 1 Тогда  
ТЗЦ = СоздатьОбъект("AddIn.VTools");
ТЗЦ.Показать(Форма.Заголовок(),Форма.Цех.Заголовок(),"GRID");
ТЗЦ.АвтоРазмер(0,0);
ТЗЦ.УстановитьРедактирование(0);
ТЗЦ.ПриДвойномНажатииЛевойКнопки("ПриДвойномНажатииЛК()");
ТЗЦ.ПриНажатииПравойКнопки      ("ПриНажатииПК()");
ТЗЦ.ПриНачалеРедактирования     ("ВНачалеРедактированияЯчейки()");
ТЗЦ.ПриОкончанииРедактирования  ("ВОкончанииРедактированияЯчейки()");
ТЗЦ.ПриНажатииКлавиши           ("ПриНажатииЛюбойКлавиши()");
ТЗЦ.УстановитьСортировкуКолонок (0);
ТЗЦ.ВыделятьСтроку (0);
Иначе
Сообщить("Ошибка загрузки компоненты "+Файл);
Сообщить("Перепишите файл VTools.dll в каталог базы данных!");
СтатусВозврата(0);
Возврат;
КонецЕсли;
 
КонецПроцедуры //ИнициализацияТаблицы()
 

Re: Выделить колонку цветом

Чучундер
13 - 15.06.2009 - 11:49
предлагаю на каждую раскрашиваемую ячейку не вызывать пересчет цвета... нормально работает в хекс-нотации
BRUSH[0xDDCCFF]

Re: Выделить колонку цветом

vombat
14 - 15.06.2009 - 12:08
2 Чучундер
Можно просто использовать глобальную переменную, которой присваивается цвет.

Re: Выделить колонку цветом

Чучундер
15 - 15.06.2009 - 12:45
14-vombat > цвета - везде свои...

Re: Выделить колонку цветом

vombat
16 - 15.06.2009 - 15:08
2 Чучундер
Создать нужное число глобальных переменных для цветов.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« КО(Сумма) в черном запросе УСН и вмененка »
© 2009 Форум 1С: Одинэс.Ру