Выделить колонку цветом

Форум 1С: Одинэс.Ру

Найти!

Выделить колонку цветом

vombat
15.06.2009 - 10:24
Можно ли в 1С Предприятие 7.7 выделить цветом колонку?
Знаю что строки можно с помощью V7Plus.dll, а колонку можно?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
25.10.2020 - 13:59
Смотри также:
ОФФ: Кто-нибудь замечает нашествие агрессивных дятлов, клюющих 7.7 ?
реквизит типа "Документ"
XP Home и сервер защиты

Re: Выделить колонку цветом

USSR
7 - 15.06.2009 - 10:55
(4)Там много кода, начиная от инициализации таблицы и кончая ее заполнением и указанием цветов. Ищи методы VTOOLS.DLL

Re: Выделить колонку цветом

Sasha
8 - 15.06.2009 - 10:56
2(4)Колонка аналогично строке. Просто задаешь необходимые параметры
COUNT[<КоличествоКолонок>] - задает количество колонок, на которые распространяется раскраска;
INDENT[<Отступ>] - задает количество колонок, которое необходимо пропустить перед началом раскраски;

Re: Выделить колонку цветом

Reaper
9 - 15.06.2009 - 10:58
//********************************************************************************
 
Функция РаскраситьТаблицу()
 
Если ТаблицаТоваров.Остаток >= ТаблицаТоваров.Количество Тогда
//Возврат "BRUSH["+ПолучитьЦвет(145,215,145)+"]";     //зеленый
Возврат "FONT["+ПолучитьЦвет(75,105,65)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
ИначеЕсли (ТаблицаТоваров.Остаток < ТаблицаТоваров.Количество) И (ЗаказКолво >= ДопКолво) Тогда
//Возврат "BRUSH["+ПолучитьЦвет(215,215,145)+"]";     //желтый  
Возврат "FONT["+ПолучитьЦвет(180,170,65)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
Иначе  
//Возврат "BRUSH["+ПолучитьЦвет(255,100,100)+"]";     //красный ;
Возврат "FONT["+ПолучитьЦвет(255,100,100)+"]; FONTSET["+Сервис.СоздатьШрифт(,,9)+"]";
КонецЕсли;
 

КонецФункции  

Re: Выделить колонку цветом

vombat
10 - 15.06.2009 - 11:04
2 Sasha и Reaper
 
Спасибо БОЛЬШОЕ. :-)

Re: Выделить колонку цветом

vombat
11 - 15.06.2009 - 11:05
2 USSR
 
Меня интересует только инициализация таблицы, цвета я в курсе как делаются и сервис как инициализируетсю тоже помню.

Интересные темы

odines.ru
25.10.2020 - 13:59
Смотри также:
Количество записей в справочнике
Как убрать картинку 1С при загрузке? (+)
Помогите уже день играюсь с регистрами!!!

Re: Выделить колонку цветом

USSR
12 - 15.06.2009 - 11:33
// -----------------------------
Процедура ИнициализацияТаблицы()
 
ВыделениеЯчеек = 0;
Сбор           = 1;
Файл           = "VTools.dll";
 
ТЗ = СоздатьОбъект("ТаблицаЗначений");
 
Рез = ЗагрузитьВнешнююКомпоненту(Файл);
Если Рез = 1 Тогда  
ТЗЦ = СоздатьОбъект("AddIn.VTools");
ТЗЦ.Показать(Форма.Заголовок(),Форма.Цех.Заголовок(),"GRID");
ТЗЦ.АвтоРазмер(0,0);
ТЗЦ.УстановитьРедактирование(0);
ТЗЦ.ПриДвойномНажатииЛевойКнопки("ПриДвойномНажатииЛК()");
ТЗЦ.ПриНажатииПравойКнопки      ("ПриНажатииПК()");
ТЗЦ.ПриНачалеРедактирования     ("ВНачалеРедактированияЯчейки()");
ТЗЦ.ПриОкончанииРедактирования  ("ВОкончанииРедактированияЯчейки()");
ТЗЦ.ПриНажатииКлавиши           ("ПриНажатииЛюбойКлавиши()");
ТЗЦ.УстановитьСортировкуКолонок (0);
ТЗЦ.ВыделятьСтроку (0);
Иначе
Сообщить("Ошибка загрузки компоненты "+Файл);
Сообщить("Перепишите файл VTools.dll в каталог базы данных!");
СтатусВозврата(0);
Возврат;
КонецЕсли;
 
КонецПроцедуры //ИнициализацияТаблицы()
 

Re: Выделить колонку цветом

Чучундер
13 - 15.06.2009 - 11:49
предлагаю на каждую раскрашиваемую ячейку не вызывать пересчет цвета... нормально работает в хекс-нотации
BRUSH[0xDDCCFF]

Re: Выделить колонку цветом

vombat
14 - 15.06.2009 - 12:08
2 Чучундер
Можно просто использовать глобальную переменную, которой присваивается цвет.

Re: Выделить колонку цветом

Чучундер
15 - 15.06.2009 - 12:45
14-vombat > цвета - везде свои...

Re: Выделить колонку цветом

vombat
16 - 15.06.2009 - 15:08
2 Чучундер
Создать нужное число глобальных переменных для цветов.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« КО(Сумма) в черном запросе УСН и вмененка »
© 2009 Форум 1С: Одинэс.Ру