В одной базе разный результат одного кода на разных движках 25 и 27

Форум 1С: Одинэс.Ру

Найти!

В одной базе разный результат одного кода на разных движках 25 и 27

lww
16.07.2009 - 08:53
Доброго времени суток, уважаемые!
Выполняю в одной и той же базе одну и туже обработку под разными движками 25 и 27, результат такой:
- в 25 движке получаю туже сумму что и в ОСВ по счету
- в 27 движке получаю 0
 
Процедура ПриОткрытии()
НачДата = '01.06.2009';
КонДата = КонМесяца(НачДата);
КонецПроцедуры
 
Процедура Сформировать()
ОчиститьОкноСообщений();
СЗ = СоздатьОбъект("СписокЗначений");
Спр = СоздатьОбъект("Справочник.Подразделения");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.Административное = 1 Тогда
СЗ.ДобавитьЗначение(Спр.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто("Подразделения", СЗ, 2,);
БИ.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("26"),,, 1,, 1);
Сообщить(БИ.СКД());
КонецПроцедуры
 
Проверял это же для одного элемента, а не списка значений, все равно тоже самое. Список значений не пуст. Дело в том что у меня локально стоит 25 движок, а юзеры работают с административной установки 27 движка. Это как-то лечится?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
24.10.2020 - 09:31
Смотри также:
3 D графика в 1С
В какой конфигурации можно вести упр и фиск учет?
Падает 1С при открытии обработки загрузки/выгрузки проводок

Re: В одной базе разный результат одного кода на разных движках 25 и 27

Uho
1 - 16.07.2009 - 09:12
ну во-первых
<ВидСубконто> - значение типа ''ВидСубконто'' - расчет временных итогов будет выполнен только для субконто указанного вида.
во-вторых
2 - отбирать по данному субконто

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
2 - 16.07.2009 - 09:16
не понял ответа... я как раз и добивался того, чтобы получить конечное дебетовое сальдо по указанному списку подразделений, но почему при этом под разными движками такие разные результаты???

Re: В одной базе разный результат одного кода на разных движках 25 и 27

Uho
3 - 16.07.2009 - 09:33
потому что криво написанный код не обязан работать одинаково

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
4 - 16.07.2009 - 09:36
напиши прямо, задача: получить конечное дебетовое сальдо по 26 счету для административных подразделений, подразделения второе субконто счета 26.

Re: В одной базе разный результат одного кода на разных движках 25 и 27

Uho
5 - 16.07.2009 - 10:01
еще раз:
<ВидСубконто> - значение типа ''ВидСубконто'' - расчет временных итогов будет выполнен только для субконто указанного вида.
<Субконто> - значение Субконто, по которому будут отобраны итоги по аналитике. Если параметр не задан - то считается пустым значением субконто.
<ТипФильтра> - число - тип фильтра по субконто. Может принимать следующие значения: 1 - разворачивать по данному субконто, 2 - отбирать по данному субконто, 3 - не учитывать это субконто вообще. По умолчанию 1.
 
(с) СП

Интересные темы

odines.ru
24.10.2020 - 09:31
Смотри также:
Бюджетка. 631 релиз - при обновлении ошибка...
ПУБ интересная ситуация (про вилки)
Пропали документы

Re: В одной базе разный результат одного кода на разных движках 25 и 27

pit
6 - 16.07.2009 - 10:06
Пишу прямо после оглашения суммы "На руки"

Re: В одной базе разный результат одного кода на разных движках 25 и 27

Хоменко Валерий
7 - 16.07.2009 - 10:11
Релиз 7.70.027 от 18.12.2006 г.
Новое в релизе:
• Исправлена ошибка работы объекта БухгалтерскиеИтоги в клиент-серверной версии системы 1С:Предприятие.

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
8 - 16.07.2009 - 10:19
(5) не доходит... ну переписал вот так
Процедура Сформировать()
ОчиститьОкноСообщений();
Спр = СоздатьОбъект("Справочник.Подразделения");
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
Если Спр.НайтиПоКоду("0000000001") = 1 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.Подразделения, Спр.ТекущийЭлемент(), 2);
КонецЕсли;
БИ.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("26"),,, 1,, 1);
Сообщить(БИ.СКД());
КонецПроцедуры
а результат тотже:
- в 25 движке некая сумма как и в ОСВ по счету 26
- в 27 движке 0

Re: В одной базе разный результат одного кода на разных движках 25 и 27

pit
9 - 16.07.2009 - 10:24
(8)
Драстуй, дятел...
Драстуй, птица...
На сосне что не сидится?....
 

ваще то БИ.СКД() по 26 щету всегда равно нулю... В типовых...

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
10 - 16.07.2009 - 10:29
(9) это только вроде после закрытия месяца, код из документа закрытия месяца типовой конфы, в которой работаем:
 
БИ26 = СоздатьОбъект("БухгалтерскиеИтоги");
БИ26.ОсновныеИтоги();
БИ26.ПериодД(ДатаНач, ДатаКон);
СуммаОХ = БИ26.СКД(Сч26);
 
полученная сумма закрывается на 90.8.1
это для туканов...

Re: В одной базе разный результат одного кода на разных движках 25 и 27

roma n
11 - 16.07.2009 - 10:35
(10) "код из документа закрытия месяца типовой конфы" - постеснялся бы... или релиз назови.
В типовых оба субконто 26 - оборотные

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
12 - 16.07.2009 - 10:38
ПУБ релиз 310, процедура РаспределениеСчета26_ДиректКостинг

Re: В одной базе разный результат одного кода на разных движках 25 и 27

Uho
13 - 16.07.2009 - 10:48
(10) дык это по счету в целом...

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
14 - 16.07.2009 - 10:49
едиственное на основании (7) - исправлена ошибка работы с БИ и (10) - оба субконто по 26 обротные, могу предположить, что 25 по ошибке получает СКД, а 27 уже не может и всегда дает 0

Re: В одной базе разный результат одного кода на разных движках 25 и 27

lww
15 - 16.07.2009 - 10:51
(14) + имеется ввиду в разрезе субконто
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Как из 1С заполнить поле <МЕМО> в файле DBF ? Как перебрать табличную часть подченённого подчинённому справочнику справочника »
© 2009 Форум 1С: Одинэс.Ру