Нет возможности разместить документ после ТА

Форум 1С: Одинэс.Ру

Найти!

Нет возможности разместить документ после ТА

Dimon1C
02.07.2009 - 02:49
После некоторого периода времени так получилось что у текущего документа установилось время 23:59:59. И после этого на проведение документов 1С (ТиС, комплексная) ругается "Нет возможности разместить документ после ТА".
Вопрос 1: Как этого избежать, чтоб время не доходило до 23.59.59?
Вопрос 2: Как это исправить? Попытался исправить время (сделал документ непроведенным, изменил время). Но все равно ПолучитьТА() = "..... 23:59:59", и соответственно не дает проводить документы.
Самое главное условие: это нет возможности зайти в базу монопольно.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
29.10.2020 - 19:29
Смотри также:
Как на ваш взгляд лучше "подвязать" дополнительную инфу в документ?
является ли отсутствие ключа защиты нарушением использования лицензионного ПО?
Присвоить перечисление :(

Re: Нет возможности разместить документ после ТА

Чучундер
1 - 02.07.2009 - 04:57
0. "так получилось" - САМО?
1. работать и проводть документы текущим временем, а не выеживаться, помещая доки в 23-59
2. Меню-сервис-параметры-оперативный учет

Re: Нет возможности разместить документ после ТА

Dimon1C
2 - 02.07.2009 - 06:45
(1)
Уверяю 100% получилось САМО!
Никто нарочно не помещал документы в 23-59, накопилось время, т.к. вводили документы на завтра (не проведенные).
Например, вот такой сценарий. Вечером вводятся ПКО датой следующего дня, не проводятся. На след. день отправная точка времени уже вечер, и так как документов много,то наступает момент когда наступить секунда Ч.
2. Меню-сервис-параметры-оперативный учет
Что там менять? Пробывал, ноль эффекта.

Re: Нет возможности разместить документ после ТА

Cthulhu
3 - 02.07.2009 - 06:54
уверения не убедительны..
но - поделитесь все-таки эзотерическими знаниями: как вы лделаете чтобы у вас "копилось время" и где в 1с-ине хранится и как используется "всемя Ч" ?!..

Re: Нет возможности разместить документ после ТА

Dimon1C
4 - 02.07.2009 - 07:10
(3) Объясняю подробнее. Вот сегодня вечером кладовщик выписал ПКО на завтра. Время документа стало текущее, допустим 18-00.
Завтра с утра пришел кладовщик, провел этот ПКО и ТА стало 18-00 и начал вводить документы, у которых уже время устанавливает после 18-00. В этот день вечером снова сделал ПКО на завтра, а время уже не текущее (т.к. ТА ушла вперед) (допустим 20-00). На след. день уже документы выписываются со временем более 20-00. И т.д. И в один день наступает "время Ч", когда ТА=23-59

Re: Нет возможности разместить документ после ТА

31337
5 - 02.07.2009 - 07:21
Dimon1C - скажи чтоб набивали время документов будущих не текущее, а начало дня (например 09:00) и всё.  Тоесть, если кто делает документ "на завтра" пусть при записи указывает не текущее время, а выбирает конкретно 09:00 например

Интересные темы

odines.ru
29.10.2020 - 19:29
Смотри также:
Можно ли в УСН вести индивдуального предпринимателя?
Восстановление базы SQL
КомпонентаСХК.Инициализация().Ошибка создания файла.

Re: Нет возможности разместить документ после ТА

USSR
6 - 02.07.2009 - 07:23
Кладовщик выписывает ПКО на завтра. Супер

Re: Нет возможности разместить документ после ТА

drums2004
7 - 02.07.2009 - 08:31
Тут тема была ... как разместить док между 23:59:59 и 0:00:00

Re: Нет возможности разместить документ после ТА

Musett
8 - 02.07.2009 - 09:17
1. При проведении сегодня вчерашних документов ставить им ТЕКУЩЕЕ СЕГОДНЯШНЕЕ время (пользователи должны быть аккуратными). Либо в начале дня обработкой менять время у непроведенных документов.
2. В немонопольном режиме сдвинуть ТА штатно нельзя. Алгоритм действий: все проведенные будущим временем документы распроводишь, в монопольном режиме ставишь ТА на последний проведенный документ с правильным текущим временем, дальше при проведении документов ставишь им текущее время.

Re: Нет возможности разместить документ после ТА

Uho
9 - 02.07.2009 - 09:36
(6) +1000
(8) В немонопольном режиме сдвинуть ТА штатно нельзя
уверен?

Re: Нет возможности разместить документ после ТА

Musett
10 - 02.07.2009 - 09:39
9-Uho >Имеется в виду - сдвинуть назад нельзя.

Re: Нет возможности разместить документ после ТА

Uho
11 - 02.07.2009 - 09:48
10-Musett > а я могу

Re: Нет возможности разместить документ после ТА

Musett
12 - 02.07.2009 - 09:50
11-Uho >Ну поделись с людьми!

Re: Нет возможности разместить документ после ТА

Cthulhu
13 - 02.07.2009 - 10:12
(12): тыкай правой кнопкой на любой задний документ и читай по слогам пункты контекстного меню.. например...

Re: Нет возможности разместить документ после ТА

Musett
14 - 02.07.2009 - 10:14
13-Cthulhu >Промазал - в немонопольном (разделенном) режиме пункт "Установить ТА на документ" недоступен.

Re: Нет возможности разместить документ после ТА

Dimon1C
15 - 02.07.2009 - 10:15
(13) Ты сам то тыкал?
 
На обсуждение, решают ли такие изменения в конфе данную проблему:
Функция глМожноЗаписатьДокумент(Конт) Экспорт
          
 
Если Конт.ДатаДок<=Константа.ДатаЗапретаРедактирования Тогда
Предупреждение("Нельзя записывать документы с датой, более ранней чем дата запрета редактирования документов!", 60);
Возврат 0;
КонецЕсли;  
                                    
// {{ -- Будущие документы пихаем в начало дня
Если Конт.ДатаДок > ПолучитьДатуТА() Тогда
Конт.АвтоВремяНачалоДня();
КонецЕсли;
// }}
 
Возврат 1;
КонецФункции // глМожноЗаписатьДокумент()

Re: Нет возможности разместить документ после ТА

Uho
16 - 02.07.2009 - 10:31
(12) перечитал тему, понял, что я вообще не в теме 8)

Re: Нет возможности разместить документ после ТА

Musett
17 - 02.07.2009 - 11:10
15-Dimon1C >Только теперь документы будут стремиться не к концу, а к началу дня, а когда его (начало) достигнут, то опять будут записываться текущим временем и ситуация сведется к предыдущей. Еще и в обратном порядке будут в журнале. Хотя, если оценить вероятности - может быть, вас это устроит.

Re: Нет возможности разместить документ после ТА

Dimon1C
18 - 02.07.2009 - 11:28
(17) Впринципе на утро оставляют до 20-50 документов. Думаю влезут в начало дня.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Активизировать строку в табличной части формы документа не показывает СНД по сумме »
© 2009 Форум 1С: Одинэс.Ру