Нет возможности разместить документ после ТА

Форум 1С: Одинэс.Ру

Найти!

Нет возможности разместить документ после ТА

Dimon1C
02.07.2009 - 02:49
После некоторого периода времени так получилось что у текущего документа установилось время 23:59:59. И после этого на проведение документов 1С (ТиС, комплексная) ругается "Нет возможности разместить документ после ТА".
Вопрос 1: Как этого избежать, чтоб время не доходило до 23.59.59?
Вопрос 2: Как это исправить? Попытался исправить время (сделал документ непроведенным, изменил время). Но все равно ПолучитьТА() = "..... 23:59:59", и соответственно не дает проводить документы.
Самое главное условие: это нет возможности зайти в базу монопольно.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
05.12.2020 - 05:22
Смотри также:
"Объект ещё не загружен толком..."
Сделать фотографию из 7.7
ТиС 949. Отчёт по продажам ТМЦ. 100 % прибыль при списании ?!

Re: Нет возможности разместить документ после ТА

Uho
9 - 02.07.2009 - 09:36
(6) +1000
(8) В немонопольном режиме сдвинуть ТА штатно нельзя
уверен?

Re: Нет возможности разместить документ после ТА

Musett
10 - 02.07.2009 - 09:39
9-Uho >Имеется в виду - сдвинуть назад нельзя.

Re: Нет возможности разместить документ после ТА

Uho
11 - 02.07.2009 - 09:48
10-Musett > а я могу

Re: Нет возможности разместить документ после ТА

Musett
12 - 02.07.2009 - 09:50
11-Uho >Ну поделись с людьми!

Re: Нет возможности разместить документ после ТА

Cthulhu
13 - 02.07.2009 - 10:12
(12): тыкай правой кнопкой на любой задний документ и читай по слогам пункты контекстного меню.. например...

Интересные темы

odines.ru
05.12.2020 - 05:22
Смотри также:
Удаленное рабочее место кассира (v7.7 SQL)
Налог на прибыль - КПП выводится только на титульном листе
Багофича (?) ОбработкаВнешнегоСобытия()

Re: Нет возможности разместить документ после ТА

Musett
14 - 02.07.2009 - 10:14
13-Cthulhu >Промазал - в немонопольном (разделенном) режиме пункт "Установить ТА на документ" недоступен.

Re: Нет возможности разместить документ после ТА

Dimon1C
15 - 02.07.2009 - 10:15
(13) Ты сам то тыкал?
 
На обсуждение, решают ли такие изменения в конфе данную проблему:
Функция глМожноЗаписатьДокумент(Конт) Экспорт
          
 
Если Конт.ДатаДок<=Константа.ДатаЗапретаРедактирования Тогда
Предупреждение("Нельзя записывать документы с датой, более ранней чем дата запрета редактирования документов!", 60);
Возврат 0;
КонецЕсли;  
                                    
// {{ -- Будущие документы пихаем в начало дня
Если Конт.ДатаДок > ПолучитьДатуТА() Тогда
Конт.АвтоВремяНачалоДня();
КонецЕсли;
// }}
 
Возврат 1;
КонецФункции // глМожноЗаписатьДокумент()

Re: Нет возможности разместить документ после ТА

Uho
16 - 02.07.2009 - 10:31
(12) перечитал тему, понял, что я вообще не в теме 8)

Re: Нет возможности разместить документ после ТА

Musett
17 - 02.07.2009 - 11:10
15-Dimon1C >Только теперь документы будут стремиться не к концу, а к началу дня, а когда его (начало) достигнут, то опять будут записываться текущим временем и ситуация сведется к предыдущей. Еще и в обратном порядке будут в журнале. Хотя, если оценить вероятности - может быть, вас это устроит.

Re: Нет возможности разместить документ после ТА

Dimon1C
18 - 02.07.2009 - 11:28
(17) Впринципе на утро оставляют до 20-50 документов. Думаю влезут в начало дня.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Активизировать строку в табличной части формы документа не показывает СНД по сумме »
© 2009 Форум 1С: Одинэс.Ру