Обратный порядок периодов

Форум 1С: Одинэс.Ру

Найти!

Обратный порядок периодов

Мисти
25.06.2009 - 12:52
Забыла волшебное слово в 7 - как сделать, чтобы бухгалтерские итоги по периодам выдавались, начиная с последнего? Вроде видела такую штуку!
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
27.09.2021 - 09:06
Смотри также:
Ошибка после обновления базы с 158 на 159
Вопрос по объекту Форма.
Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Re: Обратный порядок периодов

Мисти
1 - 25.06.2009 - 13:23
Скажите мне. это возможно, или я что-то перепутала?

Re: Обратный порядок периодов

pit
2 - 25.06.2009 - 13:58
Кота не погладила... Слова не будет...

Re: Обратный порядок периодов

Мисти
3 - 25.06.2009 - 14:27
Бог с ним с обратным порядком!
Почему у меня сумма себестоимости - не нулевая, а количество - 0? БухИтСебест=СоздатьОбъект("БухгалтерскиеИтоги"); БухИтСебест.ИспользоватьСубконто(ВидыСубконто.Номенклатура,ДокОсн.Товар);
БухИтСебест.Опции(0,1); БухИтСебест.ВыполнитьЗапрос('01.01.2009',ДокОсн.ДатаДок,"41.1",,,,"Месяц",5);
БухИтСебест.ВыбратьПериоды();
КолСебест=0;
СуммаСебест=0;
Пока БухИтСебест.ПолучитьПериод()=1 Цикл
Если БухИтСебест.КО("С")=0 Тогда
Продолжить;
КонецЕсли;    КолСебест=БухИтСебест.КО("К"); СуммаСебест=БухИтСебест.КО("С"); КонецЦикла;

Re: Обратный порядок периодов

Reaper
4 - 25.06.2009 - 14:30
3-Мисти > Потому что количество было списано все, но с неверной стоимостью...

Re: Обратный порядок периодов

pit
5 - 25.06.2009 - 14:43
Почему у меня сумма себестоимости - не нулевая, а количество - 0
Потому что количество было списано все, но с неверной стоимостью...
найди последнее списание и перепроведи... станет по нулям...

Интересные темы

odines.ru
27.09.2021 - 09:06
Смотри также:
631 бюджет: как учитывать БО по новой инструкции?
XP Home и сервер защиты
Подскажите, плиз, код или ВК, который(ая) фиксирует время простоя 1С-ины и запускает определенную обработку

Re: Обратный порядок периодов

Reaper
6 - 25.06.2009 - 14:45
+ (5) ежели списание типовое...

Re: Обратный порядок периодов

Мисти
7 - 25.06.2009 - 15:19
5-pit > Не, на я же вижу проводки! Там есть и количество и сумма!
Это ж обороты!

Re: Обратный порядок периодов

pit
8 - 25.06.2009 - 15:57
ну pit тупой, ну тупой.....
 
БухИтСебест=СоздатьОбъект("БухгалтерскиеИтоги");
БухИтСебест.ИспользоватьСубконто(ВидыСубконто.Номенклатура,ДокОсн.Товар);
БухИтСебест.Опции(0,1);
БухИтСебест.ВыполнитьЗапрос('01.01.2009',ДокОсн.ДатаДок,"41.1",,,,"Месяц",5);
БухИтСебест.ВыбратьПериоды();
КолСебест=0;
СуммаСебест=0;
Пока БухИтСебест.ПолучитьПериод()=1 Цикл
Если БухИтСебест.КО("С")=0 Тогда Продолжить; КонецЕсли;
КолСебест=БухИтСебест.КО("К");
СуммаСебест=БухИтСебест.КО("С");
КонецЦикла;
 
а субконто дяденька выбирать будет?

Re: Обратный порядок периодов

Мисти
9 - 26.06.2009 - 09:29
8-pit > А чего его выбирать, оно одно!
БухИтСебест.ИспользоватьСубконто(ВидыСубконто.Номенклатура,ДокОсн.Товар);
И потом - по сумме-то есть!

Re: Обратный порядок периодов

pit
10 - 26.06.2009 - 09:33
положено выбрать... значит, выбирай...

Re: Обратный порядок периодов

Мисти
11 - 26.06.2009 - 10:03
10-pit >Вах! Получилось! Расскажи, в чем прикол? А я никогда - если субконто и так выбрано в запросе - больше его не выбираю!

Re: Обратный порядок периодов

Uho
12 - 26.06.2009 - 10:16
11-Мисти >
 
а так?
БухИтСебест.ИспользоватьСубконто(ВидыСубконто.Номенклатура,ДокОсн.Товар,2);

Re: Обратный порядок периодов

Мисти
13 - 26.06.2009 - 10:18
12-Uho > Ну, я больше не буду пробовать. Там же вроде по умолчанию - если уже вставлено субконто, то - 2. И потом - сумма-то была!! Вот что удивляет! Не было только количества!

Re: Обратный порядок периодов

Uho
14 - 26.06.2009 - 10:24
13-Мисти > по умолчанию 1
К списку тем 1 > К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Бюджетка. 631 релиз - при обновлении ошибка... Недостаточно памяти »
© 2009 Форум 1С: Одинэс.Ру