ПУБ 298 Проблема с вводом нормативов

Форум 1С: Одинэс.Ру

Найти!

ПУБ 298 Проблема с вводом нормативов

Lvrn
29.01.2009 - 09:05
Нужна помощь специалиста. Я ковыряюсь уже неделю и не могу понять в чем дело.
При вводе нормативов при вводе нового элемента расхода в справочник нормативы расходов не записываются норма расхода и количество продукции.
Приходится после ввода нового элемента входить в него еще раз и править эти два периодических параметра.
В справочнике НормыРасходов запись новых периодических параметров проходит через глобальный модуль в процедуре ПриЗаписи() строкой
   Если глБухЗаписьПериодическихРеквизитов(Контекст) = 0 Тогда
Глобальный модуль отслеживает появление новых периодических реквизитов элемента справочника через
СтрСписок = Конт.СохранениеПериодическихРеквизитов(5);
Такое впечатление, что по умолчанию норма и количество продукции равны единице, т.к. если ввести в эти поля другие значения (хотя бы ноль), при записи элемента ПУБ предложит их сохранить. Но если в полях стоят единицы, то при сохранении элемента периодические реквизиты норма и количество продукции не будут предложены к сохранению. А при следующем открытии элемента в этих полях будут стоять нули :(
Я могу заставить справочник писать эти два элемента принудительно, но смысл в периодические реквизиты прописывать не изменяющийся элемент, а пользователь наверняка забудет снять галочку :D
Похоже дело в программном коде.
Ну так кто может помочь?
p.s. при вводе первого элемента в справочник таких проблем нет. Все начинается со второго...
К списку тем 1 > К списку форумов

Re: ПУБ 298 Проблема с вводом нормативов

МаriP
2 - 29.01.2009 - 17:02
посмотри историю

Re: ПУБ 298 Проблема с вводом нормативов

6AT9l
3 - 29.01.2009 - 17:07
А почему не используете документ "Спецификация"?

Re: ПУБ 298 Проблема с вводом нормативов

Ctrl P
4 - 29.01.2009 - 20:20
была такая проблемма тоже, но очень давно, посмотри хорошо отладчиком, там если разобраться видно, что есть ошибка... и ее надо править руками...

Re: ПУБ 298 Проблема с вводом нормативов

Lvrn
5 - 04.02.2009 - 07:47
(3) спецификацию пытались использовать, но не понятно что она дает. Те же нормативы как и в отдельном изделии, да еще и цену другую поставить нельзя.
 
Выложил видео в подтверждение webfile.ru/2609672
Сегодня обновил движок с 025 на 027 - не помогло.

Re: ПУБ 298 Проблема с вводом нормативов

Ctrl P
6 - 04.02.2009 - 08:24
Покажи сюда функцию в ГМ - глБухЗаписьПериодическихРеквизитов(Конт)...

Re: ПУБ 298 Проблема с вводом нормативов

Ctrl P
7 - 04.02.2009 - 08:39
Ôóíêöèÿ ãëÁóõÇàïèñüÏåðèîäè÷åñêèõÐåêâèçèòîâ(Êîíò) Ýêñïîðò
 
// Îáðàáîòêå ÇàïèñüÏåðèîäè÷åñêèõÐåêâèçèòîâ íåîáõîäèìî ïåðåäàòü
// çíà÷åíèÿ ïåðèîäè÷åñêèõ ðåêâèçèòîâ, ââåäåííûå â ôîðìå äèàëîãà.
Ñïèñîê = ÑîçäàòüÎáúåêò("ÑïèñîêÇíà÷åíèé");
ÏóñòîéÑïèñîê = ÑîçäàòüÎáúåêò("ÑïèñîêÇíà÷åíèé");
 
ÑòðÑïèñîê = Êîíò.ÑîõðàíåíèåÏåðèîäè÷åñêèõÐåêâèçèòîâ(5);
Êîíò.ÑîõðàíåíèåÏåðèîäè÷åñêèõÐåêâèçèòîâ(5, ÏóñòîéÑïèñîê);
Ñïèñîê.ÈçÑòðîêèÑÐàçäåëèòåëÿìè("""" + ÑòðÇàìåíèòü(ÑòðÑïèñîê, ",", """,""") + """");
//Ctrl F4 ÷¸ òî ãëþ÷èëî ïðè çàïèñè íîâîé íîðìû ïðèøëîñü äîáàâèòü 23.11.2005
Åñëè (Íàéòè(ÑòðÑïèñîê, "Íîðìà") = 0) è (êîíò.Âèä() = "ÍîðìûÐàñõîäîâ") Òîãäà
ÑòðÑïèñîê = ÑòðÑïèñîê + " ,Íîðìà";
ÑÏèñîê.ÄîáàâèòüÇíà÷åíèå("Íîðìà");
ÊîíåöÅñëè;
 
\ Åñëè  (Íàéòè(ÑòðÑïèñîê, "ÊîëÏðîä") = 0) è (êîíò.Âèä() = "ÍîðìûÐàñõîäîâ") Òîãäà
ÑòðÑïèñîê = ÑòðÑïèñîê + " ,ÊîëÏðîä";
ÑÏèñîê.ÄîáàâèòüÇíà÷åíèå("ÊîëÏðîä");
ÊîíåöÅñëè;
 
//Ctrl F4  - 23.11.2005
 

Re: ПУБ 298 Проблема с вводом нормативов

Ctrl P
8 - 04.02.2009 - 08:40
7 - ой а что это?

Re: ПУБ 298 Проблема с вводом нормативов

PIP
9 - 04.02.2009 - 09:14
Вот функция из нашего глобальника, №284, не обновлялась, в связи с сильными доработками:
 
//******************************************************************************
// глБухЗаписьПериодическихРеквизитов(Конт)
//
Функция глБухЗаписьПериодическихРеквизитов(Конт) Экспорт
 
// Обработке ЗаписьПериодическихРеквизитов необходимо передать
// значения периодических реквизитов, введенные в форме диалога.
Список = СоздатьОбъект("СписокЗначений");
ПустойСписок = СоздатьОбъект("СписокЗначений");
 
СтрСписок = Конт.СохранениеПериодическихРеквизитов(5);
Конт.СохранениеПериодическихРеквизитов(5, ПустойСписок);
// Мои изменения если новый - все реквизиты
Если (Конт.Вид() = "НормыРасходов") И (Конт.выбран() = 0) Тогда
Список.ИзСтрокиСРазделителями("""" + СтрЗаменить("Норма,КолПрод,Стоимость", ",", """,""") + """");
Иначе
Список.ИзСтрокиСРазделителями("""" + СтрЗаменить(СтрСписок, ",", """,""") + """");
КонецЕсли;
 
Если ПустоеЗначение(Список.ПолучитьЗначение(1)) = 0 Тогда
Для а = 1 по Список.РазмерСписка() Цикл
Реквизит = Список.ПолучитьЗначение(а);
Список.УстановитьЗначение(а, Конт.ПолучитьАтрибут(Реквизит), Реквизит);
КонецЦикла;
// При записи вызывается обработка ЗаписьПериодическихРеквизитов
// для управления записью значений периодических реквизитов.
СвязанныеРеквизиты = ?(ПустоеЗначение(Список.Получить("СчетЗатрат")) = 1, 0, 1);
Возврат глЗаписьПериодическихРеквизитов(Конт, Список,,, СвязанныеРеквизиты);
 
Иначе
Возврат 1;
КонецЕсли;
 
КонецФункции // глБухЗаписьПериодическихРеквизитов()
 

есть комментарий
// Мои изменения если новый - все реквизиты
 
уже не помню, возможно вносил, давно уже было

Re: ПУБ 298 Проблема с вводом нормативов

Lvrn
10 - 04.02.2009 - 10:32
(9) Большое СПАСИБО!
Именно эти строки:
Если (Конт.Вид() = "НормыРасходов") И (Конт.выбран() = 0) Тогда
Список.ИзСтрокиСРазделителями("""" + СтрЗаменить("Норма,КолПрод,Стоимость", ",", """,""") + """");
Иначе
Список.ИзСтрокиСРазделителями("""" + СтрЗаменить(СтрСписок, ",", """,""") + """");
КонецЕсли;
то что нужно. Помогло!
Не зря ж все-таки существует данный форум! :D

Re: ПУБ 298 Проблема с вводом нормативов

Ctrl P
11 - 04.02.2009 - 12:54
в 7 было почти тоже самое... только там через добавитьзначение()... :)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»