Открыть форму элемента справочника модально

Форум 1С: Одинэс.Ру

Найти!

Открыть форму элемента справочника модально

Sasha
04.07.2009 - 17:17
Имеем список справочника. Хотим - при двойном щелчке на элементе открывать форму элемента модально. Что пытались:
Процедура ПриНачалеРедактированияСтроки()
ОткрытьФормуМодально(ТекущийЭлемент());
СтатусВозврата(0);
КонецПроцедуры
не взлетает. Подменять список таблицей значений, а дерево имитировать 1С++ оставляю на крайний случай. Может есть решение?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 20:10
Смотри также:
нужна информация по 1C + AD
Как сделать документ который будет вызываться сочетанием клавишь
Помогите. Вопрос про УРБД - долгий простой

Re: Открыть форму элемента справочника модально

Sasha
3 - 04.07.2009 - 17:27
(1) Попробовал, результат аналогичный :(
Причем форма отчета/обработки в данном случае открывается нормально. Пробовал финт ушами
Процедура ПриВыбореСтроки()
ОткрытьФорму("Обработка.ОткрытиеЭлемента",ТекущийЭлемент());
КонецПроцедуры
в обработке
Процедура ПриОткрытии()
ОткрытьФормуМодально(Форма.Параметр);
КонецПроцедуры
Тоже не взлетает.
 

Re: Открыть форму элемента справочника модально

Sasha
4 - 04.07.2009 - 17:30
2(2)По всякому пробовал. На форум обращаюс за помощью в крайнем случае))

Re: Открыть форму элемента справочника модально

Sasha
5 - 04.07.2009 - 18:01
Процедура ПриВыбореСтроки()  
тЭлемент = ТекущийЭлемент();
 
Если тЭлемент.Выбран() = 1 Тогда
нач = _GetPerformanceCounter();
Сообщить("Начало выбора...");
ОткрытьФормуМодально(тЭлемент,,0);  
кон = _GetPerformanceCounter();
Сообщить("Конец выбора..."+ОКР((кон-нач)/1000,3));
КонецЕсли;
 
КонецПроцедуры
-------------------------
окно сообщений:
Начало выбора...
Конец выбора...0.002

Re: Открыть форму элемента справочника модально

Sasha
6 - 04.07.2009 - 18:18
Текущий справочник "Контрагенты"
ОткрытьФормуМодально("Элемент.Номенклатура") - работает
ОткрытьФормуМодально("Элемент.Контрагенты") - не работает

Re: Открыть форму элемента справочника модально

Reaper
7 - 04.07.2009 - 18:29
6-Sasha > не работает - ни о чем не говорит. Если не ругается - скажи хотя бы что делает...

Интересные темы

odines.ru
22.10.2020 - 20:10
Смотри также:
Оптимизация кода работы с СЕКЦИЯМИ
Кто может сказать,что за кодировка в этом DBF-файле ?
Вопрос по обновлениям базы 1С: бухгалтерия

Re: Открыть форму элемента справочника модально

Sasha
8 - 04.07.2009 - 18:33
(7)В том то и дело что вообще ничего :-) см. (5) последние три строки поста
Советую смоделировать ситацию. Вывод: Форму элемента справочника нельзя вызвать программно в форме списка этого справочника.

Re: Открыть форму элемента справочника модально

Reaper
9 - 04.07.2009 - 18:48
8-Sasha > Второй параметр укажи. Причем не значением, а переменной.

Re: Открыть форму элемента справочника модально

Sasha
10 - 04.07.2009 - 19:04
(9)тьфу, а грабли-то простые были :-(
Если указать "Редактировать в списке", форму элемента открыть нельзя не только интерактивно, но и программно

Re: Открыть форму элемента справочника модально

Блондинка в шок
11 - 04.07.2009 - 19:11
//*****************************************************************
 
Процедура ПриОткрытии()
Форма.ОбработкаВыбораСтроки(1);
КонецПроцедуры //ПриОткрытии()
//*******************************************************************
Процедура ПриВыбореСтроки()
тЭлемент = ТекущийЭлемент();  
// Сообщить(""+тЭлемент);
СпрБ = СоздатьОбъект("Справочник.Банки");
СпрБ.НайтиЭлемент(тЭлемент);
Эл = СпрБ.ТекущийЭлемент();
// Сообщить(""+Эл);
 
ОткрытьФормуМодально(Эл,,0);  
 
КонецПроцедуры

Re: Открыть форму элемента справочника модально

Блондинка в шок
12 - 04.07.2009 - 19:15
э-э-э, понятно, что это я в форме списка Справочник.Банки и баловалась...
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« ПБОЮЛ Книга доходов и расходов мозги пробила (Путевый лист) Как удалить документ из dbf вручную? »
© 2009 Форум 1С: Одинэс.Ру