Дерево групп справочника

Форум 1С: Одинэс.Ру

Найти!

Дерево групп справочника

san_nisan
04.03.2009 - 14:25
Здравствуйте. Подскажите, пожалуйста, как сделать, так чтобы по нажатию на кнопку, открывалась форма на которой можно было мышкой выбрать, в окне дерева групп справочника, именно ту папку(группу) которая мне будет нужна, затем название этой группы отобразить в текстовом поле, а в этой группе в цикле создать 20 элементов справочника.
К списку тем К списку форумов

Интересные темы

odines.ru
09.12.2021 - 14:06
Смотри также:
ЖКХ: Расчет квартплаты
Когда рухнет база?
Клиент-банк (ibank2) vs 1C77 экспорт/импорт

Re: Дерево групп справочника

victuan
1 - 04.03.2009 - 14:46
(0) А чем тебе мой ответ на мисте не понравился?

Re: Дерево групп справочника

Arden
2 - 04.03.2009 - 14:48
дерево групп можно положить только на форму списка справочника и то только если он многоуровневый.
какая вообще то задача ? чем не устраивает в поле ввода группы выбирать ?

Re: Дерево групп справочника

victuan
3 - 04.03.2009 - 14:56
На форме кладешь реквизит типа справочник нужного типа вида с идентификатором спрТовар
В модуле формы пишешь:
 
Процедура ПриОткрытии()
  спрТовар.ВыборГруппы(1);
КонецПроцедуры
 
Процедура Сформировать()
Если СпрТовар.выбран()=0 тогда
  Предупреждение("Задайте группу справочника!");
  Возврат
конецесли;
спр = создатьОбъект("Справочник.Номенклатура");
Спр.ИспользоватьРодителя(спрТовар);
для й =1 по 20 Цикл
  Спр.Новый();
... //присвоение реквизитов новым эл-там спр.
 
  Спр.Записать();
КонецЦикла
КонецПроцедуры

Re: Дерево групп справочника

Arden
4 - 04.03.2009 - 14:58
(0) вобщем ясно. из дерева групп нельзя выбрать (не заложена в него эта возможность) выбрать можно только из списка.

Re: Дерево групп справочника

victuan
5 - 04.03.2009 - 15:05
(4) Максимум дерево групп можно видеть сбоку и использовать для удобной навигации (в моем примере выбери для рекв. спрТовар Форму "Основная"), но выбирать все-таки придется в окне списка.

Интересные темы

odines.ru
09.12.2021 - 14:06
Смотри также:
переход из sql в dbf
Доступ по Оле на БД-Сервер, приемник - на локальном ПК. Выскакивает сообщение "Сервер занят!"
Не записывается файл в формате XLS

Re: Дерево групп справочника

Arden
6 - 04.03.2009 - 15:12
(5) дык и я о том же. но автор на мисте озвучил, что ему удобнее из дерева выбирать.
К списку тем К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Какая связь между 1С и операционной системой? Конвертация данных: как добавить префикс? »
© 2009 Форум 1С: Одинэс.Ру