Обучение программированию

Форум 1С: Одинэс.Ру

Найти!

Обучение программированию

rewers
22.04.2009 - 20:46
Уважаемые программисты 1с и не только! Подскажите мне (по возможности без стёба) возможно ли стать программистом 1с если на данный момент я имею представление только о паскале и то лишь самое начало где-то до уровня подпрограмм.
Какой багаж знаний должен быть при поступлении на курсы програмистов 1с?
Что посоветуете почитать для начала?
Необходимо ли знать бухучет для программирования?
Посебе знаю, что необходима практика, но С ЧЕГО НАЧИНАТЬ?
К списку тем 1 2 3 > К списку форумов

Интересные темы

odines.ru
21.10.2020 - 16:55
Смотри также:
Розничная торговля. Помогите советом, плиз!
Подскажите, проблема с печатью отчётности из 1С 7.7
Не проводится большой документ

Re: Обучение программированию

VZ
1 - 22.04.2009 - 21:01
С предмета. Это не стёб :)
Основная беда начинающих: они кидаются выполнять "хотелки", не понимая источника этих "хотелок". Во-первых, их рожают юзеры, вообще не имеющие понятия о законах построения программ, не видящие завтрашнего дня, не умеющие предусматривать противоречия... И не умеющие формулировать цель - они диктуют действия, которые, по их мнению, необходимы...
Представь, какие будет давать советы извозчик, никогда не видивший автомобиля, автоконструктору...
Не так уж редки "хотелки", являющиеся на деле скрытым саботажем. С целью развалить базу данных.
Чтоб этого избежать, нужно знание предмета. И зравый смысл, задающий вопрос "Зачем?" :)
 
И очень неплохо понять вообще общие принципы функционирования базы данных...

Re: Обучение программированию

VZ
2 - 22.04.2009 - 21:03
"Главное - ввязаться в драку..." (с) Наполеон
;)

Re: Обучение программированию

КонецЦикла
3 - 22.04.2009 - 21:11
2(0) То что залез во всемирную паутину - уже хорошо
Далее надо найти мастера-йоду и побыть 1-2-3 года подаваном

Re: Обучение программированию

rewers
4 - 22.04.2009 - 21:15
1_Необходимо ли начинать изучение предмета с момента "как работает ЭВМ"? Или достаточно для начала знать что такое переменная, ввод-вывод, массив...

Re: Обучение программированию

КонецЦикла
5 - 22.04.2009 - 21:20
1С не требует (как правило) :) знаний прямой работы с портами, памятью и т.п.
Важнее постигнуть предметную область и правила организации нормальных БД (с оглядкой на специфику 1С)
Посмотри для начала что это вообще такое, потом как написаны типовые конфиги

Интересные темы

odines.ru
21.10.2020 - 16:55
Смотри также:
Доступ к форме документа.
Заявка на кассовый расход.Выгрузка в казначейство.Проблемы
AdoDb.Connection

Re: Обучение программированию

rewers
6 - 22.04.2009 - 21:34
5_Как я понимаю по аналогии с паскалем  начало БД это массивы, строки множества, записи?

Re: Обучение программированию

VZ
7 - 22.04.2009 - 21:41
(4, 6) Нет, под предметом следует понимать знание предметной области, предмета приложения этой программы. Для чего она предназначена.

Re: Обучение программированию

КонецЦикла
8 - 22.04.2009 - 22:00
2(6) БД - для 1С это таблицы в форматах DBF, SQL
Для конфигураста таблица - это справочник, документ, регистр... вот надо иногда думать как что куда прилепить и стоит ли это делать

Re: Обучение программированию

rewers
9 - 22.04.2009 - 22:02
7_Следовательно ддя начала необходимо стать бухгалтером, кадровиком...., а потом быть может получится и программистом 1с?

Re: Обучение программированию

Чучундер
10 - 22.04.2009 - 22:11
9-rewers > да, хотя бы начинающим, то есть знающим основы автоматизируемой предметной области. Иначе - прямая дорога в быдлокодеры 1С...

Re: Обучение программированию

КонецЦикла
11 - 22.04.2009 - 22:11
Ну если нарвешься на кадровика-программиста, то тогда не надо нифига понимать, он все разжует, радуйся...
Всем спокночи

Re: Обучение программированию

rewers
12 - 22.04.2009 - 22:22
Спасибо всем откликнувшимся! Может кто порадует ссылочками на интересную и полезную на ваш взгляд литературу?

Re: Обучение программированию

Чучундер
13 - 22.04.2009 - 22:24
по программерским вопросам ищи что-то типа "основы построения реляционных баз данных"

Re: Обучение программированию

Друзья зовут меня Курулай
14 - 23.04.2009 - 03:28
ребята, которые франчи!
явно ваш человек, не упускайте!

Re: Обучение программированию

ЖКК
15 - 23.04.2009 - 04:19
(14) +1
(13) а лучше "теория реляционных БД"

Re: Обучение программированию

reanimator
16 - 23.04.2009 - 04:29
(0) Иди в какой-нибудь франч попроще, чтоб свалить при необходимости можно было полегче. Побегай у них некоторое время, там тебя за бесплатно и обучат.

Re: Обучение программированию

Друзья зовут меня Курулай
17 - 23.04.2009 - 04:34
(16) обучат, но не бесплатно, а именно за "побегай"
свою учёбу он отработает ногами

Re: Обучение программированию

Маус
18 - 23.04.2009 - 04:35
бегать придется долго, обучаться придется самому ;)))

Re: Обучение программированию

Маус
19 - 23.04.2009 - 04:36
(16) у вас какое-то дохлое представление о франчах!

Re: Обучение программированию

Маус
20 - 23.04.2009 - 04:38
Обучают на любой работе (хоть дворником, хоть свинаркой, хоть слесарем), на любой работе есть возможность свалить/запить... Как можно работать программистом без образования? Ну хотя бы высшее математическое должно быть?!!

Re: Обучение программированию

roma n
21 - 23.04.2009 - 04:41
20-Маус >
можно... нормально.

Re: Обучение программированию

ЖКК
22 - 23.04.2009 - 04:50
(21)
Видел я писанины теоритиков - гуманитариев.
Необходимо было проверить, является ли число началом нового диапозона (10,100,1000,10000) и тд.
Решение было - перевод в строку, м уже работа со строкой.
Вот вам и отсутствие математического образования...
З.Ы. Кто как бы решил? (Не зависимо от языка программирования)

Re: Обучение программированию

Маус
23 - 23.04.2009 - 04:53
Согласен: засилье дохлых гуманитариев -> тонны некачественного кода!

Re: Обучение программированию

Маус
24 - 23.04.2009 - 04:58
++ они даже дискету не знают, какой стороной в CD-ROM пихать!

Re: Обучение программированию

roma n
25 - 23.04.2009 - 05:02
22-ЖКК >
%10 =0
ЗЫ тонны - мне производительность не позволит :)

Re: Обучение программированию

Маус
26 - 23.04.2009 - 05:06
(22) видишь: (25) - на развод попался! - только гуманитарий будет отвечать на такой децкий вопрос! (так как это для него - достижение!)

Re: Обучение программированию

roma n
27 - 23.04.2009 - 05:09
26-Маус >
Это не достижение. И я не гуманитарий.
Оператор % незаслуженно забывается. Вот и решил напомнить :)

Re: Обучение программированию

ЖКК
28 - 23.04.2009 - 06:17
27-roma n >select 100 % 10, 50 % 10
0
0

Re: Обучение программированию

roma n
29 - 23.04.2009 - 06:28
28-ЖКК > рекуррентно. Я ж говорю, что % привел просто чтоб не забывалось, достойно оно. :)
В данном случае проще цикл деления организовать

Re: Обучение программированию

reanimator
30 - 23.04.2009 - 06:28
(17) Естественно, не отрывая пятой точки, ничему и не научишься.
(19) Реальное, я ж сказал "франч попроще".

Re: Обучение программированию

ЖКК
31 - 23.04.2009 - 06:29
29-roma n > проще чем проверить результат десятичного логарифма на равность нулю?

Re: Обучение программированию

roma n
32 - 23.04.2009 - 06:35
31-ЖКК >
Условие "Не зависимо от языка программирования". Предполагаю в языке программирования наличие базовых конструкций и арифметических операций, к коим вычисление логарифма не относится (по моему скромному мнению)

Re: Обучение программированию

ЖКК
33 - 23.04.2009 - 06:36
имелось ввиду дробную часть на равность нулю.
сегодня др. пальцы заплетаются уже...

Re: Обучение программированию

ЖКК
34 - 23.04.2009 - 06:40
Проверил. даже в клюшках есть лог10
Да крайне малы языков , где логарифмы - это дополнительные бантики.
пофих.

Re: Обучение программированию

roma n
35 - 23.04.2009 - 07:05
33-ЖКК > Тебе? Тады трям!

Re: Обучение программированию

roma n
36 - 23.04.2009 - 07:07
+ Кстати, Lg тоже не безупречен
0.1, 0.01, ...

Re: Обучение программированию

ЖКК
37 - 23.04.2009 - 07:10
(36) ЖКК
33 - 23.04.2009 - 10:36 имелось ввиду дробную часть на равность нулю.

Re: Обучение программированию

ЖКК
38 - 23.04.2009 - 07:10
35-roma n > спасибо :)

Re: Обучение программированию

roma n
39 - 23.04.2009 - 07:27
37-ЖКК > ну так и я про то.
Lg(0.1)%1 = Lg(0.01)%1 =0

Re: Обучение программированию

rewers
40 - 23.04.2009 - 07:33
Франч, франч а что это за зверь? Компании которые обслуживают несколько фирм использующих 1с?

Re: Обучение программированию

roma n
41 - 23.04.2009 - 07:47
40-rewers >

Re: Обучение программированию

roma n
42 - 23.04.2009 - 07:48
40-rewers >
прошу пардону...
http://www.1c.ru/rus/firm1c/franch.htm
http://www.1c.ru/rus/partners/franch-citylist.jsp

Re: Обучение программированию

ЖКК
43 - 23.04.2009 - 07:52
declare @i int
set @i=10
while @i<>100001
begin
if log10(@i)-round(log10(@i),0,1)=0 print @i
set @i=@i+1
end

Re: Обучение программированию

Пудель
44 - 23.04.2009 - 07:58
...А у нас стажёры сначала проходят двухмесячный курс обучения...
...А потом экзамены...

Re: Обучение программированию

ЖКК
45 - 23.04.2009 - 08:03
А 1с Считает, что "деление на 0"
Перем счетчик;              
Для счетик=10 по 100001 Цикл  
  Если лог10(счетчик)-цел(лог10(счетчик))=0 Тогда Сообщить(счетчик);
  КонецЕсли;
КонецЦикла;

Re: Обучение программированию

rewers
46 - 23.04.2009 - 08:09
42_Cпасибо, а они что берут в ученики всех подряд?

Re: Обучение программированию

АндРоид
47 - 23.04.2009 - 08:10
(rewers)
Вот посмотри здесь: http://1sb.dodger.ru/
Как раз на тебя нацеленный сайт под лозунгом "Изучай 1С сам, не напрягаясь".
Не факт, что сходу надо покупать ихние курсы, но - ознакомиться внимательно стоит.
Сама идея - "Изучать не напрягаясь" - очень правильная.
Адекватный чел вообще всё делает ненапрягаясь.
Напряг - признак неправильного понимания сущности бытия.
Про хорошего мастерера - будь то токарь, плотник, одинэсник или даже тичер или стюдент(как ты) - говорят, что он "работает играя", т.е. без напряга.

Re: Обучение программированию

rewers
48 - 23.04.2009 - 08:11
44_Курсы платные? стоимость? А у нас -это где?

Re: Обучение программированию

roma n
49 - 23.04.2009 - 08:20
(43,45) ишь, хитрый какой... кто сказал что натуральные не меньше 10 исследуются? Я ж тебе припоминаю о 10^-1, 10^-2 etc, которые формально удовлетворяют условию лог10(ИсследуемоеЧисло)-цел(лог10(ИсследуемоеЧисло))=0, но по смыслу прикладной задачи, скорее всего, должны быть отметены как неподходящие.
;)

Re: Обучение программированию

bushd
50 - 23.04.2009 - 08:21
(47) Ну и как, - удаеться? Лично вам, просто первый раз вижу человека который умеет не напрягаться. Интересно.
К списку тем 1 2 3 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Ищу типовая конфигурацию "Торговля+ Склад" редакция 9.2 Форма списка справочника »
© 2009 Форум 1С: Одинэс.Ру