Открыть диалог нового документа через расшифровку ячейки возможно?

Форум 1С: Одинэс.Ру

Найти!

Открыть диалог нового документа через расшифровку ячейки возможно?

du el
27.04.2009 - 10:15
Как работать с функцией я поняла, а как заставить сделать процедуру?
К списку тем 1 2 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 15:04
Смотри также:
выгрузка из ЗиК в Бух
Подскажите конфигурации по 7.7
Нужен программист 7.7

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
1 - 27.04.2009 - 10:15
да. Можно не только открыть новый, но и заполнить его данными...

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
2 - 27.04.2009 - 10:18
а на пример с кодом какой-нибудь не могли бы надоумить?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
3 - 27.04.2009 - 10:21
с кодом - проблема. Лень надоумливать...

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
4 - 27.04.2009 - 10:23
но ты не расстараивайся - щас набегут Дятлы, предводимые VZ и начнут учить....

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
5 - 27.04.2009 - 10:34
звучит устрашающе

Интересные темы

odines.ru
22.10.2020 - 15:04
Смотри также:
Выделить колонку цветом
УРБД. Как организовать миграцию документов не по виду документа, а по определенному критерию
ЭККА Мария-301 + VPN + Terminal

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
6 - 27.04.2009 - 10:58
а фото будет?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
7 - 27.04.2009 - 11:01
оно есть, а зачем?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
8 - 27.04.2009 - 11:13
всегда приятно общаться, зная с кем)

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
9 - 27.04.2009 - 11:19
а по существу пообщаться вдвойне приятнее

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Arden
10 - 27.04.2009 - 11:26
Процедура ОбработкаЯчейкиТаблицы(Значение, ФлагСтандОбраб)
ФлагСтандОбраб = 0; // не надо обрабатывать стандартно
        ОткрытьФорму("Документ.ПоступлениеТоваров", Параметр);
КонецПроцедуры
 
так не срабатывает ?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
11 - 27.04.2009 - 11:27
а чё надо то? чем тебе функция не нравится? зачем процедура?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

SunShinne
12 - 27.04.2009 - 11:31
А можна параметр в форму передать и заполнить док из его же модуля. А в восьмерке вообще все красиво

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
13 - 27.04.2009 - 11:38
(10) спасибо, "значение" - это результат функции из расшифровки или что?
(11) надо примерно следующее: на печать выводится таблица в ней несколько
ячеек-кнопок, при нажатии на которые открывается диалог документа,
реквизиты которого заполняются в зависимости оттого какая ячейка "тыкнута"

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
14 - 27.04.2009 - 11:40
Процедура ОбработкаЯчейкиТаблицы(<?>,,,)
КонецПроцедуры
Синтаксис:
ОбработкаЯчейкиТаблицы(<Значение>,<ФлагСтандОбраб>,<Таблица>,<Адрес>)
Назначение:
Предопределенная процедура обработки ячейки таблицы (по двойному щелчку мыши или по нажатию клавиши ''Enter'' в табличном документе на выбранной ячейке).
Параметры:
<Значение> - здесь в процедуру передается вычисленное значение ячейки (задается в конфигураторе: ''Свойства'' ячейки, ''Текст'', ''Значение'').
<ФлагСтандОбраб> - флаг обработки ячейки: установка в 1 приведет к выполнению стандартной обработки значения ячейки по завершении процедуры (открытию документа, элемента справочника и т.п.).
<Таблица> - необязательный параметр. Имя переменной, куда система передаст объект типа ''Таблица''. С помощью значения этого контекста можно произвольно манипулировать данной таблицей, пока она открыта. Пока данный объект ''Таблица'' существует,  тип значения данного параметра равен 100, если закрыта - 0.
<Адрес> - необязательный параметр. Имя переменной, куда система передаст адрес ячейки/объекта в формате ''R1C1:R2C2''.
Замечание:
Объект типа ''СписокЗначений'' может записываться в поле ''значение'' ячейки таблицы и использоваться затем процедурой ОбработкаЯчейкиТаблицы.
Важно!
Если данная процедура описана в модуле формы, то вызывается она, иначе система запускает одноименную процедуру из глобального модуля.
Внимание!
Данная предопределенная процедура НЕ вызывается при выборе ячейки таблицы в режиме ввода данных. Для этого случая вызывается предопределенная процедура ПриВыбореЯчейкиТаблицы.

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Arden
15 - 27.04.2009 - 11:41
(13) я не совсем понимаю про какую функцию ты говоришь

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
16 - 27.04.2009 - 11:41
(13)Да, значение содержит расшифровку ячейки. Соответственно реквизиты можно заполнять либо фиксированными значениям в процедуре, либо полученными из расшифровки
pS.Симатичная фотка)

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
17 - 27.04.2009 - 11:43
(12)Имхо, лучше наоборот работать с обработке с документом через контекст, так мы не меняем конфигурацию

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
18 - 27.04.2009 - 11:44
функция удобна тем что я подставляю туда значения, ,
в форме где расшифровка пишу РасшифровкаЗаявки(1...5 - в зависимоти от
ячейки)
они вроде выбираются
Функция РасшифровкаЗаявки(ИдЗаявки)
Расшифровка.Установить("Содержание", ИдЗаявки);
Возврат Расшифровка;
КонецФункции
 
а что дальше с этим делать не поняла

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
19 - 27.04.2009 - 11:46
(16) т.е я опоздал?
(18) посмотри, как в типовых конфигах сделаны кнопки Настройка/Обновить в отчетах

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
20 - 27.04.2009 - 11:48
(18)Ну дальше параметр "Значение" у тебя будет фактически содержать список значений полученный твоей функцией. То есть
Процедура ОбработкаЯчейкиТаблицы(Значение, ФлагСтандОбраб)
ФлагСтандОбраб = 0;
ИдЗаявки = Значение.Получить("Содержание");
//а дальше уже с этим ИД делаешь что нужно
КОнецПроцедуры
Если есть какие-то другие значения расшифровок отличные от списка значений, нужно делать проверку

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
21 - 27.04.2009 - 11:48
(14) спасибо, это я вижу в хелпе. я не понимаю куда включать эту
процедуру, в какой момент она выполняется. т.е. я по ячейке тыкнула,
выполнилась функция которая указана в расшифровке, а как теперь на
процедуру ОбработкаЯчейкиТаблицы попасть?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
22 - 27.04.2009 - 11:50
(21)Нет :) Когда два раза тыкаешь по ячейке, как раз вызывается ОбработкаЯчейкиТаблицы()

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
23 - 27.04.2009 - 11:50
(19) вот туда я и смотрела, оттуда и скопировала функцию, даже через
отладчик отследить пыталась... запуталась только :(

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
24 - 27.04.2009 - 11:51
(22) отлично! т.е. она автоматом вызывается и в расшифровке ничего писать
не надо?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Arden
25 - 27.04.2009 - 11:54
(23) твоя функция должна выполнятся не тогда когда ты "тыкаешь" на ячейку, а перед тем как эту ячейку вывести в печатную форму. + см (22)

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
26 - 27.04.2009 - 11:54
(24)Расшифровка ячейки заполняется значением в момент вывода секций объекта "Таблица", функция ОбработкаЯчейкиТаблицы выполняется при двойном клике на ячейке, если стоит запрет редактирования, если такая функция не обнаруживается в форме обработки, создавшей Таблицу, либо форма уже закрыта, то выполняется аналогичная функция в глобальном модуле. Да, вызывается "автоматом" ибо предопределенная :-)

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
27 - 27.04.2009 - 11:56
(19)Нет, не опоздал :-) Я думаю, автор не обидится
http://foto.mail.ru/mail/el_dunaevskaya/_myphoto/11.html

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
28 - 27.04.2009 - 12:00
(27) может и опоздал скоро 3 года этой фотке )))

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
29 - 27.04.2009 - 12:01
спасибо всем ответившим, буду ваять дальше!

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
30 - 27.04.2009 - 12:38
Извините, снова я туплю :(
 
Функция РасшифровкаЗаявки(ИдЗаявки)
Расшифровка.Установить("Заявка", ИдЗаявки);
Возврат Расшифровка;
КонецФункции
.....
Процедура ОбработкаЯчейкиТаблицы(Значение, ФлагСтандОбраб)
ПараметрЗаявки = СоздатьОбъект("СписокЗначений");
Заполняем = СоздатьОбъект("Документ.Заявка");
 
ФлагСтандОбраб = 0;
ИдЗаявки = Значение.Получить("Заявка");
Если ИдЗаявки = 1 Тогда
Заполняем.Адрессат = "хххххх";
Заполняем.Титул = "уууууу";
ПараметрПисьма = Заполняем;
ОткрытьФорму("Документ.Заявка", ПараметрЗаявки);
КонецЕсли;
КонецПроцедуры
 
сначала все замечательно - тыкаю в ячейку, открывается заявка, но не
заполненная. как с этим параметром бороться?

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
31 - 27.04.2009 - 12:59
(30)Заполняем.Новый();
---
Заполняем.Записать();
ОткрытьФорму(Заполняем.ТекущийДокумент());

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
32 - 27.04.2009 - 13:04
(+31)Либо после ОткрытьФорму() работай с переменной ПараметрЗаявки, который будет содержать контекст открытой формы

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
33 - 27.04.2009 - 13:10
(31)отлично! спасибо!

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
34 - 27.04.2009 - 13:35
(31) фигня решение...
Если пользователь случайно ткнет в ячейку - создастся и запишется документ. И ТУТ  ЮЗЕР ПОНИМАЕТ - он зря ткнул я чейку, погорячился.... Что будем делать с документом? Он то уже записан....
 

P.S. лучше открывать ЗАПОЛНЕННЫЙ НЕЗАПИСАННЫЙ ДОКУМЕНТ - пусть решение принимает юзер. Записывает или закрывает без сохранения....
 
P.S. уже задолбали решения типа (31) - большая часть доков обычно помечена на удаление....

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
35 - 27.04.2009 - 13:41
(34) действительно :-)
а как в заставить печатать с новой строки?
предполагаю
СтрокаАдрессата = Адрессат.ПолнНаименование+КодСимв(??
)+Адрессат.ПочтовыйАдрес;
а какой код не знаю :-/

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
36 - 27.04.2009 - 13:43
СтрокаАдрессата = СокрЛП(Адрессат.ПолнНаименование)+ РазделительСтрок +
+сокрлп(Адрессат.ПочтовыйАдрес) + .......

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
37 - 27.04.2009 - 13:47
спасибо!

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Uho
38 - 27.04.2009 - 14:10
4-pit > щас набегут Дятлы, предводимые VZ и начнут учить....
34-pit > фигня решение...

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
39 - 27.04.2009 - 14:39
38-Uho >  38-Uho >  38-Uho >  38-Uho >  38-Uho > фигня решение от компании.

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
40 - 27.04.2009 - 16:41
(34) хм, если убрать
Заполняем.Записать();
перестает открываться документ...
и как быть?
а если оставить мусора действительно много плодится :(((

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

VZ
41 - 27.04.2009 - 16:54
Я бы попросил...... Не упоминать всуе......
 
Тем паче коды я не пишу - мне лениво....

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
42 - 27.04.2009 - 16:55
- все нужные документу параметры, передаваемые в документ, записываем в список значений...
- выполняем ОткрытьФорму("Документ.ВидДокумента",.....синтаксис в СП есть)
- в документе в предопределенной процедуре ВводНового смотрим. если у формы есть параметр и этот параметр - списокЗначений - пытаемся его распотрошить и полученными значениями заполнить реквизиты нового дока....  

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

VZ
43 - 27.04.2009 - 17:01
(42) Это надо в конфу лезть, а это не есть гуд...

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
44 - 27.04.2009 - 17:06
можно и по другому сделать...

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

roma n
45 - 27.04.2009 - 17:09
(40) веселый способ:
начатьтранзакцию()
док.записать()
открытьформу()
отменитьтранзакцию()
ЗЫ на рабочей базе не рекомендую, но на кошках попробовать - познавательно

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

du el
46 - 27.04.2009 - 18:00
(45) мне на рабочей надо

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Cthulhu
47 - 27.04.2009 - 19:10
(16),(27): а тут симпатичнее: http://foto.mail.ru/mail/el_dunaevskaya/_myphoto/10.html
:)

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
48 - 28.04.2009 - 04:19
2(34) Я предложил автору на выбора два решения, первое через СоздатьОбъект(), соответственно здесь можно открыть форму уже записанного документа, и через управление контекстом формы при открытии формы нового документа в  (35), где запись уже будет делать юзер в открытой форме по желанию

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

Sasha
49 - 28.04.2009 - 04:23
(+48) в 32 )) Если всё расписать то получится вот что:
Перем ПараметрЗаявки;
Если ИДЗаявки = 1 Тогда
ОткрытьФорму("Документ.Заявка", ПараметрЗаявки);
ПараметрЗаявки.Адрессат = "хххххх";
ПараметрЗаявки.Титул = "уууууу";
ПараметрЗаявки.Форма.Обновить();
КонецЕсли;
и никакой СоздатьОбъект() тогда тут естетвенно не нужен

Re: Открыть диалог нового документа через расшифровку ячейки возможно?

pit
50 - 28.04.2009 - 04:56
Недостаток (49) - заключается в том, что нельзя заполнить табличную часть документа...
К списку тем 1 2 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Кто может сказать,что за кодировка в этом DBF-файле ? Проблема с KATRAN LPT »
© 2009 Форум 1С: Одинэс.Ру