Падает 1С при открытии обработки загрузки/выгрузки проводок

Форум 1С: Одинэс.Ру

Найти!

Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
30.03.2009 - 10:50
После переустановки компа возникла проблема - в ЗиКе и Бух, при открытии обработки для выгрузки/загрузки проводок 1С закрывается с ошибкой. DEP, антивирус отключил. Темпы короткие сделал, v7plus последнюю поставил. Результата никакого. Сам релиз (25 и 27) переустанавливал. Что еще можно посомтреть?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 11:42
Смотри также:
ВК на Delphi
цены в форме элемента номенклатуры
Что за глюки с ТЗ (вопрос в стиле Чучундера)?

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

user1C
1 - 30.03.2009 - 11:19
что за ошибка?

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

Чучундер
2 - 30.03.2009 - 11:24
У меня наблюдается падение 1Ски при попытке загрузки V7plus.dll - почему и как лечить - не знаю...

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

user1C
3 - 30.03.2009 - 11:33
(2)
regsvr32 пробовал?

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
4 - 30.03.2009 - 12:51
(0) Невразумительный вопрос и не предполагает ответа... Что "падает"? Что "закрывается"? Что за "ошибка"?
Что еще можно посомтреть? - правила форума. И погуглить инет на предмет "Как правильно задать вопрос".

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
5 - 30.03.2009 - 13:42
regsvr пробовал. и старую разрегистрировал/регистрировал и новую тоже. Результата нет. Ошибка? Да вот просто так и пишет в журнале "Ошибка приложения 1cv7s.exe, версия 7.70.0.27, модуль kernel32.dll, версия 5.1.2600.2180, адрес 0x0000979d.". На экране тоже - "Приложение вызвало ошибку и будет закрыто" и никаких более развернутых ссылок и описаний.

Интересные темы

odines.ru
22.10.2020 - 11:42
Смотри также:
Подскажите, плиз, код или ВК, который(ая) фиксирует время простоя 1С-ины и запускает определенную обработку
Почему не проводит документ?
Помогите. Вопрос про УРБД - долгий простой

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

user1C
6 - 30.03.2009 - 14:25
(5)
при такой ошибке, одноэсина обычно падает в следствии отсутствия каких-либо прав...

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

:)
7 - 30.03.2009 - 14:28
хмлпарсеры посмотри

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
8 - 30.03.2009 - 14:45
(6) WinXp, заходят под Админом.
(7) Куда их смотреть,что с ними делать? Все в ExtForms скопировано с последних обновлений.
Еще замечание - когда начинает падать, то починить пока удается только одним способом - запустить 1c_portable (версия где весь каталог BIN сжат в один exe файл) ДАльше какое-то время все работает и на обычных экзешниках

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
9 - 30.03.2009 - 14:56
Еще раз: опиши ситуацию вразумительно. Ты можешь не мычать, а четко описать ситуацию? И не надо рассказывать про то, что ты видишь на экране, и виноват ли DEP.
Я и так знаю, что не виноват.
 
А вот инсталляция приложений очень даже, похоже, причем...

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

Uho
10 - 30.03.2009 - 15:09
общий реквизит неограниченной длины на последнее место

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
11 - 30.03.2009 - 15:29
(9) Пардон,в чем Вы видите мычание? Я вроде описал все что есть, или Вам не хватает еще каких то данных? Озвучьте,сообщу.
(10) Куда? На какое место? Конфы типовые. Последняя Бух и ЗиК. Никаких дописок с измененными реквизитами там нет.

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
12 - 30.03.2009 - 15:50
(11) Нет не все. Совершенно непонятна фраза "Сам релиз (25 и 27) переустанавливал". Какой релиз? Бух? ЗиК? В разных каталогах? Это комплексный, в одном каталоге, скульный? Базы ДБФ, скульные? Кодовые страницы одинаковы, разные? Что "падает"? Бух? Зик? Обе сразу? Что за обмен? Метод? Есть ли сообщения в строке состояния, какое? Что за обработка, на каком этапе вылет? Какие внешние компоненты вызваны?........
Какого черта об этом всем надо гадать?!

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
13 - 30.03.2009 - 16:05
(12) Движки стоят в разных каталогах. Пробовал ставить 27 и 25 релизы.Базы ДБФ. Кодовые страницы одинаковые. Падают одинаково и Бух и Зик (3 базы Бух и з базы ЗиК для разных фирм). Падает при открытии встроенной обработки по выгрузке проводок в ЗиК и по загрузке в Бух. Обработки родные. Вываливается сразу как открывается, никаких сообщений в строке состояния не успевает высветиться. Базы стандартные,поэтому никаких доп. компонент нет. Отладчиком залезть не успел - комп клиентский. На моем компе базы работают нормально. Еще  что-нибудь?

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
14 - 30.03.2009 - 16:14
(13) Внешние компоненты? 1С++? Другие?

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

:)
15 - 30.03.2009 - 16:32
xml парсер какой версии стоит? Рабочий или нет? Попробуй его разрегистрировать и опять зарегистрировать. Если вывалится с ошибкой - значит битый.

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
16 - 30.03.2009 - 16:52
Наблюдал аналогичное падение. Проход по шагам выявил оператор, на выполнении которого одноэсина валилась.
Пока не всю информацию получил от автора...

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

user1C
17 - 30.03.2009 - 19:58
(8)
оке, отсюда подробней:
"После переустановки компа возникла проблема" -  от первого до последнего
слова фразы...

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
18 - 31.03.2009 - 06:07
(14) Конфы,как я писал выше -типовые, никаких доп компонент
(15) парсер дополнительно не ставил, только то что при установке Винды, SP2
(16) По шагам,как я написал выше, не трэйсил - комп у клиента, не было времени и возможности
(17) Что рассказать подробнее? Комп переставлял не я - местный админ. Винда лицензионная, 1С тоже. После установки всего этого возникла описанная выше ошибка

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
19 - 31.03.2009 - 08:45
Системные журналы смотрел? Там отмечается время события - по нему можно найти причину. Главное - зафиксировать время перед вылетом. Т.е., вызываешь обработку, которая повалит одноэсину - взгляни на время в трее.
Важна самая ранняя запись с временем падения - остальные наведенные.

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
20 - 31.03.2009 - 09:56
(19) Об этом я уже написал в (5)

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

banzay
21 - 31.03.2009 - 10:17
(15)+ Запусти из 1С отчет с таким кодом:
//*******************************************
Функция НайтиПервыйСуществующийФайл(СписокВозможныхМест)
 
Для Сч = 1 По СписокВозможныхМест.РазмерСписка() Цикл
ПолноеИмя = СписокВозможныхМест.ПолучитьЗначение(Сч);
Если Фс.СуществуетФайл(ПолноеИмя) = 1 Тогда Возврат(ПолноеИмя) КонецЕсли;
КонецЦикла;
 
Возврат("");
 
КонецФункции // НайтиПервыйСуществующийФайл()
 
//*******************************************
Процедура Сформировать()
СписокВозможныхМест = СоздатьОбъект("СписокЗначений");
СписокВозможныхМест.ДобавитьЗначение( КаталогИБ() + "v7plus.dll" );
СписокВозможныхМест.ДобавитьЗначение( КаталогПрограммы() + "v7plus.dll" );
СписокВозможныхМест.ДобавитьЗначение( КаталогИБ() + "ExtForms\" + "v7plus.dll" );
гПутьОбъекта_КомпонентаV7plus = НайтиПервыйСуществующийФайл(СписокВозможныхМест);
 
Если ЗагрузитьВнешнююКомпоненту(гПутьОбъекта_КомпонентаV7plus) <> 1 Тогда
Предупреждение("Компонента v7plus.dll не найдена!");
СтатусВозврата(0); Возврат;
КонецЕсли;
 
гXMLАнализатор = СоздатьОбъект("AddIn.XMLParser");
ВерсияАнализатора = гXMLАнализатор.ВерсияАнализатора;
ВерсияБазовогоАнализатора = гXMLАнализатор.ВерсияБазовогоАнализатора;
Сообщить("Версия ХМЛ-анализатора: " + ВерсияАнализатора);
Сообщить("Версия базового ХМЛ-анализатора: " + ВерсияБазовогоАнализатора);
КонецПроцедуры
 
Что он тебе говорит?
 
"(15) парсер дополнительно не ставил, только то что при установке Винды, SP2" - настораживает.
 

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

iogri
22 - 31.03.2009 - 10:21
2(20)
При открытии обработок выгрузки-загрузки производится поиск файлов при помощи объекта "ФС"
Кроме того, используется метод "ЗагрузитьВнешнююКомпоненту"
И то, и другое зависит от прав пользователя

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
23 - 31.03.2009 - 12:06
(21) буду у клиента  - проверю. но v7plus.dll  я проверял - только в каталогах ИБ лежат. Вот парсера не было с собой, переустановить.
(22) как написано в (8) заходят с правами Администратора

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
24 - 01.04.2009 - 09:49
(21) запустил,сказало:
Версия ХМЛ-анализатора: 2.0
Версия базового ХМЛ-анализатора: 3.0
переустановил с ИТС диска файл msxml3.exe
результата не дало

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

VZ
25 - 01.04.2009 - 09:56
Четвертый поставь. ХРюня терпимо отностся к наличию анализаторов разных версий.

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

banzay
26 - 01.04.2009 - 10:27
(25)+ У меня Версия ХМЛ-анализатора: 2.0
Версия базового ХМЛ-анализатора: 4.0. Полет нормальный, без "падений"

Re: Падает 1С при открытии обработки загрузки/выгрузки проводок

MAXXL
27 - 01.04.2009 - 12:05
Поставил 4 версию. Пока работает. Буду наблюдать. Всем спасибо за советы
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Проблема с перепроведением документа Общий реквизит документов »
© 2009 Форум 1С: Одинэс.Ру