Изменил конфигурацию, но изменения не применились

Форум 1С: Одинэс.Ру

Найти!

Изменил конфигурацию, но изменения не применились

moTUZ
19.02.2009 - 07:42
Добрый день. Подскажите пожалуйста изменил в кофигураторе конфигурацию документа. В модуле этого документа убрал одно правилило.Сохранил конфигурацию. Запускаю 1С , этот документ - правило как было так и осталось, хотя по модулям такого правила нет. Я конечно не програмист в 1с но приходится этим заниматся.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
21.10.2020 - 16:00
Смотри также:
Можно ли вывести на экран таблицу значений, если ее нет на форме?
Выгрузка зарплаты на пластиковые карты из 7.7 УСН
Холивар: для тех, кто не читает Апгрейд

Re: Изменил конфигурацию, но изменения не применились

Uho
1 - 19.02.2009 - 07:43
что такое правилило?

Re: Изменил конфигурацию, но изменения не применились

Mitrich
2 - 19.02.2009 - 07:44
(0) Архивную-то копию перед заколбашиванием сделать не забыл? Или как обычно?
В модулях документов в 7.7 я никаких "правил" не вижу. Что это такое?

Re: Изменил конфигурацию, но изменения не применились

moTUZ
3 - 19.02.2009 - 07:47
ну не правило а условие, тоесть при сохранение документа он проверяет если одно значения равно томуто то тогда не сохраняет, ну и т.д. (я просто хз как это называется) архивную копию сделал

Re: Изменил конфигурацию, но изменения не применились

Uho
4 - 19.02.2009 - 08:04
Ну тады попорядку.
Что за конфигурация
Что за документ
Где изменял
Какое "правило" изменял

Re: Изменил конфигурацию, но изменения не применились

lalex23
5 - 19.02.2009 - 08:06
всё чудесатее и чудесатее сегодя ветки одна за одной...

Интересные темы

odines.ru
21.10.2020 - 16:00
Смотри также:
Как еще русифицировать дисплей покупателя???
Журнал регистрации
Изменены все диалоги конфигурации

Re: Изменил конфигурацию, но изменения не применились

bvk
6 - 19.02.2009 - 08:10
Не ту конфигурацию менял или не тот документ.:)

Re: Изменил конфигурацию, но изменения не применились

moTUZ
7 - 19.02.2009 - 08:12
документ "Заявка", изменял заходил в конфигуратор заходил в форму документа  в модуль,
Удалил строчку в фукнкции Проверка при записи
Если (ПустоеЗначение(Контрагент)=1) и (ПустоеЗначение(Клиент)=1) Тогда
глПровРекв(ОК,"","Не указан клиент");
КонецЕсли;

Re: Изменил конфигурацию, но изменения не применились

lalex23
8 - 19.02.2009 - 08:14
(7)Уважаемый. Вы бредите - в моей конфигурации в модуле формы документа нет таких строк, можете убедиться:
//**************************************************
Процедура ПриЗаписи()
Если Аптека.Выбран() = 0 Тогда
Предупреждение("Не выбрана аптека");
СтатусВозврата(0);
Возврат;
КонецЕсли;
 
Если Фирма.Выбран() = 0 Тогда
Предупреждение("Не выбрана фирма");
СтатусВозврата(0);
Возврат;
КонецЕсли;
 
КонецПроцедуры
 

Re: Изменил конфигурацию, но изменения не применились

moTUZ
9 - 19.02.2009 - 08:16
Конфигурация настроена под сервисный центр по ремонту бытовой техники, весь модуль скинуть????

Re: Изменил конфигурацию, но изменения не применились

Vacony
10 - 19.02.2009 - 08:29
Вы уверены что это был конфигуратор именно рабочей базы в который вы проверяете ?
Вы уверены что данная проверка стоит только один раз в одном месте ?
Напиши вместо тех строк строку
Сообщить("У Тати красавы волосы росли");
сохраните, запустите 1С предприятие.
При проведении документа Заявка появляется данная надпись ?

Re: Изменил конфигурацию, но изменения не применились

Duke1C
11 - 19.02.2009 - 08:32
(9) КОНЕЧНО ВЕСЬ, а еще лучше весь MDшник, чтоб мы тут его сами поправили и заодно еще пару-тройку каких-нить ваших хотелок внедрили - завтра же тяпница...
А если серьёзно, то смотри (6), плюс проверка может быть не только  в модуле формы документа, а и в модуле документа...
А если СОВСЕМ серьёзно, то тебе лучше вообще там ничего не трогать, а то потом начнуться вопросы про кривые отчеты, не закрывающиеся регистры и т.д.

Re: Изменил конфигурацию, но изменения не применились

moTUZ
12 - 19.02.2009 - 08:44
да конфигуратор рабочей базы, проверял через поиск во всех текстах "Не указан клиент" не где не находит, при изменение текста выводит "Не указан клиент"

Re: Изменил конфигурацию, но изменения не применились

Vacony
13 - 19.02.2009 - 08:46
(12) Сделайте что я попросил в (10). Чудес не бывает.

Re: Изменил конфигурацию, но изменения не применились

Looking
14 - 19.02.2009 - 08:47
(12):) поищи по слову "указан", может пробелы лишние в строке поиска, иногда модули выводят во внешние текстовые файлы (#ЗагрузитьИзФайла ..\ХХХ\ххх.txt), там ещё поищи.

Re: Изменил конфигурацию, но изменения не применились

мыша007
15 - 19.02.2009 - 09:48
пройдись отладчиком, вообще у меня такая ерунда в 8-ке была в клиент-серверном варианте, я просто добавила комментарий и еще раз сохранила - помогло
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Типовая конфигурация для бюджетных учреждений ред.6.1 7.70.632 может кто ставил? Вывод доп.полей в своем справочнике контрагентов. Как грамотнее сделать?... »
© 2009 Форум 1С: Одинэс.Ру