Вопрос о ПриУдаленииДокумента(Док, Реж)

Форум 1С: Одинэс.Ру

Найти!

Вопрос о ПриУдаленииДокумента(Док, Реж)

kvitalka
24.07.2009 - 14:31
Нужно сделать определенные действия до удаления документа и после.
В предопределенной процедуре ПриУдаленииДокумента(Док, Реж) я я сделаю действия ДО, а как сделать после?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 02:55
Смотри также:
Выгрузка в казначейтсво Бух Бюджет 7.7
1С вылетает в терминальном режиме при печати на принтере самсунг 2015
v7: Убрать пустые значения в запросе.

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

kvitalka
5 - 24.07.2009 - 14:44
по моему в пределах одной процедуры это не пройдет

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
6 - 24.07.2009 - 14:48
А какое у документа состояние после удаления?)))

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

Uho
7 - 24.07.2009 - 14:48
что может произойти с состоянием документа в момент удаления, кроме как не установка/снятие пометки удаления (или вообще удаления документа)?

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
8 - 24.07.2009 - 14:49
(5)Наведите порядок в своей голове. Достаточно в лог записать, что документ удален

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
9 - 24.07.2009 - 14:50
(4)Такого бреда давно не видывал ))

Интересные темы

odines.ru
20.10.2020 - 02:55
Смотри также:
Запросы к БухИтогам
Подскажите, плиз, код или ВК, который(ая) фиксирует время простоя 1С-ины и запускает определенную обработку
Почему поле недоступно сразу

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

kvitalka
10 - 24.07.2009 - 14:51
USSS - дошло! Зачем дожидатся состояния - помечен на удаления, если он и так станет помеченым на удаление.
 
Напишу еще одну обработку Обработка.ЗаписатьПослеУдаления и все)))

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

kvitalka
11 - 24.07.2009 - 14:52
Спасибо - тема закрыта.

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
12 - 24.07.2009 - 14:52
ПриУдалении - процедура, вызываемая до выполнения операции. Вы поймали это действие и соглашайтесь с ним, либо отказывайтесь, логируйте, делайте что хотите

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
13 - 24.07.2009 - 14:53
(10)Что записать после удаления? я щас умру )))

Re: Вопрос о ПриУдаленииДокумента(Док, Реж)

USSR
14 - 24.07.2009 - 14:57
вот например:
// ----------------------------------------
Процедура ПриУдаленииДокумента(Докум,Режим)
 
//  -- ААА
Если  глПроверкаПраваНаОперациюСОбъектомМетаданных ("Документ." + Докум.Вид(), "Удаление") = 0 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;    
//  -- ААА
 
СтатусВозврата(глПриУдаленииДокумента(Докум));
    
Если СтатусВозврата() = 0 Тогда
Возврат;
КонецЕсли;
 
Если Режим = 0 Тогда
Если Докум.ПометкаУдаления() = 0 Тогда
глЛогДокумента (Докум, 1, "Пометка на удаление");
Иначе
глЛогДокумента (Докум, 1, "Отмена пометки на удаление");
КонецЕсли;
Иначе
глЛогДокумента (Докум, 2, "Удаление");
КонецЕсли;
 
КонецПроцедуры // ПриУдаленииДокумента()
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Ошибка разделения доступа к 1Cv7.MD Выгрузка Бух баланса (вер 5.1) »
© 2009 Форум 1С: Одинэс.Ру