Глюк с БИ или я чё-то не понимаю

Форум 1С: Одинэс.Ру

Найти!

Глюк с БИ или я чё-то не понимаю

aladdin
03.02.2009 - 18:02
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСубконто1, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
Ит.ИспользоватьКорСубконто(,, 1);
Ит.ИспользоватьКорСубконто(ВидыСубконто.Номенклатура,, 1);
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "10",,, 3, "Операция", "СК");
Ит.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
// Если тут в отладчике смотреть например,  Ит.СКД() - считает ерунду
Например период 1-31 число, Бочка, на начало нет, потом у нее операция (обе проводки в ней), сделанная 1-го числа:
Д10 НашСклад К20   107
Д10...  К10 НашСклад  107
В отладчике в указанном останове: СНД=0, ДО=107, КО=0 ,  СКД=107
ЧТО ЭТО!?  И еще к тому же Ит.НачДата=1.12.08   Ит.КонДата=1.12.08
Подскажите, в чем тут дело?
К списку тем 1 > К списку форумов

Re: Глюк с БИ или я чё-то не понимаю

Ctrl P
5 - 03.02.2009 - 19:37
Сч10 = "10.1, 10.2, 10.3, 10.4, 10.5, 10.6";
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСубконто1, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
Ит.ИспользоватьКорСубконто(,, 1);
Ит.ИспользоватьКорСубконто(,, 1);
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, Сч10,Сч10+", 20, 23, 25, 26, 16, 10.7,08.3,08.4,60,71,91.1,91.2,94,97",, 3,, "СК");
Таб.ВывестиСекцию("Заголовок");
Сформировать_Колонки(Ит, Таб, "Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
КолСтрокНастранице = 28;
ТекСтрока = 0;
Ит.ВыбратьСчета();
Пока Ит.ПолучитьСчет() = 1 Цикл
Ит.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
Если ТекСтрока = КолСтрокНастранице Тогда
ТекСтрока = 0;
КонецЕсли;
ТекСтрока=ТекСтрока+1;
Сформировать_Колонки(Ит, Таб, "Субконто1");
КонецЦикла;
Сформировать_Колонки(Ит, Таб, "Счет");
КонецЦикла;
Сформировать_Колонки(Ит, Таб, "Подвал");

Re: Глюк с БИ или я чё-то не понимаю

Ctrl P
6 - 03.02.2009 - 19:38
Процедуру Сформировать_Колонки() не покажу, т.к. там черт ногу сломает, сам уже фиг пойму как это работает... :)

Re: Глюк с БИ или я чё-то не понимаю

Buhta
7 - 03.02.2009 - 20:16
Если про материальный отчет, то тоже где-то что-то подобное валялось... искать сейчас лень. вначале было сделано через одно место, т.к. фичу про
ИспользоватьКорСубконто() без параметров не знала, потом вроде переделала поприличнее, только давно не видела, мож потерялся при переезде на другой комп

Re: Глюк с БИ или я чё-то не понимаю

user1C
8 - 03.02.2009 - 20:32
:))
 
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСубконто1, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
 
местами менять не пробовал?

Re: Глюк с БИ или я чё-то не понимаю

Ctrl P
9 - 03.02.2009 - 20:39
8 зачем?

Re: Глюк с БИ или я чё-то не понимаю

user1C
10 - 03.02.2009 - 20:55
(9)
да так, пища для ума...

Re: Глюк с БИ или я чё-то не понимаю

aladdin
11 - 04.02.2009 - 09:31
(1) Зто не 10.7, а 107 руб. Хочу материальный отчет но с парой извращений (нужно будет из него выкинуть всеручные операции - поэтому и периодичность такая и нужно будет по одному из счетов(20) обратиться не к 1-му, а ко второму субконто-Номенклатура - отсюда второе ИспользоватьКорСубконто)
(2)Не понимаю - почему без сумм? И Суммы, и количество есть, я же говорю, что Ит.ДО()=107  ИТ.КО()=0  -  как будто он мне дает результат после первой проводки в операции?!
(3) Места хранения на всей 10-ке есть
(4) да, это продолжение ;))  Сейчас попробую (5), но что даст заместо моего
Ит.ИспользоватьКорСубконто(,, 1);
Ит.ИспользоватьКорСубконто(,, 1);
И не совсем понял - ,Сч10,Сч10+", 20,   ЧтоЭто?
И кстати - вчера опытным путем выяснил - если убираю второе ИспользоватьКорСубконто (Ит.ИспользоватьКорСубконто(ВидыСубконто.Номенклатура,, 1)  - все работает корректно...

Re: Глюк с БИ или я чё-то не понимаю

aladdin
12 - 04.02.2009 - 10:36
помогло
Ит.ИспользоватьКорСубконто(,, 1);
Ит.ИспользоватьКорСубконто(,, 1);
Теперь корректно считает - обороты и остатки
 
Типа "при установке использования субконто/корсубконто в бух.запросе в него не попадут данные по счетам, не имеющим хотя бы одного используемого субконто/корсубконто. Т.е. если ты установишь использование двух субконто, то данные по счетам, на которых есть только одно из двух указанных субконто, в результат запроса не попадут." (не моё)

Re: Глюк с БИ или я чё-то не понимаю

Buhta
13 - 04.02.2009 - 13:54
(11) Нетиповая? В типовой бух на счете 10.7 другие виды субконто и на 10.11 тоже. А от суммы в 107 р счет 10.7 могу отличить:)

Re: Глюк с БИ или я чё-то не понимаю

Cthulhu
14 - 04.02.2009 - 23:05
(12): ну и сказал бы чьё...
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»