Групповая печать документов Бюджет 631 релиз

Форум 1С: Одинэс.Ру

Найти!

Групповая печать документов Бюджет 631 релиз

Tron
10.04.2009 - 08:36
Имеется задача - необходимо иметь возможность распечатать все документы (заявки на кассовый расход) за один день определенным количеством копий.
 
Сломал моск решая эту задачу - помогите кому сколько не жалко)))
 
Имея вот такую обработку
 

Процедура Выполнить()
Док=СоздатьОбъект("Документ.ЗаявкаНаКассовыйРасход");
Док.ВыбратьДокументы(ВыбНачПериода, ВыбКонПериода);
НачатьТранзакцию();
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ПометкаУдаления()=0 Тогда  
 

 

КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцию();
 
КонецПроцедуры
 

Необходимо сразу распечатать без предпросмотра 2 экземпляра.
 
Хотябы в каком направлении ковырять подскажите)) (простой способ с передиранием модуля и печатной формы как было с платежными поручениями в случае с заявкой не осилил( с подсчетом страниц запутался:)
К списку тем К списку форумов

Интересные темы

odines.ru
22.10.2020 - 09:38
Смотри также:
Восстановление базы SQL
Нужно в бухгалтерии дописать торговлю
Выводить отсортированными по алфавиту не получается...

Re: Групповая печать документов Бюджет 631 релиз

asupsam
1 - 10.04.2009 - 09:46
Это вставить в серединку
  Параметр = СоздатьОбъект("СписокЗначений");
  Параметр.Установить("Действие","Печать");
  Параметр.Установить("СразуНаПечать", 1);
  ОткрытьФорму(Док.ТекущийДокумент(),Параметр);
 
И подкорректировать форму дока ЗаявкаНаКР процедуру "приОткрытии"
раскоментив строку //СразуНаПечать = ....

Re: Групповая печать документов Бюджет 631 релиз

Tron
2 - 10.04.2009 - 10:23
(1) Спасибо большое.
Раскоментил
 
СразуНаПечать= Форма.Параметр.Получить("СразуНаПечать");
ПоКнопкеПечать(СразуНаПечать);
 
И все заработало.
Один вопрос - есть возможность задать количество копий - например 2?

Re: Групповая печать документов Бюджет 631 релиз

Tron
3 - 10.04.2009 - 10:40
Все, вопрос снимается.
В Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1) КолЭкз = 2 сделал. Все заработало.
 
Казначейство требует чтобы им заявки по суммам раскладывали а когда в один день 250-300 платежей - в общем UNIPROCS сортирую и этой обработкой печатаю.
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Выгрузка из 1С в ЕГАИС в формате xml Глюк с БИ или я чё-то не понимаю »
© 2009 Форум 1С: Одинэс.Ру