Можно ли из модуля документа?

Форум 1С: Одинэс.Ру

Найти!

Можно ли из модуля документа?

нагчампа
14.03.2009 - 15:42
как нибудь поменять реквизит его табличной части? Нужно это сделать именно не из номера формы.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 20:08
Смотри также:
отправка по почте
Число прописью?!
1-НДФЛ

Re: Можно ли из модуля документа?

Дятeл
1 - 14.03.2009 - 16:08
что мешает?

Re: Можно ли из модуля документа?

pit
2 - 14.03.2009 - 16:21
(1) наверное, хвост....

Re: Можно ли из модуля документа?

нагчампа
3 - 14.03.2009 - 18:39
:)
Делаю через УстановитьАтрибут.
После этого мне из модуля документа надо все это дело как то записать.
ТекущийДокумент() спозиционирован вроде правильно.А на Записать() говорит что документ не выбран.
 

Re: Можно ли из модуля документа?

Дятeл
4 - 14.03.2009 - 18:42
в какой процедуре?

Re: Можно ли из модуля документа?

нагчампа
5 - 14.03.2009 - 18:45
В обработке проведения.

Интересные темы

odines.ru
20.10.2020 - 20:08
Смотри также:
Как из 1С отсортировать excel-таблицу программно через ОЛЕ
Бюджетка. 631 релиз - при обновлении ошибка...
Как определить в запросе |ВидДок = Регистр.Партии.ТекущийДокумент.Вид();?

Re: Можно ли из модуля документа?

Дятeл
6 - 14.03.2009 - 19:00
а пробовал просто изменить и ни каких дополнительных Записать?

Re: Можно ли из модуля документа?

нагчампа
7 - 14.03.2009 - 19:02
ага. Тогда я в документ из отчета лезу и те поля пустые.

Re: Можно ли из модуля документа?

нагчампа
8 - 14.03.2009 - 19:04
по идее он жешь из модуля записывает только созданные операции и ему плевать, что я там реквизиты в табличной части еще меняю. А вот как то надо сделать.

Re: Можно ли из модуля документа?

Дятeл
9 - 14.03.2009 - 19:09
в демо ТиС такой код успешно зануляет всё количество:
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
    Количество = 0;
КонецЦикла;

так что проблема на вашей стороне... код покажи

Re: Можно ли из модуля документа?

нагчампа
10 - 14.03.2009 - 19:14
ддд=ТекущийДокумент();      
ддд.ВыбратьСтроки();
Пока ддд.ПолучитьСтроку()=1 Цикл    
себест=СуммаОтгрузки;          
КонецЦикла;                                        
 
или так
ддд=ТекущийДокумент();      
ддд.ВыбратьСтроки();
Пока ддд.ПолучитьСтроку()=1 Цикл    
УстановитьАтрибут("себест",СуммаОтгрузки);
КонецЦикла;                                        
 
Где себест - реквизит табличной части. При этом ТекущийДокумент показывает тот что надо и то, что присваиваю тоже.
 

            

Re: Можно ли из модуля документа?

Дятeл
11 - 14.03.2009 - 19:18
ну дык поменяй как в (9) и не ужен тебе ТекущийДокумент() - ты ж внутри объекта..

Re: Можно ли из модуля документа?

Мымра
12 - 15.03.2009 - 00:08
(10)не поняла...
каким тут ТекущийДокумент()?
Или мы обработке проведения одного документа меняем что-то в другом?    

Re: Можно ли из модуля документа?

нагчампа
13 - 15.03.2009 - 09:49
Ура, получилось, спасибо :)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Как убрать картинку 1С при загрузке? (+) OLE Объект в таблице »
© 2009 Форум 1С: Одинэс.Ру