Как вывести остатки?

Форум 1С: Одинэс.Ру

Найти!

Как вывести остатки?

nzi
24.01.2009 - 21:45
Пытаюсь просмотреть по текущей номенклатуре остаток на складе, чёто не получается
К списку тем 1 > К списку форумов

Re: Как вывести остатки?

Грязный Танка
1 - 25.01.2009 - 05:30
Сочувствую.

Re: Как вывести остатки?

aka AMIGO
2 - 25.01.2009 - 07:58
В 0:45 по-местному полагается смотреть сны, а не остатки.
либо уж открывать глаза, если сидишь за монитором :))

Re: Как вывести остатки?

биос
3 - 25.01.2009 - 11:24
(0) Так Вы скажите, в какой программе и конфигурации работаете, а после, может быть, и подсказка будет :-)

Re: Как вывести остатки?

Чучундер
4 - 25.01.2009 - 11:32
забъем, что Тис?

Re: Как вывести остатки?

биос
5 - 25.01.2009 - 11:36
(0) Похоже, но не факт. А "забивать" с "сильными мира сего" не хочется - пролететь недолго :-))

Re: Как вывести остатки?

биос
6 - 25.01.2009 - 11:37
(5) адресовано для (4), сорри :-)

Re: Как вывести остатки?

Чучундер
7 - 25.01.2009 - 12:01
(5) зато и обогатиться можно! ;-)

Re: Как вывести остатки?

lalex23
8 - 25.01.2009 - 13:06
(4) имеешь в наличии  хрустальный шар?

Re: Как вывести остатки?

nzi
9 - 25.01.2009 - 14:13
Да действительно ТиС. Всё должно быть как-то просто, но у меня что-то не получается

Re: Как вывести остатки?

Грязный Танка
10 - 25.01.2009 - 14:33
(9) а ты старайся...

Re: Как вывести остатки?

МимохожийОднако
11 - 25.01.2009 - 14:43
Попробуй открыть отчет Остатки ТМЦ или на худой конец кнопка Подбор в документе Реализация с птичкой "Показывать остатки" на форме подбора

Re: Как вывести остатки?

Грязный Танка
12 - 25.01.2009 - 14:48
Хм... Думаешь он как чукча в анекдоте сидит перед компом и говорит:"Кампутера, капутера, пакажи астатки пажалуста, аднака!"? :) (твой ник ни причём, просто правда анекдот вспомнил:)

Re: Как вывести остатки?

nzi
13 - 25.01.2009 - 15:20
(11)До этого я уже догадался, но увы.
Но подбор это не документ, а форма справочника номенклатура (не надо Сусанина)
*************************************
ТекНоменклатура = ТекущийЭлемент<<?>>();
Функция не обнаружена (ТекущийЭлемент)
*************************************
 

Re: Как вывести остатки?

Грязный Танка
14 - 25.01.2009 - 16:20
О как дело то поворачивается! Вернись к русскому языку и изложи проблему подробно. Имхо ЖКК не читал. (нифига намёков не понимает!)

Re: Как вывести остатки?

nzi
15 - 25.01.2009 - 16:30
Что есть Имко ЖКК?

Re: Как вывести остатки?

nzi
16 - 25.01.2009 - 16:33
В ТиС нужно проверить есть ли номенклатура на розничном складе и в соответствии с ответом выполнить действия.

Re: Как вывести остатки?

nzi
17 - 25.01.2009 - 16:35
Ещё не могу найти как сделать косвенную ссылку на содержимое в переменной
Аналог:
Переменная="номенклатура";
ТаблицаЗначений.ЗначПеременной(Переменная)=...?

Re: Как вывести остатки?

Грязный Танка
18 - 25.01.2009 - 16:43
ЖКК - желто-красные книги. Книги с описанием встроенного языка имею в виду я. Ты не правильно используешь конструкции этого языка. Категорическт. В частности метод ТекущийЭлемент() должен использоваться как Номенклатура.ТекущийЭлемент() Где Номенклатура - идентификатор спозиционированного объекта типа Справочник.Номенклатура.

Re: Как вывести остатки?

nzi
19 - 25.01.2009 - 16:52
Это оригинал откуда пытаюсь взять:
*********************************************
Функция ИнформационнаяСтрокаПоНоменклатуре()
Перем ТовОстаток, ТовОстатокПоФирме, ТовЕдиница, ТовЦена, ТовВалюта;
 
ИнформационнаяСтрока = "";
 
ТекНоменклатура = ТекущийЭлемент();
 
Если (ТекНоменклатура.ЭтоГруппа() = 0)
   и (ПоказатьОстаткиЦену = 0)  Тогда        
 
Если ЦенаВподборе = "Розница" Тогда
Если (ТекНоменклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга)
или (ТекНоменклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Работа) Тогда
 
// Для услуг и работ розничную цену берем из справочника
глВернутьЦену(ТекНоменклатура, Константа.РозничныйТипЦен, ПолучитьДатуЦен(), ТовЦена, ТовЕдиница, ТовВалюта);
ТовОстаток = "";
ИнформационнаяСтрока = СформироватьИнфНадпись(ТовОстаток,, ТовЕдиница, ТовЦена, ТовВалюта);
 
Иначе // не услуга, розничная цена
глПолучитьРозничныйОстатокЦену(ТекНоменклатура, ТекНоменклатура.ОсновнаяЕдиница, ОстаткиТМЦ, ТовОстаток, ТовЦена);
*******************************************************
Почему у них да, а у меня мля

Re: Как вывести остатки?

nzi
20 - 25.01.2009 - 16:58
Авот что происходит если так
ТекНоменклатура = спр.ТекущийЭлемент();
глПолучитьРозничныйОстатокЦену(ТекНоменклатура, ТекНоменклатура.ОсновнаяЕдиница, ОстаткиТМЦ, ТовОстаток, ТовЦена);
***********************************
ОстаткиТМЦ.УстановитьЗначениеФильтра("Номенклатура", Номенклатура, 1);
{Глобальный модуль(1606)}: Значение не представляет агрегатный объект (УстановитьЗначениеФильтра)
 

Re: Как вывести остатки?

Buhta
21 - 25.01.2009 - 17:03
Развод какой-то. (20) хоть бы написал что вообще нужно и где ты это пишешь?

Re: Как вывести остатки?

nzi
22 - 25.01.2009 - 17:09
(21) прочитай в (16), а рассказываете про ЖКК.
 
УстановитьЗначениеФильтра(<Идентиф>,<Значен>,<Вариант>)
Как понять <значен>, что из себя это представляет?

Re: Как вывести остатки?

Грязный Танка
23 - 25.01.2009 - 17:15
(22) Ты здоров? До свиданья. Надоело тянуть из тебя сведения.

Re: Как вывести остатки?

nzi
24 - 25.01.2009 - 17:23
Процедура Сформировать()
перем Артрез;
спр = СоздатьОбъект("Справочник.номенклатура");
спр.ВыбратьЭлементы(0);
   Пока спр.ПолучитьЭлемент()=1 Цикл   
Если Спр.ЭтоГруппа() = 1 Тогда Продолжить; КонецЕсли;
    артрез = Сред(Спр.Артикул,2,3);
 
    //если нет на складе то в переменная АРТРЕЗ="нет на складе"
 
    ПереместитьЭлВГруппу(Артрез,спр.ТекущийЭлемент());
тз.НоваяСтрока();
КонецЦикла
КонецПроцедуры

Re: Как вывести остатки?

nzi
25 - 25.01.2009 - 17:24
ещё какие сведения?

Re: Как вывести остатки?

lalex23
26 - 25.01.2009 - 18:17
мистец

Re: Как вывести остатки?

Твинсен
27 - 25.01.2009 - 18:29
Потрясный код.

Re: Как вывести остатки?

nzi
28 - 25.01.2009 - 18:41
А по существу?

Re: Как вывести остатки?

Бармаглот
29 - 25.01.2009 - 19:20
На Буншу... бр-р-р... хаксера нашего похож...

Re: Как вывести остатки?

Твинсен
30 - 25.01.2009 - 19:36
*кивая* Вылитый Бунша.

Re: Как вывести остатки?

nzi
31 - 25.01.2009 - 20:29
Почему 1с'ки могут так, а я нет ТекНоменклатура = ТекущийЭлемент();

Re: Как вывести остатки?

nzi
32 - 25.01.2009 - 20:35
Хто есть бунша?

Re: Как вывести остатки?

lalex23
33 - 25.01.2009 - 21:45
(32) не бунша, а Бунша... классику надо знать!!!

Re: Как вывести остатки?

ПодОпытный
34 - 26.01.2009 - 10:14
Вот, спугнули вольнообитаемого дятла ...

Re: Как вывести остатки?

Жеглофф
35 - 26.01.2009 - 10:22
Я так и не понял, чего ему нужно то было? )

Re: Как вывести остатки?

USSR
36 - 26.01.2009 - 13:40
Смешались в кучу кони, люди, и залпы тысячи орудий ...Сначала было "как вывести остатки" кончилось непонятным переносом в какую то группу, идентифицированную по одному символу артикула, и добавлением строки в некую таблицу значений, причем без заполнения ее колонок. Однозначно развод

Re: Как вывести остатки?

reanimator
37 - 26.01.2009 - 14:35
Почему у глазных хирургов получается, а я как не возьмусь за пациента - бац! и глаз долой...
Вроде скальпель тот же :(

Re: Как вывести остатки?

Чучундер
38 - 26.01.2009 - 15:47
(37) Потому как ты "реаниматор" - получилось = чемпион, не получилось = а вы что хотели? осклик-то мертвый ;-)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»