Редактирование MD

Форум 1С: Одинэс.Ру

Найти!

Редактирование MD

Lada
13.02.2009 - 17:08
Подскажите хороший альтернативный редактор MD, позволяющий УДАЛЯТЬ объекты метаданных. Пробовал DocFile (плагин к Far'у), но он отображает ID объектов, а мне надо идентификаторы как они заданы в конфигурации.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 00:53
Смотри также:
7.Помогите организовать поиск по адресной строке в списке справочника
Помогите начинающему своё дело
Почему не выполняется "КомандаСистемы"?

Re: Редактирование MD

VZ
1 - 13.02.2009 - 19:35
И чем родной конфигуратор насолил? Он ведь как раз под это дело заточен.

Re: Редактирование MD

Lada
2 - 13.02.2009 - 22:32
Надо удалить порядка 700 (!) объектов. Объекты имеют ссылки друг на друга,
но не имеют ссылок на объекты которые должны остаться. Если пользоваться
конфигуратором, то надо сначала у этих объектов очистить ссылки друг на
друга, чтоб была возможность удалить. таких МД-шников около 50 шт. Все
разные (не потомки).

Re: Редактирование MD

КонецЦикла
3 - 14.02.2009 - 00:26
А может проще копипастом перенести то что должно остаться? :)
Короче поищи по слову gcomp
Он может помочь и после копипаста назначить нужные ИД (если надо вставить в рабочую базу)

Re: Редактирование MD

2Green
4 - 14.02.2009 - 00:31
а чем вы их плодили, 700 объектов эти?

Re: Редактирование MD

Lada
5 - 14.02.2009 - 01:14
3. Кипастом тоже не получится, поскольку 700 это даже не треть. т.е.
остается гораздо больше.
4. В разные времена они по разному использовались. Размер md 55 Мб :)

Интересные темы

odines.ru
22.10.2020 - 00:53
Смотри также:
выгрузка в txt файл
Люди, спасите немощных! Пиво-коньячный вопрос!
Хелп! Перестала работать "Выгрузить данные"

Re: Редактирование MD

МимохожийОднако
6 - 14.02.2009 - 04:37
(5)Подозреваю, что удаление объектов  только частная задача. Чем так мешают объекты? Зачастую проще перенести в новую необходимые объекты. Попробуй для начала создать отчет по метаданным и связям между ними. После этого поймешь, что можно удалять сразу. ИМХО, тараписса не нада.

Re: Редактирование MD

VZ
7 - 14.02.2009 - 05:44
Фигня какая-то... Если много объектов, теперь не нужных, то что мешает создать пустую БД как копию существующей, удалить ненужное, а затем тихо и без надрыва перенести соответствующие данные?
Или просто удалить ненужные таблицы, лишив метаданные содержания и так же легко удалить конфигуратором?
 
Кароче, "кризисный одноэсник", поменьше выдумывай, меньше совершишь открытий..

Re: Редактирование MD

Ctrl P
8 - 14.02.2009 - 07:55
создать пустую базу, объединить мдшкником, при объединении с помощью "пробела" снять 700 галочек... за 12 часов существования ветки уже можно было сделать...

Re: Редактирование MD

Gosha
9 - 14.02.2009 - 08:16
"надо сначала у этих объектов очистить ссылки друг на
друга, чтоб была возможность удалить" -- неа, НЕ надо (необязательно).

Re: Редактирование MD

Тёмный
10 - 14.02.2009 - 11:55
Видимо просто перепутано наличие ссылок на объекты конфигурации с существованием собственно данных в базе по этим объектам метаданных

Re: Редактирование MD

Lada
11 - 14.02.2009 - 12:55
9 ничего я не перепутал.
Объясняю:
Есть документ "МойДокумент", для которого определен журнал "МойЖурнал".
В журнал "МойЖурнал" есть графа, "МояГрафа" со значением
"МойДокумент.МойРеквизит"
Как удалить "МойДокумент" и "МойЖурнал"? Надо сначала очищать ссылки в
документе или в журнале, а потом уже удалять.
Ситуация осложняется количеством объектов и количеством MD-шников (РАЗНЫХ)

Re: Редактирование MD

Lada
12 - 14.02.2009 - 12:58
6. Именно так я и сделал.
7. Ничего не мешает.Кроме общего кол-ва объектом метаданных. Их несколько
тысяч и баз 50 штук разных

Re: Редактирование MD

Lada
13 - 14.02.2009 - 13:00
8. За 12 часов существования темы сделал 3 базы, осталось 47 :)

Re: Редактирование MD

Gosha
14 - 14.02.2009 - 14:44
(11): не надо.

Re: Редактирование MD

Lada
15 - 14.02.2009 - 15:06
Gosha, ты что думаешь я не пробовал?!
 

Re: Редактирование MD

bvk
16 - 14.02.2009 - 15:07
за пару недель закончишь, а сейчас иди отдыхай...

Re: Редактирование MD

VZ
17 - 14.02.2009 - 20:43
(12) Ты бы хоть похвастался, что это за чудо сейчас кромсаешь. Что было задумано так грандиозно, что случилось, что решили жить по новому... :)

Re: Редактирование MD

Lada
18 - 14.02.2009 - 21:33
17. Да хвастаться в общем то нечем, скорее наоборот, стыдится этого чуда надо.
Была задумана одна единая конфигурация для нескольких десятков разнопрофильных
предприятий. А жить по новому решаем каждый год после свертки баз :) Т.е. такая
зачистка проводится ежегодно, поскольку за год многое меняется, многое
добавляется

Re: Редактирование MD

leshik
19 - 15.02.2009 - 06:33
(18) Позвольте узнать - Lada - это имя или род деятельности (имеется ввиду автомобили)?

Re: Редактирование MD

Lada
20 - 15.02.2009 - 12:36
19. Lada это ник :))) А что? :)

Re: Редактирование MD

КонецЦикла
21 - 15.02.2009 - 21:36
Странный ник для мальчега :)

Re: Редактирование MD

КонецЦикла
22 - 15.02.2009 - 21:44
Аха-ха... жесть
50 МДшников непотомкоф
Счас только прочитал повнимательнее
Тут точно надо автоматизировать
Возможно кто часто пользовался gcomp'ом подскажет как лучше
ЗЫ. А если собираетесь навести порядок - можно и потерпеть да унифицировать такой зоопарк с переносом данных (все равно ведь останется 50 разных МД - не есть гуд мягко говоря)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Камин 2.0: Есть ли стандартные средства по работе со сдельщиками Ввод начальных остатков »
© 2009 Форум 1С: Одинэс.Ру