Почему не записывает документ

Форум 1С: Одинэс.Ру

Найти!

Почему не записывает документ

ubah
11.07.2009 - 17:04
Процедура ПриЗакрытии()
 

    
     Док=ТекущийДокумент();
 
      Док.ВыбратьСтроки();
Док.ПолучитьСтроку();  
 
Если СокрЛП(док.товар)="Товар" Тогда
Док.Комментарий="ТТТТТ" иначе  Док.Комментарий="ППП";    
КонецЕсли;
Сообщить(док.выбран());
Док.Записать();
КонецПроцедуры
 
Говорит документ не выбран
К списку тем К списку форумов

Интересные темы

odines.ru
22.10.2020 - 14:37
Смотри также:
нужно пособие.....
ДЕКЛАРАЦИЯ
ПУБ: есть ли правила для ввода сивола слэш?

Re: Почему не записывает документ

Дятeл
1 - 11.07.2009 - 17:27
док убери

Re: Почему не записывает документ

ubah
2 - 11.07.2009 - 17:31
Спасибки, все работает.

Re: Почему не записывает документ

USSR
3 - 12.07.2009 - 02:54
Это можно было делать в обработке подбора, чтобы лишний раз не записывать документ и не деогать базу

Re: Почему не записывает документ

Ctrl P
4 - 12.07.2009 - 08:50
Человек, не делай этого в процедуре ПриЗакрытии(), делай в ПриЗаписи()
 
ВыбратьСтроки();
ПолучитьСтроку();  
 
Если СокрЛП(товар)="Товар" Тогда
Комментарий="ТТТТТ" иначе  Комментарий="ППП";    
КонецЕсли;
----
что за манера менять "самопроизвольно" данные без ведома пользователя. Открыл юзер глянуть в форме запятую правильно ли поставил, проверил - правильно - закрыл, а она тебе (программа) оп и записала сама, а если он с дуру че нить стер случайно или исправил не так и все вариантов откатиться нет?
или в ПриОткрытии пихнут код из 0, открыл ниче не делал, закрываешь, а она тебе "Записать документ?" я то понимаю что "НЕТ". Но юзер то пугливый, жмет "ДА", а вдруг Последовательность используется или документ "долгоиграющий" медленно проводится и всё - все курят...
ЗЫ: опять же, а почему проверяем только 1 - первую строку?
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« класс РедакторТЗ При изменении реквизита документа из вызываемой обработки не устанавливается признак модифицированности. »
© 2009 Форум 1С: Одинэс.Ру