ТиС, продажи по дням

Форум 1С: Одинэс.Ру

Найти!

ТиС, продажи по дням

Dimon1C
25.05.2009 - 11:28
Помогите составить запрос для получения данных о продажах по номенклатуре (или группам номенклатуры), по дням заданного периода. Также возможна группировка по контрагентам.
Например:
         01.01.2009 02.01.2009 03.01.2009
Товар1      100          0         160
Товар2        0         100        200
Товар3      300          0          0
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
31.10.2020 - 22:18
Смотри также:
помогите отловить "Ошибка при выполнении команды"
В SQL база вылетает при открытии документа "Отмена заявок"
v7: ТИС: Автоматическое перемещение товара между фирмами

Re: ТиС, продажи по дням

Sasha
1 - 25.05.2009 - 11:32
Группировка День Все ВошедшиеВЗапрос ( или просто Все)
 
Таб.ПрисоединитьСекцию("Строка|ПродажиПоДням");

Re: ТиС, продажи по дням

roma n
2 - 25.05.2009 - 11:33
Запрос точно такой же как и для случая
Товар1
--01.01 -100
--02.01 -0
--03.01 -160
....

Re: ТиС, продажи по дням

Dimon1C
3 - 25.05.2009 - 11:52
вот запрос:
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|ТекущийЭлемент = Регистр.Продажи.Номенклатура.ТекущийЭлемент;
|Количество = Регистр.Продажи.Количество;
|ПродСтоимость = Регистр.Продажи.ПродСтоимость;
|Функция ПродСтоимостьСумма = Сумма(ПродСтоимость);
|Группировка ТекущийЭлемент;
|Группировка День все;
|"//}}ЗАПРОС
;
 
почему то не выдает итоги по группам номенклатуры?

Re: ТиС, продажи по дням

КвазиСпец
4 - 25.05.2009 - 12:32
А зачем ТекущийЭлемент в регистре?

Re: ТиС, продажи по дням

Dimon1C
5 - 25.05.2009 - 13:24
(4) А как правильно? я дизайнером делал

Интересные темы

odines.ru
31.10.2020 - 22:18
Смотри также:
Как вытащить SQL идентификаторы реквизитов..
Бухгалтерия, модернизация ОС
Как правельно выбрать элементы

Re: ТиС, продажи по дням

КвазиСпец
6 - 25.05.2009 - 13:31
|ТекущийЭлемент = Регистр.Продажи.Номенклатура;
должно прокатить

Re: ТиС, продажи по дням

Vacony
7 - 25.05.2009 - 13:34
вот слово ВСЕ  для дня я бы пропустил, а то если продажи 1 и 30 числа только будут 30 колонок :)

Re: ТиС, продажи по дням

Dimon1C
8 - 26.05.2009 - 03:22
(6) Не помогло, все равно нет итогов по группам номенклатуры

Re: ТиС, продажи по дням

Umka2008
9 - 26.05.2009 - 06:30
(0) - студент что ль?

Re: ТиС, продажи по дням

Vacony
10 - 26.05.2009 - 06:35
(9) очень креативно и свежо и главное поможет (0)
 
(8) начнем с простого. возьми любой универсальный отчет - посмори им за период свои продажи. Данные есть вообще ?
Потом в запросе ТекущийЭлемент замени на всякий пожарный на любое другое - Товар например. Дальше - регистр у тебя обортный ?
Ну и самое галвное - что ты видишь своим запросом то и как это смотришь ? Может ты запрос.выгрузить пишешь без выгрузки итогов ?

Re: ТиС, продажи по дням

Dimon1C
11 - 26.05.2009 - 10:47
(8) данные есть, т.к. даже этот запрос выдает данные по позициям номенклатуры
 
Может не правильно вопрос задал, я имею ввиду итоги по дням для каждой группы номенклатуры
 
Вот вся процедура:
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с НачПериода по КонПериода;
|Товар = Регистр.Продажи.Номенклатура;
|Количество = Регистр.Продажи.Количество;
|ПродСтоимость = Регистр.Продажи.ПродСтоимость;
|Функция ПродСтоимостьСумма = Сумма(ПродСтоимость);
|Группировка Товар;
|Группировка День все;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
 
//Запрос.Выгрузить(тз, 3);
 
// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок|Начало");
 
Для ном = 0 По КонПериода-НачПериода Цикл
День = НачПериода + ном;
Таб.ПрисоединитьСекцию("Заголовок|ДеньПродажи");
КонецЦикла;
 
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
Таб.ВывестиСекцию("Строка|Начало");
Пока Запрос.Группировка(2) = 1 Цикл
Таб.ПрисоединитьСекцию("Строка|ДеньПродажи");
КонецЦикла;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
 
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры

Re: ТиС, продажи по дням

Dimon1C
12 - 26.05.2009 - 10:48
Хочу видеть вот так:
         д1 д2 д3
Группа1  50 20 30
  ном1   10 10 10
  ном2   40 10 20
Группа2  60 60 10
...

Re: ТиС, продажи по дням

Umka2008
13 - 26.05.2009 - 11:04
Ну и че у тебя не получается?

Re: ТиС, продажи по дням

Dimon1C
14 - 26.05.2009 - 11:14
(13) Если ничем помочь не можешь, зачем тогда пишешь.

Re: ТиС, продажи по дням

Umka2008
15 - 26.05.2009 - 11:22
Сделай
Запрос.Выгрузить(тз);
потом
ТЗ.ПолучитьСтроку()
есть ИТОГИ?

Re: ТиС, продажи по дням

Dimon1C
16 - 26.05.2009 - 11:26
(15) Ты слишком умный чтоб меня понять. Пройди мимо.

Re: ТиС, продажи по дням

КвазиСпец
17 - 26.05.2009 - 11:35
Вот теперь понятно! Тебе нужны ГРУППЫ? В (0) ты сказал просто о номенклатуре...
Так группы в запрос по регистрам не попадают.

Re: ТиС, продажи по дням

Umka2008
18 - 26.05.2009 - 11:35
бывай

Re: ТиС, продажи по дням

Dimon1C
19 - 26.05.2009 - 11:38
(17) Как быть?

Re: ТиС, продажи по дням

КвазиСпец
20 - 26.05.2009 - 11:41
Примерно так:
        д1 д2 д3
Группа1  
  ном1   10 10 10
  ном2   40 10 20
всего по группе 50 20 30
Группа2  
...
А итоги получать накоплением при обходе цикла группировки.

Re: ТиС, продажи по дням

Гуня
21 - 26.05.2009 - 12:58
Добавь в запрос справочник номенклатура
|ТекущийЭлемент = Регистр.Продажи.Номенклатура.ТекущийЭлемент, Справочник.Номенклатура.ТекущийЭлемент;

Re: ТиС, продажи по дням

Чучундер
22 - 26.05.2009 - 15:53
Есть готовая обработка для типовой ТиС.
если есть предметный разговор - стучись в мыло.
поищи на инфостарте также.
.если хочешь сам, тогда тривиально...
создай запросом ПЛОСКУЮ ТЗ вида
контрагент-товар-дата
и подсунь ее в этот универсальный отчет (и хоть обстройся нужных тебе шахматок и группировок) http://www.infostart.ru/projects/942/
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Поиск партии по мпз выгрузка печатной формы в формате Excel »
© 2009 Форум 1С: Одинэс.Ру