Как найти документы, в которых присутствует реквизит определённого типа

Форум 1С: Одинэс.Ру

Найти!

Как найти документы, в которых присутствует реквизит определённого типа

ЗашелСпросить
17.07.2009 - 07:51
День добрый, господа! Второй день не приходит в голову каким образом можно организовать поиск документов по конфигурации, в которых присутствует реквизит определённого вида. Проще говоря, требуется найти все виды документов, в которых присутствует реквизит с типом "справочник.контрагенты". Всем заранее спасибо
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
25.10.2020 - 19:49
Смотри также:
УСН- Налоги и отчисления-ПФР
Плиз, 1SJOURN.DBF - разрушена таблица, как восстановить?
Налог на прибыль - КПП выводится только на титульном листе

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
1 - 17.07.2009 - 08:04
Для Каждого Документ Из Метаданные.Документы Цикл
//реквизиты шапки
Для Каждого Реквизит Из Документ.Реквизиты Цикл
.....
КонецЦикла;
//реквизиты табличных частей
Для Каждого ТЧ Из Документ.ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТЧ.Реквизиты Цикл
....
КонецЦикла;
КонецЦикла;
КонецЦикла;

Re: Как найти документы, в которых присутствует реквизит определённого типа

chief accountant
2 - 17.07.2009 - 08:08
Метаданные.ОбщийРеквизитДокумента(ИмяРеквизита)
Метаданные.Документ(ВидДокумента).РеквизитШапки(ИмяРеквизита)
Метаданные.Документ(ВидДокумента).РеквизитТабличнойЧасти(ИмяРеквизита)

Re: Как найти документы, в которых присутствует реквизит определённого типа

pit
3 - 17.07.2009 - 08:25
я же тебе сказал - гони 500000 копеек...

Re: Как найти документы, в которых присутствует реквизит определённого типа

ЗашелСпросить
4 - 17.07.2009 - 08:38
3 - сделаем, шеф :)) сами
ужо всё интереснее становится

Re: Как найти документы, в которых присутствует реквизит определённого типа

iogri
5 - 17.07.2009 - 08:47
+1,2
Я бы на всяк случай добавил в отбор реквизиты типа "Справочник" и неопределенного типа - там тоже могут быть контрагенты.

Интересные темы

odines.ru
25.10.2020 - 19:49
Смотри также:
Вопрос по таблице (печатной :))
Инициализация меню в зависимости от значения константы
выгрузка из УСН в УСН

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
6 - 17.07.2009 - 08:52
+1 сорри, подумал, что восьмерка
 
тогда так:
 
Для счДок=1 По Метаданные.Документ() Цикл  
//реквизиты шапки
Для счРек=1 По Метаданные.Документ(счДок).РеквизитШапки() Цикл  
Тип=Метаданные.Документ(счДок).РеквизитШапки(счРек).Тип;
Вид=Метаданные.Документ(счДок).РеквизитШапки(счРек).Вид;
Если (Тип="Справочник") И (Вид="Контрагенты") Тогда
...
КонецЕсли;
КонецЦикла;
//реквизиты ТЧ
Для счРек=1 По Метаданные.Документ(счДок).РеквизитТабличнойЧасти() Цикл
Тип=Метаданные.Документ(счДок).РеквизитТабличнойЧасти(счРек).Тип;
Вид=Метаданные.Документ(счДок).РеквизитТабличнойЧасти(счРек).Вид;
Если (Тип="Справочник") И (Вид="Контрагенты") Тогда
...
КонецЕсли;
КонецЦикла;
КонецЦикла;

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
7 - 17.07.2009 - 08:53
+5 ну еще и общие реквизиты тогда в кучу

Re: Как найти документы, в которых присутствует реквизит определённого типа

chief accountant
8 - 17.07.2009 - 08:57
(6) А зачем все реквизиты перебирать? Достаточно .Выбран()

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
9 - 17.07.2009 - 08:59
(8) известен только тип

Re: Как найти документы, в которых присутствует реквизит определённого типа

Мисти
10 - 17.07.2009 - 09:24
А просто - "поиск ссылок на объект" - не нравится?

Re: Как найти документы, в которых присутствует реквизит определённого типа

chief accountant
11 - 17.07.2009 - 09:35
9-Uho >Точно, торможу однако :)

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
12 - 17.07.2009 - 10:09
10-Мисти > речь не об объекте, а о реквизите определенного типа

Re: Как найти документы, в которых присутствует реквизит определённого типа

roma n
13 - 17.07.2009 - 10:12
(12) Поиск ссылок на объект есть и в пофигураторе :)
Вопрос только для чего это нужно (0)

Re: Как найти документы, в которых присутствует реквизит определённого типа

Мисти
14 - 17.07.2009 - 10:14
Объект: Справочник.Контрагенты использован в:
Справочник.Договоры
Справочник.НалогиИОтчисления.Получатель
Справочник.РасчетныеСчета
Документ.ВыплатаЗПКасса.Контрагент
Документ.ВыполнениеЭтапаРабот.Контрагент
Документ.Доверенность.Плательщик
Документ.Доверенность.Поставщик
Документ.ЗавершениеРабот.Контрагент
...
Разве это не то???

Re: Как найти документы, в которых присутствует реквизит определённого типа

ЗашелСпросить
15 - 17.07.2009 - 10:15
13 - обработку пишу для подмены "клонов" разных по "контрагентам". Недавно граждане пришли и "навыгружали" из какого-то стороннего софта в Бухгалтерию... Щас контрагентов развелось...

Re: Как найти документы, в которых присутствует реквизит определённого типа

ЗашелСпросить
16 - 17.07.2009 - 10:16
+15 Кстати, Господа, на ИТС нашёл такую по смыслу обработку...
хе...
ток она какая-то не совсем живая - ни один кнопарик не работаетъ :))

Re: Как найти документы, в которых присутствует реквизит определённого типа

ЗашелСпросить
17 - 17.07.2009 - 10:22
Называется "Замена значений"
Щас вот её ковыряю
Странно это всё конечно

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
18 - 17.07.2009 - 10:46
15-ЗашелСпросить >обработку пишу для подмены "клонов" разных по "контрагентам"
тогда самое оно, поиск ссылок на объекты с одновременной их подменой (только не забудь, что надо еще и договора, например, подменять)
13-roma n >я почему то думал, что там поиск только объектов, а не типов, однако и типы есть...

Re: Как найти документы, в которых присутствует реквизит определённого типа

Бертыш
19 - 17.07.2009 - 11:11
(14) Это в конфигураторе, а ему в коде нужно

Re: Как найти документы, в которых присутствует реквизит определённого типа

Uho
20 - 17.07.2009 - 11:19
+19
13-roma n > блин, думал ты про НайтиСсылки() :)))))))
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Бух 7.7 - отдельный учёт НДС для товара внутри страны и экспортного. ПУБ Нереальные суммы корректировки стоимости материалов полученных в переработку и переданных в переработку. »
© 2009 Форум 1С: Одинэс.Ру