Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

Форум 1С: Одинэс.Ру

Найти!

Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

OlegKZ
27.05.2009 - 05:43
Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>". На БИ.Операция говорит "Опрация".
Вот запрос:
бухи.выполнитьзапрос(НачДата,КонДата);
бухи.выбратьСубконто();            
Пока бухи.ПолучитьСубконто()=1 Цикл
  Сообщить("Док="+бухи.Операция.Документ)
КонецЦикла;
Что не так?
К списку тем К списку форумов

Интересные темы

odines.ru
21.10.2020 - 18:15
Смотри также:
как в ЗАПРОСе использовать результат Функции в Условии?
ПУБ. Методика отражения списания сырья на выпуск продукции
что тормозит 7.7 ?

Re: Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

roma n
1 - 27.05.2009 - 05:47
ну так ведь итог по субконто может быть получен массой операий. А перебирать операции ты не удосужился

Re: Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

pit
2 - 27.05.2009 - 05:52
и не получишь... Клевать ЖКК надо уметь....

Re: Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

OlegKZ
3 - 27.05.2009 - 06:15
Пр примеру и ЖКК тоже не идет.
бухи.ВыбратьСчета();
Пока бухи.ПолучитьСчет() = 1 цикл
  бухи.ВыбратьПериоды();
  Пока бухи.ПолучитьПериод() = 1 цикл
    Сообщить("Операция " + бухи.Операция.Документ);
  КонецЦикла;
КонецЦикла;

Re: Не могу из запроса вытащить БИ.Операция.Документ. Сообщает "<Объект не найден>".

pit
4 - 27.05.2009 - 06:19
курим параметры ВыполнитьЗапрос
курим ВыбратьПериоды
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Загрузка из АЦК Финансы в Бюджет в формате XML v.1.1 Вопрос по таблице (печатной :)) »
© 2009 Форум 1С: Одинэс.Ру