БУХ. Сбита нумерация СФ

Форум 1С: Одинэс.Ру

Найти!

БУХ. Сбита нумерация СФ

VV
17.06.2009 - 17:28
и при программном создании СФ, есно, ругается на неуникальность. Перенумеровывать СФ нельзя - слишком много перепечатывать и развозить по клиентам. Варианта 2:
1. При программном создании искать свободные новые номера
2. При ручном - что предложила программа, то и ....
Вопрос: подскажите идеи по 1 варианту. Как быстро и надежно это сделать. В сбитой нумерации нет логики, могу сформировать список номеров и в тхт выложит для того, чтобы показывать - КАК не надо делать :) и бить по руками линейкой "продвинутых" операторов.
К списку тем 1 2 > К списку форумов

Интересные темы

odines.ru
29.10.2020 - 19:45
Смотри также:
Строка таблица значений как параметр процедуры
Отредактировать файл xml
Срочно нужен sauron - восстановление MD

Re: БУХ. Сбита нумерация СФ

pit
1 - 17.06.2009 - 17:48
можно и не перенумеровывать...
 
есть и 3-й вариант - корректно сделать номера уникальными, не изменяя их и продолжить автонумерацию с прерванного места.
 
выложи - разрядность номера
часть последовательности правильных номеров (штук 10 подряд)
уродливые номера (все). выложи здесь - на файлообменники лень лазить.

Re: БУХ. Сбита нумерация СФ

VV
2 - 17.06.2009 - 18:13
Петь, разрядность типовая - тестовый, 8.
правильных - каких? там не пойми что считать правильными. Я все сгоню в тхт с разделителями и на слил кину - так проще. тут нет скрытого сообщения, как на руборде :(

Re: БУХ. Сбита нумерация СФ

VV
3 - 17.06.2009 - 18:17
сделал ДатаДок/НомерДок, чтобы была видна вся дрянь.
http://slil.ru/27768615

Re: БУХ. Сбита нумерация СФ

VV
4 - 17.06.2009 - 18:22
Честно говоря - я непонятках: если бы обнаружить сразу после сбоя - понятно. А через полгода обратились - вот теперь вообще "тостая полярная лисичка".

Re: БУХ. Сбита нумерация СФ

VZ
5 - 17.06.2009 - 18:52
Мдя... Ежели бы сразу, токо нулей доббавит, а теперь... понеслась п... карета по кочкам...
Вариант такой: жестокий, справедливый, обучаемый: пусть заводят, как хотят. Лапками.
Потом будут шелковыми.

Интересные темы

odines.ru
29.10.2020 - 19:45
Смотри также:
OFF: Для тех кому нечем заняться предлагается размять мозги
Код элемента справочника не уникальный!!!
Как вывести остатки?

Re: БУХ. Сбита нумерация СФ

VV
6 - 17.06.2009 - 18:57
(5) Именно так им и было сказано. Руками так и делают. Но вся фигня в том, что ежедневно создается программно цепочка Счет - РНК - СФ. И на записи СФ обработка затыкается и вылетает - понятно почему. Пока что отключил создание СФ, думаю - что тут можно сделать.

Re: БУХ. Сбита нумерация СФ

Путевый лист
7 - 17.06.2009 - 19:07
зайди в аську у тебя выходит максимальный номер 24165

Re: БУХ. Сбита нумерация СФ

Cthulhu
8 - 17.06.2009 - 19:12
(1): до длинаномера нормализовать усё шо есть с антиповтором удлиняемых номеров посредством гуляющего префикса, а потом с последнего создать с номером длинаномера-1?..

Re: БУХ. Сбита нумерация СФ

victuan
9 - 18.06.2009 - 00:48
(0) Советую посмотреть как сделана программная нумерация документов в ЗИКе. Там не автонумерация, там программный поиск очередного номера в диапазоне.
Может поможет?

Re: БУХ. Сбита нумерация СФ

serge
10 - 18.06.2009 - 02:03
автоподстановка нового префикса в интерактивном режиме и программно? можно даже разные префиксы ставить: будет сразу видно, программно или интерактивно создавался документ.

Re: БУХ. Сбита нумерация СФ

pit
11 - 18.06.2009 - 02:48
советы лохов...
все нормально делается... а если лечить по советам (10) - фигня...
по советам VZ - это полезно... чтобы не дергались в дальнейшем...
гуляющий префикс - вставить юзерам в зад... а не в программу, он ей не нужен...

Re: БУХ. Сбита нумерация СФ

:)
12 - 18.06.2009 - 02:49
в конфе хомнет:лизинг есть кусок
 
Префикс = ПрефиксАвтоНумерации("Документ."+ВидДокумента);
ТипНомера = Метаданные.Документ(ВидДокумента).ТипНомера;
 
док.Новый();
док.ДатаДок = ДатаДок;
 
Если (ТипНомера = "Текстовый") Тогда
док.УстановитьНовыйНомер(Префикс);
Иначе
док.УстановитьНовыйНомер();
КонецЕсли;
 
ДокумДляПоиска = СоздатьОбъект("Документ."+ВидДокумента);
Если (ДокумДляПоиска.НайтиПоНомеру(док.НомерДок, ДатаДок) = 0) Тогда
Возврат 1; // Все ОК
ИначеЕсли (ТипНомера = "Числовой") Тогда
Выругаться("Не удалось создать новый документ """+док.ПредставлениеВида()+""" - нет свободных номеров!");
Возврат 0; // Числовой номер ничего больше не спасет...
КонецЕсли;
 
// --- Возможно, сбилась нумерация документа - пытаемся сами работать за нумератор
ДлинаСчетчика = Метаданные.Документ(ВидДокумента).ДлинаНомера - СтрДлина(Префикс);
 
МаксСчетчик = 0;
Для Сч = 1 По ДлинаСчетчика Цикл  МаксСчетчик = 10*МаксСчетчик+9;  КонецЦикла;
 
Для Сч = 1 По МаксСчетчик Цикл
НомерДок = Префикс + Формат(Сч, "Ч(0)"+ДлинаСчетчика);
Если (ДокумДляПоиска.НайтиПоНомеру(НомерДок, ДатаДок) = 0) Тогда
док.НомерДок = НомерДок; Возврат 1; // наконец-то нашли искомый номер!
КонецЕсли;
КонецЦикла;
 
Выругаться("Не удалось создать новый документ """+док.ПредставлениеВида()+""" - нет свободных номеров!");
Возврат 0; // не сложилось...

Re: БУХ. Сбита нумерация СФ

victuan
13 - 18.06.2009 - 03:32
(12) Вот и в ЗИКе примерно так же.

Re: БУХ. Сбита нумерация СФ

pit
14 - 18.06.2009 - 03:50
фигня куски...
просто кодеры не знают прикольной фичи в автонумерации семерки...

Re: БУХ. Сбита нумерация СФ

victuan
15 - 18.06.2009 - 03:58
Есть такая фича: если текстовый не выровнен лидирующими нулями, то можно выровнять без кодерства:
1) в конфигураторе ставим числовой тип кода. Сохраняем
2) в конфигураторе возвращаем текстовый тип кода. Сохраняем.
вуаля. Лидирующие нули появились, а буковки пропали.

Re: БУХ. Сбита нумерация СФ

pit
16 - 18.06.2009 - 04:14
авно совет
после такого как раз дубли номеров частенько появляются...

Re: БУХ. Сбита нумерация СФ

VZ
17 - 18.06.2009 - 04:36
Вообще-то, Номер - реквизит строковый, даже если объявлен "числовым"... ;)
А у строковых реквизитов индексация по афавиту: сначала blank, затем цифры...

Re: БУХ. Сбита нумерация СФ

chief accountant
18 - 18.06.2009 - 04:56
Согласен с (5) и (11), но уж если бы у меня была такая беда с нумерацией поменял бы периодичность в нумераторе, чтобы исправить ситуацию

Re: БУХ. Сбита нумерация СФ

VZ
19 - 18.06.2009 - 05:02
11-pit > Вот, Петь, ругаешь меня за "кровожадность", а ведь зачастую наказание необходимо... Номер - фигня, да и болезнь"детская", но после усиленной работы руками немножко по другому воспринимают критику своих "хотелок" ;)

Re: БУХ. Сбита нумерация СФ

VZ
20 - 18.06.2009 - 05:05
(18) Ишь ты... Делал так?

Re: БУХ. Сбита нумерация СФ

chief accountant
21 - 18.06.2009 - 05:08
20-VZ >Нет не делал, но после аналогичных мучений в свое время закрыл доступ к номерам в 90% документах и 100% справочниках

Re: БУХ. Сбита нумерация СФ

pma
22 - 18.06.2009 - 05:40
Я бы добил короткие номера нулями. При записи проверял - уникальный записать и все, не уникальный первый ноль заменить на ".". При печати можно точку выкидывать.

Re: БУХ. Сбита нумерация СФ

VV
23 - 18.06.2009 - 06:00
Петя - как вчегда, "я знаю, но никому не скажу". :)
(15) я добил нулями все, пока при записи не начало ругаться на неуникальность. Пример "00000001" и "1"
Обратитет внимание: мне нужно сделать номер только в обработке. РУКАМИ пусть долбят полгода сами - наука будет.
(12) прикольно, вчерком попробую.
(21) обновлять потом не замучался? Это типовая Бух, она ей и должна остаться.

Re: БУХ. Сбита нумерация СФ

chief accountant
24 - 18.06.2009 - 06:11
23-VV >Это типовая Бух, она ей и должна остаться как ты собираешься не изменяя конфу искать номера программно, она ведь перестанет быть типовой. обновлять потом не замучался моя работа не связана с обновлением типовых

Re: БУХ. Сбита нумерация СФ

serge
25 - 18.06.2009 - 06:55
(11) пожалуй, соглашусь... помнится, где-то встречал уже на "территории" способ лечения - вставка в начале номера символа (к сожалению, не помню какого или каких), в результате чего позиция номера этого документа в нумераторе становится последней... действительно, в 10 пожалуй я пошел сложным путем...

Re: БУХ. Сбита нумерация СФ

pit
26 - 18.06.2009 - 07:45
во.... один (25) вменяемый оказался...
Остальные муму гоняют по подвалу.... вместе с автором...
 
23-VV >  все подразумеваемое здесь уже не раз объяснялось на т1с. Лично я глубоко забил объяснять тебе что либо, повторяясь при этом в 79-й раз....

Re: БУХ. Сбита нумерация СФ

victuan
27 - 18.06.2009 - 09:34
(25) Букву "я" в начале номера поставь, затем нулями выровняй номер до его длины. Дальше нумерация попрет. Я такое много раз делал на практике.
Но это конечно, не решение проблемы в (0). Это лечение симптомов, а не болезни.

Re: БУХ. Сбита нумерация СФ

VV
28 - 18.06.2009 - 10:00
(26) ага. Я так и думал. Проехали.У тя апмплуа не меняется.
(27) а ты файлик мой смотрел?

Re: БУХ. Сбита нумерация СФ

Uho
29 - 18.06.2009 - 10:05
(28) пришли по почте, интересно, что там такого "непоправимого"

Re: БУХ. Сбита нумерация СФ

serge
30 - 18.06.2009 - 10:07
(27) согласен... задача в (0) была именно вылечить симтомы... сама болезнь лечится либо программно, после излечения симптомов (закрыть для редактирования номер), либо регламентно, путем применения длинной линейки (после утверждения инструкции, вычисления виновника и накатывания на него пары докладных начальству)...

Re: БУХ. Сбита нумерация СФ

serge
31 - 18.06.2009 - 10:10
(0) кстати, обшарил в поисках той ветки, на которую ссылался, архив "территории", но её так и не нашел... зато наткнулся в яндексе вот не это
http://gendin.ru/faq1c/docnum.html

Re: БУХ. Сбита нумерация СФ

VV
32 - 18.06.2009 - 10:20
(29) так он в начале ветки лежит на слил.ру. Еще и в мыло продублировать?

Re: БУХ. Сбита нумерация СФ

VV
33 - 18.06.2009 - 10:32
Про новую нумерацию: при печати СФ отбосятся символы, останутся цифры. Не будет ли у меня потом затроенные бумежные номера СФ?
от номеров типа 000000145 - 145 - СФ00000145
? а?

Re: БУХ. Сбита нумерация СФ

Uho
34 - 18.06.2009 - 10:35
(33) я не слепой ))
наверное, не просто так прошу на почту

Re: БУХ. Сбита нумерация СФ

victuan
35 - 18.06.2009 - 10:37
28-VV >ну посмотрел и чо?
33-VV >Не будет ли у меня потом затроенные бумежные номера СФ?
Ну и будут и что? Ответственность за это предусмотрена?

Re: БУХ. Сбита нумерация СФ

VV
36 - 18.06.2009 - 10:46
(34) ясн, обменники закрыты. Выслал
(35)хз - про ответсвенность. Помню, что нумерация должна быть сквозная.

Re: БУХ. Сбита нумерация СФ

victuan
37 - 18.06.2009 - 10:54
36-VV >Помню, что нумерация должна быть сквозная
Посмотрев файл, я так и понял, что такая нумерация была сделана под впечатлением этого мифа.
Был я в такой ситуации. Такая нумерация - признак "черного" учета, когда с/ф рождаются задним числом. Прошерстил законы и убедил Заказчика, что НИКАКОЙ ответственности не предусмотрено за "несквозную" и "не по порядку" нумерацию.
В итоге все осталось как есть и нумерация не была нарушена.

Re: БУХ. Сбита нумерация СФ

Uho
38 - 18.06.2009 - 11:10
(36)
и че там страшного???
восстанавливается путем прибавления ведущих нулей в Попытке, при вызове Исключения (неуникальность) прибавляется ведущая точка. Все.

Re: БУХ. Сбита нумерация СФ

VV
39 - 18.06.2009 - 11:17
(38, 37) ну, попробую, что получится, то и сделаю. Еще был предложен вариант сохранять значение максимального номера в файл при записи, а при создании нового восстанавливать его и добавлять +1.

Re: БУХ. Сбита нумерация СФ

Uho
40 - 18.06.2009 - 11:23
(39) десять строк кода отсилы
ЗЫ. навскидку - неуникальных номеров вообще не будет

Re: БУХ. Сбита нумерация СФ

VV
41 - 18.06.2009 - 11:37
(40) так как красивее? Макс номер?

Re: БУХ. Сбита нумерация СФ

Uho
42 - 18.06.2009 - 11:43
типа так:
СФ=СоздатьОбъект("Документ.СчетФактура");
СФ.ВыбратьДокументы(ТекущаяДата(),НачГода(ТекущаяДата()));
Пока СФ.ПолучитьДокумент()=1 Цикл
  Ном=Прав("00000000"+СФ.НомерДок,8);
  Если Ном<>СФ.НомерДок Тогда
    Попытка
      СФ.НомерДок=Ном;
      СФ.Записать();
    Исключение
      СФ.НомерДок=Прав("."+СФ.НомерДок,8);
    КонецПопытки
  КонецЕсли;
КонецЦикла;
 

Re: БУХ. Сбита нумерация СФ

VV
43 - 18.06.2009 - 11:48
(42) это перенумерация. Нули УЖЕ добавлены - в файле видно. Тперь точку присобачить.... ща убегаю, вечером сделаю.

Re: БУХ. Сбита нумерация СФ

Uho
44 - 18.06.2009 - 11:51
(43)
это перенумерация
ну во-первых, нулей все равно в печ. форме не видно...
Нули УЖЕ добавлены
почему они добавлены не везде тогда?????

Re: БУХ. Сбита нумерация СФ

Cthulhu
45 - 18.06.2009 - 11:52
(42): "обращаем счета-фактуры в иудейство - обрезаем префиксы" ?.. ))))

Re: БУХ. Сбита нумерация СФ

chief accountant
46 - 18.06.2009 - 11:55
+44 Причем в (0) Перенумеровывать СФ нельзя предыдущие 40 постов были не о чём

Re: БУХ. Сбита нумерация СФ

Uho
47 - 18.06.2009 - 12:34
(45) у него нет префиксов

Re: БУХ. Сбита нумерация СФ

pit
48 - 18.06.2009 - 13:43
я же говорю - что здесь мало вменяемых людей

Re: БУХ. Сбита нумерация СФ

VV
49 - 18.06.2009 - 17:17
(48) Петь, ты только один уникальный. И вменяемый. Остальные  - нет.
(44)
Нули УЖЕ добавлены
почему они добавлены не везде тогда?????

Значицца так: когда произошла ситуация, я с помощью паяльника и логики выяснил:
начало года - нумерация нормальная, с нулями. Потом шаловливые ручки вбивают кривой номер - и дальше начинается свистопляска.
Я, пытаясь исправить, добавляю нули туда, где их нет. Вылет - уже такой с нулями СФ есть. Тогда чрез попытку кому можно доавил нули, остальные так и остались. Причем народу сказал - будете все долбить руками, потому что бывший оператор - шибко грамотная дивчина была.
Вот и долбили и долбят, а я потихоньку думаю, как исправить проблему. Причем их руки мне не жалко, мне главное - чтобы обработка нормально отрабатывала.

Re: БУХ. Сбита нумерация СФ

VV
50 - 18.06.2009 - 17:23
(46)Причем в (0) Перенумеровывать СФ нельзя предыдущие 40 постов были не о чём
вообще-то перенумерация подразумевает от начала года до текущей даты замену номеров. Про это вообще речи нет.
К списку тем 1 2 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Поиск фрагмента текста во внешних файлах Настройка нумерации документов в УРБД »
© 2009 Форум 1С: Одинэс.Ру