Присвоить перечисление :(

Форум 1С: Одинэс.Ру

Найти!

Присвоить перечисление :(

Apollo
14.05.2009 - 09:57
Коллеги, доброе утро!
 
Кто-то сталкивался как присвоить реквизиту типа "перечисление" какое-то значение. Например у меня есть строковое выражение типа "Перечисление.ВидТМЦ.Товар". Как извернуться, чтобы это записать в реквизит справочника с типом "Перечисление.ВидТМЦ" ???
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
06.12.2020 - 01:01
Смотри также:
Как попроще закрыть от изменения задним числом периодические реквизиты?
Регл отчеты не грузятся
ПУБ - но все таки ?

Re: Присвоить перечисление :(

Reaper
25 - 14.05.2009 - 12:39
22-roma n > Извиняюсь за кривость цитаты, обещаю исправиться.

Re: Присвоить перечисление :(

victuan
26 - 14.05.2009 - 14:20
(24) Для твоего случая сработает и такой вариант:
Спр.Реквизит = Шаблон("["+МояСтрока+"]");
Намного изящнее

Re: Присвоить перечисление :(

roma n
27 - 14.05.2009 - 14:49
(26) * бубня в сторону
всю жизнь думал, что шаблон возвращает строку...

Re: Присвоить перечисление :(

Исчо
28 - 14.05.2009 - 15:29
Самый простой способ - написать ВК на С, там есть приведение типов.

Re: Присвоить перечисление :(

victuan
29 - 15.05.2009 - 03:31
(27) Я это и сам понял сразу как высказался. Так что пост (26) прошу считать недействительным.

Интересные темы

odines.ru
06.12.2020 - 01:01
Смотри также:
Учёт и отчётность предпринимателя 7.70.154 - Не завершается обновление ИБ :)
Интервал просмотра для журнала документов
Лузерский вопрос: Вставляю из модуля документа 7.7 в текстовый документ- "кракозябры"

Re: Присвоить перечисление :(

100п
30 - 15.05.2009 - 07:05
(22) Правильный первоисточник: "Как нам реогранизовать рабкрин". В нем "еще раз" присутствует. Reaper-у не надо исправляться.

Re: Присвоить перечисление :(

roma n
31 - 15.05.2009 - 07:21
30-100п >
не ври, чего не знаешь. ПСС. http://libelli.ru/library/tema/sc/marxism/lenin.htm
том 45
Сама статья: http://libelli.ru/works/45-3.htm

Re: Присвоить перечисление :(

100п
32 - 15.05.2009 - 07:32
(31) С первоисточником пускай лоханулся, но! Не учили мы "Попятное направление..."! Ни в школе, ни в универе. А цитата походу была.

Re: Присвоить перечисление :(

diaser
33 - 15.05.2009 - 07:33
******************************************************************************
// НайтиЗначПеречисления(Вид, Стр)
//
// Параметры:
//  Вид - строка – вид перечисления.
//  Стр - строка, представление значения перечисления.
//
// Возвращаемое значение:
//  значение перечисления
//
// Описание:
//  Определяет значение перечисления по идентификатору перечисления и представлению
// его значения.
//
Функция глНайтиЗначПеречисления(Вид, Стр) Экспорт
 
Если Метаданные.Перечисление(Вид).Выбран() = 0 Тогда
  Возврат "";
КонецЕсли;
 
Перечисл=Перечисление.ПолучитьАтрибут(Вид);
Для К=1 по Перечисл.КоличествоЗначений() Цикл
  Значение=Перечисл.ЗначениеПоНомеру(К);
  Если Строка(Значение)=СокрЛП(Стр) Тогда
               Возврат(Значение);
          КонецЕсли;
КонецЦикла;
 
Возврат(ПолучитьПустоеЗначение("Перечисление."+Вид));
 
КонецФункции // НайтиЗначПеречисления()
 
Это как пример....

Re: Присвоить перечисление :(

2Green
34 - 15.05.2009 - 09:38
лучше предварителдьно запихнуть в список значений идентификаторы перечислений и уже в нём искать значение в цикле по строкам файла
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Как вытащить из Парус 4.50 зарплата в 1С Бюджет Загрузка данных из Excel »
© 2009 Форум 1С: Одинэс.Ру