Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

Форум 1С: Одинэс.Ру

Найти!

Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

niks77
17.03.2009 - 10:12
Перем ТаблицаНазвМатериалов, СуммТаблицаПроизводтвРасходов;
 
Процедура ДобавитьНовыйМатериалПолуфабрикатПоТаблицамЗначений(Материал)
СуммТаблицаПроизводствРасходов.НоваяКолонка("М"+Строка(ТаблицаНазвМатериалов.КоличествоСтрок()),"Число",15,7,Строка(Материал));                          
СуммТаблицаПроизводствРасходов.НоваяКолонка("О"+Строка(ТаблицаНазвМатериалов.КоличествоСтрок()),"Число",10,0,"остатки: "+Строка(Материал));
КонецПроцедуры
 
Процедура Сформировать()
....
СуммТаблицаПроизводствРасходов.НоваяКолонка("КоличествоВыпуск"+Строка(iКолДнейДляВыводаВыпускаПоДням),"Число",10,0,"Выпуск"+Строка(ТекДатаЦикла));
...
КонецПроцедуры
 
Процедура ПриОткрытии()
// -------------------------------------------- инициализация основных рабочих таблиц значений -------------------------------------------------------ТаблицаНазвМатериалов=СоздатьОбъект("ТаблицаЗначений");  
СуммТаблицаПроизводствРасходов=СоздатьОбъект("ТаблицаЗначений");
КонецПроцедуры //ПриОткрытии
К списку тем К списку форумов

Интересные темы

odines.ru
24.10.2020 - 08:53
Смотри также:
Печать в окошке адреса для прозрачного конверта. Есть ли такое?
При удаление строки из табличной части дока
Алкоголь....

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

niks77
1 - 17.03.2009 - 10:15
Ругается на две строки процедуры ДобавитьНовыйМатериалПолуфабрикатПоТаблицамЗначений(Материал)
хотя все таблица инициализированы как полагается...

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

roma n
2 - 17.03.2009 - 10:53
Перем ... СуммТаблицаПроизводтвРасходов
далее по тексту
СуммТаблицаПроизводствРасходов

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

niks77
3 - 17.03.2009 - 12:19
2(2) roma, нашел. Спаси Господи! Это уже тормоза. Пора в отпуск...

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

Дятeл
4 - 17.03.2009 - 12:39
(2) предлагаю выдать медаль за дотошность... у меня от неформатированного кода глаза в кучу.

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

niks77
5 - 17.03.2009 - 12:44
2(4) Нефомальный код иногда упрощает процесс вспоминия чего же ты там понаписал прошлый раз...

Интересные темы

odines.ru
24.10.2020 - 08:53
Смотри также:
v7. Возможно ли редактировать движения в регистр в "операции" документа?
Перенос длинной текстовой строки без пробелов
Автозапуск 1С ночью, Win2003

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

roma n
6 - 17.03.2009 - 13:11
(5) "Нефомальный" = "нефоРмальный"?
В любом случае на счет отпуска думай, бо "нефомальный" шибко сильно далеко от "неформатированный" ;)

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

АЛьФ
7 - 17.03.2009 - 13:58
Отсюда мораль: надо пользоваться Телепатом :)

Re: Модуль на ровном месте стал выдавать ошибку: "Переменная не определена (СуммТаблицаПроизводствРасходов)"

pit
8 - 17.03.2009 - 14:24
да, скрипты по форматированию текста + SciColorer --- и все восьмерки, девятки, десятки отдыхают....
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« 1C и SQL какие варианты связи? Нарушение уникальности нумерации докуменов. »
© 2009 Форум 1С: Одинэс.Ру