отсутствует интерфейс IInitDone.....

Форум 1С: Одинэс.Ру

Найти!

отсутствует интерфейс IInitDone.....

axell
05.05.2009 - 07:45
Ребята низная из за чего стала вываливаться ошибка "Ошибка при создании объекта из компоненты \\file\1sbases\v7plus.dll (отсутствует интерфейс IInitDone)". Это внешняя обработка Подготовка сведений в ПФР. Само интересное что не работает на компе у одной из расчетчиц. у остальных работает все нормально. Подскажите пожалуйста кто сталкивался с проблемой.
К списку тем К списку форумов

Интересные темы

odines.ru
29.10.2020 - 20:35
Смотри также:
Есть ли возможность развернуть наименование колонки
Подскажите по списку значений с пометками
ошибка каждый вечер

Re: отсутствует интерфейс IInitDone.....

VZ
1 - 05.05.2009 - 08:16
Зарегистрируй. И не держи длл-ку на сетевом ресурсе: стрёмно это.

Re: отсутствует интерфейс IInitDone.....

axell
2 - 05.05.2009 - 08:23
в бин каждому пользователю запихать?

Re: отсутствует интерфейс IInitDone.....

VZ
3 - 05.05.2009 - 08:31
А что? Не знаешь как?

Re: отсутствует интерфейс IInitDone.....

axell
4 - 05.05.2009 - 08:43
regsvr32 V7PLUS.DLL???? на каждой машинке?

Re: отсутствует интерфейс IInitDone.....

vip
5 - 05.05.2009 - 08:55
(0) Запусти один раз эту внешнюю обработку под админом. Это обычная ВК, regsvr32 не нужен.
(1) Почему стрёмно?

Интересные темы

odines.ru
29.10.2020 - 20:35
Смотри также:
Нет возможности разместить документ после ТА
Как определить в запросе |ВидДок = Регистр.Партии.ТекущийДокумент.Вид();?
Как загрузить из TXT файла?

Re: отсутствует интерфейс IInitDone.....

VZ
6 - 05.05.2009 - 09:41
5-vip > Потомушто эта ВК в реестре прописывается. Вместе с путем доступа.
 
А база-то, поди, не одна... А пути доступа, поди, меняются...
И зачем себе городить трудности в формате неопределенности? Не всегда дядя Билли так доброжелателен к своим пользователям, хотя и очень старается ;)
 
Итак, небольшие заметочки:
Процедура ПриНачалеРаботыСистемы()
.....
Если ФС.СуществуетФайл(КаталогПользователя()+"\start.ert")=1 Тогда //Нашли ее в каталоге пользователя
ОткрытьФормуМодально("Отчет",Предстарт,КаталогПользователя()+"\start.ert");
ИначеЕсли ФС.СуществуетФайл(КаталогИБ()+"\ExtForms\start.ert")=1 Тогда  //Нашли "дефолтную" в ExtForms
ОткрытьФормуМодально("Отчет",Предстарт,КаталогИБ()+"\ExtForms\start.ert");
КонецЕсли;
.....
КонецПроцедуры
 
Обработка start.ert:
Функция НайтиПервыйСуществующийФайл(ИмяФайла, СписокВозможныхМест)
    
    НашлиВБИН = 0;
//ВерсияБИН = ""; //ограничимся датой записи...
ДатаВремяБИН = "";
Для Сч = 1 По СписокВозможныхМест.РазмерСписка() Цикл
КаталогСписка = СписокВозможныхМест.ПолучитьЗначение(Сч);
        ПолноеИмя     =  КаталогСписка+ИмяФайла;
        Если Фс.СуществуетФайл(ПолноеИмя) = 1 Тогда
ВремяСоздания = "";
ФС.АтрибутыФайла(ПолноеИмя,,,ВремяСоздания,,,);
Если КаталогСписка = КаталогПрограммы() Тогда
НашлиВБИН = 1;
ДатаВремяБИН = ВремяСоздания;
Продолжить;
ИначеЕсли КаталогСписка = КаталогDLL Тогда
Если НашлиВБИН = 1 Тогда
Если ДатаВремяБИН < ВремяСоздания Тогда
Попытка
    ФС.КопироватьФайл(ПолноеИмя,КаталогПрограммы()+ИмяФайла,0);
ПолноеИмя = КаталогПрограммы()+ИмяФайла;
Исключение
    //Здесь надо сообщить о неудаче записи в каталог BIN
Сообщить(ОписаниеОшибки());
КонецПопытки;
Иначе
ПолноеИмя = КаталогПрограммы()+ИмяФайла;
КонецЕсли;
Иначе //пытаемся поместить в каталог программы
Попытка //для юзеров с ограниченными правами писать скрипт для run as от имени администратора
ФС.КопироватьФайл(ПолноеИмя,КаталогПрограммы()+ИмяФайла,0);
ПолноеИмя = КаталогПрограммы()+ИмяФайла;
Исключение
//Здесь надо сообщить о неудаче записи в каталог BIN
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЕсли;
Возврат ПолноеИмя;
КонецЕсли;
    КонецЦикла;
 
    Возврат "";
 
КонецФункции        //    НайтиПервыйСуществующийФайл()
 
Процедура ЗагрузитьВК()
Перем Каталог;
Перем УправлениеНастройками;
 
СписокВозможныхМест    =    СоздатьОбъект("СписокЗначений");
    СписокВозможныхМест.ДобавитьЗначение(КаталогИБ());
    СписокВозможныхМест.ДобавитьЗначение(КаталогПрограммы());
    //СписокВозможныхМест.ДобавитьЗначение(КаталогИБ() + "ExtForms\");
    КаталогDll = КаталогИБ()+"DLL\";
    //сообщить("Каталог ДЛЛ = """+КаталогDll+"""");
    СписокВозможныхМест.ДобавитьЗначение(КаталогDll);
..............
    МестоРасположения_vkloader = НайтиПервыйСуществующийФайл("vkloader.dll", СписокВозможныхМест);
    Если ПустоеЗначение(МестоРасположения_vkloader) = 0 Тогда
        ЗагрузитьВнешнююКомпоненту(МестоРасположения_vkloader);
        Загрузчик = СоздатьОбъект("ЗагрузчикВК");
КонецЕсли;
....................
КонецПроцедуры
 
//*******************************************
Процедура Сформировать()
 
ЗагрузитьВК();  //Загрузка компонент
 
ДеньМесяца = ДатаЧисло(РабочаяДата());
//  далее закомментированы условия вывода этого "информационного блока" от 1С, чтоб было понятно,
//  что мы ставим взамен, чтоб эти условия не сработали никогда ;)
//Если ОткрытьИнформационныйБлок =2 Тогда
СохранитьЗначение("НеобходимостьОткрытияИнформационныйБлок",-1);
//Если ((ДеньМесяца=1) или (ДеньМесяца=15)) и (РабочаяДата() <> ДатаОткрытияИнформационныйБлок) Тогда
Если ((ДеньМесяца=1) или (ДеньМесяца=15)) Тогда
СохранитьЗначение("ДатаОткрытияИнформационныйБлок",РабочаяДата());
//ИначеЕсли ((ДеньМесяца<15) и (ДатаОткрытияИнформационныйБлок <> НачМесяца(РабочаяДата())))
//или ((ДеньМесяца>=15) и (ДатаОткрытияИнформационныйБлок <> Дата(ДатаГод(РабочаяДата()),ДатаМесяц(РабочаяДата()),15))) Тогда
ИначеЕсли (ДеньМесяца<15) Тогда
СохранитьЗначение("ДатаОткрытияИнформационныйБлок",НачМесяца(РабочаяДата()));
ИначеЕсли (ДеньМесяца>=15) Тогда
СохранитьЗначение("ДатаОткрытияИнформационныйБлок",Дата(ДатаГод(РабочаяДата()),ДатаМесяц(РабочаяДата()),15));
КонецЕсли;
 
КонецПроцедуры
 
Кусочки, естественно ;)

Re: отсутствует интерфейс IInitDone.....

vip
7 - 05.05.2009 - 10:30
(6)
1. > А база-то, поди, не одна...
Откуда такие сведения?
 
2. "Небольшие заметочки" в виде копипаста неотформатированного кода добавили автору понимания сути вопроса?

Re: отсутствует интерфейс IInitDone.....

VZ
8 - 05.05.2009 - 10:48
7-vip > 1. Обычная практика: несколько баз ;)
2. Код-то отформатирован как раз, а при копи-пасте это форматирование "съелось". Но у меня нет желание исследовать методы борьбы с этим явлением... А вот показать метОду для внесения компонет на комп юзера - вроде показал как для хоть сотни этих самых юзеров.
Для кого это интересно.
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Условие в запросе и таблица значений ЭККА Мария-301 + VPN + Terminal »
© 2009 Форум 1С: Одинэс.Ру