Программно поменять дату документа ...

Форум 1С: Одинэс.Ру

Найти!

Программно поменять дату документа ...

deefm
07.04.2009 - 09:37
Здравствуйте, подскажите пож-та, как можно массово поменять у проведенных документов ДатуДокумента. Т.е. у всех документов с датой от 28.03.2009г надо поставить ДатуДокумента - последний день месяца (31марта)?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 09:13
Смотри также:
Кто может сказать,что за кодировка в этом DBF-файле ?
Остатки по сч.Н02 отрицательные. Что делать?
Надо преобразовать "18 Февраля 2009" в Дату

Re: Программно поменять дату документа ...

roma n
1 - 07.04.2009 - 09:46
а в чем проблема? Программно и не такое можно...

Re: Программно поменять дату документа ...

который не честный
2 - 07.04.2009 - 10:12
Собери все доки в список значений.
Иди по списку, находи док, распроводи, меняй дату, проводи.

Re: Программно поменять дату документа ...

JannyS
3 - 07.04.2009 - 10:16
групповая обработка справочников и документов

Re: Программно поменять дату документа ...

deefm
4 - 07.04.2009 - 10:32
Вот мой текст, находит последний документ на 28марта и только его меняет, ниже мой код:
 

Док = СоздатьОбъект("Документ.ОказаниеУслуг");
Док.ВыбратьДокументы(НачДата, КонДата);
Пока Док.ПолучитьДокумент() = 1 Цикл  
Если Док.Комментарий = СокрЛП("Загружено в автоматическом режиме !!!")  Тогда  
 
Если (Док.Проведен()=1) Тогда  
Док.СделатьНеПроведенным();
Док.ДатаДок = КонМесяца(Док.ДатаДок);
Док.Записать();  
Док.Провести();
КонецЕсли;
КонецЕсли;
КонецЦикла;

Re: Программно поменять дату документа ...

roma n
5 - 07.04.2009 - 10:41
Писатель?
Читай (2). Позиционирование не сбивай

Интересные темы

odines.ru
20.10.2020 - 09:13
Смотри также:
Проблема с запуском 1С: исключение unknown software exception приложении по адресу
Отчет по остаткам товаров на складе
Вопрос по таблице (печатной :))

Re: Программно поменять дату документа ...

VZ
6 - 07.04.2009 - 10:42
Типичная чайниковская (повторенная становится ламерской) ошибка: менять значение, которое является индексом при выборке.
Ты задаешь выборку в неком диапазоне. Дата и время документа - предопределенный индекс для сканирования журнала документа. После изменения даты объекта сканирование пытается обратится к больщему значению даты+время и напарывается на выход из заданного диапазона.
Выход: (2).

Re: Программно поменять дату документа ...

Anonymous
7 - 07.04.2009 - 10:45
Выбрать запросом, обходить результат запроса.

Re: Программно поменять дату документа ...

VZ
8 - 07.04.2009 - 10:50
(7) Это модификация (2).

Re: Программно поменять дату документа ...

deefm
9 - 07.04.2009 - 10:53
На примере моего кода подскажите пож-та...

Re: Программно поменять дату документа ...

Andemion
10 - 07.04.2009 - 10:57
Док = СоздатьОбъект("Документ.ОказаниеУслуг");
Сп = СоздатьОбъект("СписокЗначений");
 
Док.ВыбратьДокументы(НачДата, КонДата);
Пока Док.ПолучитьДокумент() = 1 Цикл  
Если Док.Комментарий = СокрЛП("Загружено в автоматическом режиме !!!")  тогда
Если (Док.Проведен()=1) Тогда  
Сп.ДобавитьЗначение(Док.ТекущийДокумент());
КонецЕсли;
КонецЕсли;
КонецЦикла;
 
Для А = 1 по Сп.РазмерСписка() Цикл
Док.НайтиДокумент(Сп.ПолучитьЗначение(А));
Док.СделатьНеПроведенным();
Док.ДатаДок = КонМесяца(Док.ДатаДок);
Док.Записать();  
Док.Провести();
КонецЕсли;
КонецЦикла;

Re: Программно поменять дату документа ...

Anonymous
11 - 07.04.2009 - 11:15
0-deefm > Код нужен для 8 или для 7?

Re: Программно поменять дату документа ...

deefm
12 - 07.04.2009 - 11:17
(10) СПАСИБО!!!
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Заполение счёт фактуры по OLE. Туплю, помогите разобраться.... Помогите разобраться с ошибкой "Не выбран документ!" »
© 2009 Форум 1С: Одинэс.Ру