Как в отчете сделать табличную часть?

Форум 1С: Одинэс.Ру

Найти!

Как в отчете сделать табличную часть?

Полька
02.06.2009 - 10:11
Бухия 7.7.
В отчете хочу сделать, чтобы из справочника материалы выбрали несколько позиций, и по ним собирать информацию.
Никак не соображу- где подобный отчет глянуть можно?
Ну вроде как табличная часть в документе.
К списку тем К списку форумов

Интересные темы

odines.ru
25.10.2020 - 19:59
Смотри также:
Остатки по сч.Н02 отрицательные. Что делать?
ПУБ Нереальные суммы корректировки стоимости материалов полученных в переработку и переданных в переработку.
FormEx Раскраска строк Дерева и ТаблицыЗначений

Re: Как в отчете сделать табличную часть?

roma n
1 - 02.06.2009 - 10:14
в ТиСе чуть ли не каждый первый отчет имеет возможность установки множественного фильтра.
ТЗ на форме.

Re: Как в отчете сделать табличную часть?

Полька
2 - 02.06.2009 - 10:47
А если не в ТиС? Нет у меня его :(

Re: Как в отчете сделать табличную часть?

chief accountant
3 - 02.06.2009 - 10:52
Отбор по субконто в любом стандартном отчете

Re: Как в отчете сделать табличную часть?

roma n
4 - 02.06.2009 - 10:53
Второго предложения достаточно...
Вставить - Таблица значений/Список значений.
Подборы/удаления открываешь программно по клику на предварительно нарисованных кнопочках

Re: Как в отчете сделать табличную часть?

Полька
5 - 02.06.2009 - 10:59
Эх, а в документе и делать ничего не надо :)))) Все само :))))

Интересные темы

odines.ru
25.10.2020 - 19:59
Смотри также:
Не ищет "НайтиЗначение" в ТЗ.
Какова длина строки неограниченной длины?
Пропадают номера ПФР

Re: Как в отчете сделать табличную часть?

Кибер
6 - 02.06.2009 - 11:22
в бюджетке можно глянуть

Re: Как в отчете сделать табличную часть?

user1C
7 - 02.06.2009 - 11:38
(0)
глянь отчет осв, закладка Развернутое сальдо

Re: Как в отчете сделать табличную часть?

Ctrl P
8 - 02.06.2009 - 11:40
5 ну прям так и все само? все равно надо кнопку подбор делать, а вообще если очень уж нравится документ сделайте через форму документа, только при закрытии не сохраняйте его никогда :)))

Re: Как в отчете сделать табличную часть?

VZ
9 - 02.06.2009 - 11:55
(0) В отчете (на форме) делаешь список. Делаешь кнопы "Подбор", "Удалить", "Открыть".
К первой кнопе привязывешь
Процедура Подбор()
 
Если Форма.МодальныйРежим()=1 Тогда
Предупреждение("Невозможно открыть подбор в модальном режиме!",10);
Иначе
ОткрытьПодбор("Справочник.Материалы","ДляВыбора",,1);
КонецЕсли;
 
КонецПроцедуры
 
Разумеется, нужна процедура
Процедура ОбработкаПодбора(Элемент,КонтФормы)
 
Если ПустоеЗначение(Элемент)=0 Тогда
Если Элемент.ЭтоГруппа()=0 Тогда
Если спМатериалы.НайтиЗначение(Элемент)=0 Тогда
спМатериалы.ДобавитьЗначение(Элемент);
Иначе
Предупреждение("Материал уже выбран в списке!",10);
КонецЕсли;                                            
КонецЕсли;
КонецЕсли;
 
КонецПроцедуры // ОбработкаПодбора
 
"Удалить" - пнятно, "Открыть" - для посмотреть...
 
Вот и пихай сформированный список в фильтр запроса по материалам.

Re: Как в отчете сделать табличную часть?

Полька
10 - 02.06.2009 - 12:17
Спасибо, все сделала :)
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Не видно сканера штрих-кодов установка пароля на обработку »
© 2009 Форум 1С: Одинэс.Ру