Форма.Реквизит.Доступность(Флаг)

Форум 1С: Одинэс.Ру

Найти!

Форма.Реквизит.Доступность(Флаг)

Lada
20.02.2009 - 18:35
Можно ли как-то установить доступность неизвестному заранее реквизиту формы?
Проблема вот в чем: есть реквизиты формы (они же реквизиты объекта, т.е. метаданные). Неопределенного типа. Надо управлять их доступностью ПриОткрытии() в зависимости от их значения.
В идеале можно было написать так:
Форма.Реквизит1.Доступность(Флаг)
Форма.Реквизит2.Доступность(Флаг)
Форма.Реквизит3.Доступность(Флаг)
Форма.Реквизит4.Доступность(Флаг)
Т.е. перечислить в модуле ВСЕ такие реквизиты, но может есть другой способ, типа обхода метаданные.Документ(н).Реквизит(к)?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
31.10.2020 - 22:53
Смотри также:
Копирование справочника с подчиненными справочниками
Отчет о прибылях и убытках Бухгалтерия 7.7
расхождения в больничных листах

Re: Форма.Реквизит.Доступность(Флаг)

КонецЦикла
1 - 20.02.2009 - 19:09
FormEx умеет
Иначе с извратами через шаблон (или туплю)

Re: Форма.Реквизит.Доступность(Флаг)

VZ
2 - 20.02.2009 - 19:16
Несуразное девушка задумала... Правильно придуманное легко реализуется, как правило.

Re: Форма.Реквизит.Доступность(Флаг)

Грязный Танка
3 - 20.02.2009 - 19:18
Их так много что так надо?

Re: Форма.Реквизит.Доступность(Флаг)

Lada
4 - 20.02.2009 - 20:11
(1) Как через шаблон?

Re: Форма.Реквизит.Доступность(Флаг)

Lada
5 - 20.02.2009 - 20:30
Спасибо за демагогию. Вот ответ:
.
.
Для Сч=1 По Метаданные.ОбщийРеквизитДокумента() Цикл
 
Элемент=Метаданные.ОбщийРеквизитДокумента(Сч).Идентификатор;
Попытка
Форма.ПолучитьАтрибут(Элемент).Доступность(0);
Исключение
// реквизит документа отсутствует на форме
КонецПопытки;
КонецЦикла;
МетаДок=Метаданные.Документ("Счет");
Для Сч=1 По МетаДок.РеквизитШапки() Цикл
Элемент=МетаДок.РеквизитШапки(Сч).Идентификатор;
Попытка
Форма.ПолучитьАтрибут(Элемент).Доступность(0);
Исключение
// реквизит документа отсутствует на форме
КонецПопытки;
КонецЦикла;
Для Сч=1 По МетаДок.РеквизитТабличнойЧасти() Цикл
Элемент=МетаДок.РеквизитТабличнойЧасти(Сч).Идентификатор;
Попытка
Форма.ПолучитьАтрибут(Элемент).Доступность(0);
Исключение
// реквизит документа отсутствует на форме
КонецПопытки;
КонецЦикла;

Интересные темы

odines.ru
31.10.2020 - 22:53
Смотри также:
AdoDb.Connection
Как можно сократить время проводок?
ЗиК Переплата з/п

Re: Форма.Реквизит.Доступность(Флаг)

VZ
6 - 20.02.2009 - 20:38
:)) Можно гораздо проще: Форма.Доступность(0);

Re: Форма.Реквизит.Доступность(Флаг)

Lada
7 - 20.02.2009 - 20:44
Читайте (0) Форма.Доступность(0) не подходит. Поскольку мне не все
реквизиты надо делать недоступными. в просто (5) пример кода.

Re: Форма.Реквизит.Доступность(Флаг)

VZ
8 - 20.02.2009 - 21:01
Так раскроете свой, несомненно, гениальный замысел, нет?

Re: Форма.Реквизит.Доступность(Флаг)

Cthulhu
9 - 20.02.2009 - 21:29
Блин... Lada! срочно меняйте или никнэйм или гендерную принадлежность!

Re: Форма.Реквизит.Доступность(Флаг)

КонецЦикла
10 - 20.02.2009 - 21:37
2(5) Какая нахрен демагогия, в (1) исчерпывающий ответ
Можно и через метаданные если полное совпадение реквизитов формы и объекта + можно использовать свои списки (что входит - не входит)
Шматок кода не нашел, а писать лень

Re: Форма.Реквизит.Доступность(Флаг)

Cthulhu
11 - 20.02.2009 - 21:43
мнится мне, что к понятию "изврат" более подходит подрубание "мощной" ВК ради того, что можно сделать штатными (но не совсем стандартными) средствами...

Re: Форма.Реквизит.Доступность(Флаг)

Lada
12 - 20.02.2009 - 22:13
(8) да ничего гениального. Если документ проведен, то часть реквизитов
можно править, часть нет. Но реквизитов много, поэтому перечислять их счел
не красивым решением. Вот и обратился к вселенскому разуму.
(9) чем тебе мой ник не угодил?

Re: Форма.Реквизит.Доступность(Флаг)

Cthulhu
13 - 20.02.2009 - 22:24
(12): те, что это бабский ник... те чо, ся бабой приятно выставлять?.. так даже если и так, я тебе по секрету скажу: собеседникам не совсем удобно бывает, когда после обращения к тебе как к бабе вдруг выясняется что ты не она, а он (или оно?)

Re: Форма.Реквизит.Доступность(Флаг)

Lada
14 - 20.02.2009 - 22:32
(13) ладно, я подумаю :)

Re: Форма.Реквизит.Доступность(Флаг)

КонецЦикла
15 - 21.02.2009 - 00:04
Предлагаю LadaBoy :)
 

Re: Форма.Реквизит.Доступность(Флаг)

Маус
16 - 21.02.2009 - 06:40
Блондинка?

Re: Форма.Реквизит.Доступность(Флаг)

МимохожийОднако
17 - 21.02.2009 - 08:54
(12)Посмотри как в типовой Торговле реализован механизм корректировки реквизитов документов.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« УРБД. Как организовать миграцию документов не по виду документа, а по определенному критерию Копирование справочника с подчиненными справочниками »
© 2009 Форум 1С: Одинэс.Ру