Подскажите, почему не выводится печ.форма...

Форум 1С: Одинэс.Ру

Найти!

Подскажите, почему не выводится печ.форма...

deefm
10.03.2009 - 07:24
Здравствуйте, подскажите пожалуйста, где у меня ошибка.
Пишу обработку, которая копирует документы из одного месяца и создает их в другом. На форме обработки есть флажок - если он поставлен, то созданные документы - проводятся, если нет - то просто записываются. В конце обработки выходит печатная форма. Так вот, если флажок не поставлен, то печ.форма выводится, а если поставлен, то выходит сообщение об ошибке и печ.форма не создается и не выводится:
 
Таб.ИсходнаяТаблица("Старые");
{C:\обработка.ERT(133)}: Неверное имя Старые
 
Ниже мой текст, помогите разобраться, в чем может быть причина!!!
 
Процедура Сформировать()  
 
ТЗ=СоздатьОбъект("Таблицазначений");
...
 
Символ = "1";
 
Док = СоздатьОбъект("Документ.ОказаниеУслуг");
Док.ВыбратьДокументы(НачДата, КонДата);
Пока Док.ПолучитьДокумент() = 1 Цикл  
 
Если (Док.Проведен()=0) ИЛИ (Док.ПометкаУдаления()=1) Тогда  
Прервать;
КонецЕсли;
 
// выбираем только док-ты, у которых НомерДок начинается с 1
Если Лев(Строка(Док.НомерДок),1) = Символ Тогда  
 
ТЗ.НоваяСтрока();
...
 
Док1 = СоздатьОбъект("Документ.ОказаниеУслуг");
Док1.Новый();
Док1.ДатаДок = ДобавитьМесяц(Док.ДатаДок,1);
...
Док1.УстановитьНовыйНомер("1");
Док1.Комментарий = "Загружено в автоматическом режиме !!!";
 
Док1.Записать();
 
Если Пров=1 Тогда
Док1.Провести();    
КонецЕсли;
 
Иначе
Продолжить;
КонецЕсли;
 
КонецЦикла;
 
Если ТЗ.КоличествоСтрок()>0 Тогда
 
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Старые");
Таб.ВывестиСекцию("Заголовок");    
Таб.ВывестиСекцию("Шапка");
 
ТЗ.ВыбратьСтроки();  
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
Таб.ВывестиСекцию("Строки");
КонецЦикла;
 
КонецЕсли;
 
КонецПроцедуры
 
К списку тем К списку форумов

Интересные темы

odines.ru
22.10.2020 - 11:50
Смотри также:
Люди, спасите немощных! Пиво-коньячный вопрос!
обязанности программера 1С
Слить 2 ТЗ в одну. Как?

Re: Подскажите, почему не выводится печ.форма...

АЛьФ
1 - 10.03.2009 - 07:34
Вот эти строки перенеси в начало процедуры:
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Старые");

Re: Подскажите, почему не выводится печ.форма...

deefm
2 - 10.03.2009 - 08:17
(1) спасибо, все получилось!!!
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Вопрос по УРИБ Единица и коэффициент в ТиС - загадка для мну... »
© 2009 Форум 1С: Одинэс.Ру