ПриНачалеВыбораЗначения + открытьформу. Как передать значение обратно?

Форум 1С: Одинэс.Ру

Найти!

ПриНачалеВыбораЗначения + открытьформу. Как передать значение обратно?

ПашаК
23.07.2009 - 07:05
В справочник1 есть реквизит - вПроекте. Тип значения- Документ.Документ1
У документа Есть реквизит Задача. - Тип значения Справочник.справочник1
Сначала создаем новый элемент справочника. Затем, если необходимо, заполняем реквизит - вПроекте.
При этом нужно создать новый документ Документ1. И передать ему элемент справочника.
написал
В модуле формы справочника:
 
Процедура ПриНачалеВыбораЗначения(Элемент, Флаг)
    Если (Элемент = "вПроекте") и (ПустоеЗначение(вПроекте)=1) Тогда
      Флаг = 0;
      ОткрытьФорму("Документ.Документ1", текущийэлемент());
   КонецЕсли;
КонецПроцедуры
 
В модуле формы Документа:
 
Процедура ВводНового()
Если форма.параметр.вид()="Справочник1" тогда
Задача=форма.параметр;
КонецЕсли;
КонецПроцедуры
 
Документ заполнили, закрыли и вернулись в форму справочника. Но при этом необходимо, чтобы реквизит справочника вПроекте имел значение новый созданный документ
 
Как бы это сделать?
К списку тем К списку форумов

Интересные темы

odines.ru
20.10.2020 - 08:11
Смотри также:
Бух. Глюк на компе
Как из 1С заполнить поле <МЕМО> в файле DBF ?
Как сделать что бы счет корреспондировал с пустым счетом?

Re: ПриНачалеВыбораЗначения + открытьформу. Как передать значение обратно?

Ёпрст
1 - 23.07.2009 - 07:06
ОбработкаВыбораЗначения

Re: ПриНачалеВыбораЗначения + открытьформу. Как передать значение обратно?

Uho
2 - 23.07.2009 - 07:11
нафига в элементе ссылка на документа, а в документе на элемент?

Re: ПриНачалеВыбораЗначения + открытьформу. Как передать значение обратно?

ПашаК
3 - 23.07.2009 - 07:16
1-Ёпрст > не совсем понятно в какой модуль вставить эту процедуру
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Плиз, 1SJOURN.DBF - разрушена таблица, как восстановить? Очистить историю периодического реквизита »
© 2009 Форум 1С: Одинэс.Ру