FormEx Раскраска строк Дерева и ТаблицыЗначений

Форум 1С: Одинэс.Ру

Найти!

FormEx Раскраска строк Дерева и ТаблицыЗначений

Mobilis
01.04.2009 - 09:28
Собственно сабж. Если можно пример кода.
К списку тем К списку форумов

Интересные темы

odines.ru
21.10.2020 - 19:20
Смотри также:
Бух Списывать при вводе в эксплуатацию
Комплекс защиты конфигураций 1C 7.7 «Кольчуга»
Ошибка работы в 2008Server. Кто поможет?

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Mobilis
1 - 01.04.2009 - 09:35
Интересует именно Дерево. Есть ли там возможность раскраски строк ?

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Anonymous
2 - 01.04.2009 - 09:42
(0,1)"Назначение:
Компонента позволяет устанавливать произвольную раскраску в таблицах 1С (многострочные части документов, формы списков, таблицы значений на форме, дерево+таблица и т.д.)..." (с)Мануал

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Anonymous
3 - 01.04.2009 - 09:44
+2 Раскраска пишется аналогино тз

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Mobilis
4 - 01.04.2009 - 10:13
ПриОткрытии()
ТЗ.НоваяКолонка("ТЗВлож");
ТЗ.НоваяКолонка("Пикт","Число",1,0,"",4,);
ТЗ.НоваяКолонка("Наименование",,,,,40);
ТЗ.НоваяКолонка("Объект");
ТЗ.НоваяКолонка("FormEx_ПланРаскраски");
ТЗ.ВыводитьПиктограммы("Пикт");
КонецПроцедуры
 
Процедура ПослеОткрытия()
 
Сервис = СоздатьОбъект("Сервис");
//разрешаем использование раскраски таблиц
 
Сервис.ВключитьРаскраскуТаблиц(1);
Сервис.ИспользоватьПланРаскраски(1);
 
РФорма = СоздатьОбъект("РасширениеФормы");
РФорма.РаскрашиватьТаблицу("ТЗ");
 
АтрФормы = СоздатьОбъект("АтрибутФормы");
АтрФормы.УстановитьАтрибут(Форма,"ТЗ");
АтрФормы.ПерехватитьТаблицуЗначений();
АтрФормы.ОпцииДерева(0,1,1,2);
АтрФормы.УстановитьТекущийУзел(1);
 
КонецПроцедуры
 
Функция ПроверитьВид()
Возврат "()()(BRUSH["+ПолучитьЦвет(254,135,118)+"])()()()";
КонецФункции
 
Процедура ПриВыбореШаблона()
 
ТЗ.КоличествоСтрок(0);
Спр=СоздатьОбъект("Справочник.НормыРасходов");
Спр.ИспользоватьВладельца(ВыбШаблон);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
ТЗ.НоваяСтрока();
ТЗ.Пикт=1;
ТЗ.Наименование=Спр.ТекущийЭлемент();
ТЗ.Объект=Спр.ТекущийЭлемент();
ТЗ.FormEx_ПланРаскраски=ПроверитьВид();
КонецЦикла;
АтрФормы.ОбновитьДерево();
 
КонецПроцедуры
 
Раскраска работает начиная с колонки FormEx_ПланРаскраски, а хотелось, чтоб и колонка Наименование тоже раскрашивалась.

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Anonymous
5 - 01.04.2009 - 10:27
(4)
Возврат "(BRUSH["+ПолучитьЦвет(254,135,118)+"])()()()";
а так?

Интересные темы

odines.ru
21.10.2020 - 19:20
Смотри также:
Изменить границу последовательности БЕЗ проведения документов
Для меня до сих пор остается загадкой
цены в форме элемента номенклатуры

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Mobilis
6 - 01.04.2009 - 10:32
+5 Тоже не работает.

Re: FormEx Раскраска строк Дерева и ТаблицыЗначений

Anonymous
7 - 01.04.2009 - 11:04
(6)Дествительно не хотит (даже при ИспользоватьПланРаскраски(0)), сделай тестовую обработку и выложи на: http://www.1cpp.ru/forum/YaBB.pl?board=FormEx , может АЛьФ там чем подможет.
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Каринки и таблицы Как опознать ИБ "Свод отчетности" »
© 2009 Форум 1С: Одинэс.Ру