Удаление строки из документа?

Форум 1С: Одинэс.Ру

Найти!

Удаление строки из документа?

volodja
04.06.2009 - 06:38
Пишу вот такой код в документе с табличной частью
Процедура ПриЗаписи()
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
    Если Количество = 0 Тогда  
        УдалитьСтроку();
    КонецЕсли;
КонецЦикла;
КонецПроцедуры
 
Удаляет при каждой записи только по 1 строке
Почему ?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
05.12.2020 - 06:07
Смотри также:
Как определить в запросе |ВидДок = Регистр.Партии.ТекущийДокумент.Вид();?
Как сделать что бы счет корреспондировал с пустым счетом?
После обновления до 7.70.027 перестала работать обработка

Re: Удаление строки из документа?

Uho
18 - 05.06.2009 - 09:54
а у меня красивее, короче и лаконичнее :P

Re: Удаление строки из документа?

roma n
19 - 05.06.2009 - 10:01
(18) лень проверять, но с чем-то вроде была там закавыка...
после удаления последней строки позиционирование теряется. ПолучитьСтроку() в этом случае не матерится?

Re: Удаление строки из документа?

Uho
20 - 05.06.2009 - 10:34
(19) помню-помню, что-то было)))

Re: Удаление строки из документа?

Uho
21 - 05.06.2009 - 10:40
+20 проверил различные варианты на ТЗ - вроде все работает

Re: Удаление строки из документа?

USSR
22 - 05.06.2009 - 10:56
(19,21) Дети "лейтенанта" Кнута :)

Интересные темы

odines.ru
05.12.2020 - 06:07
Смотри также:
Добавление колонки Автор в журнал документов
Как вытащить из Парус 4.50 зарплата в 1С Бюджет
Сумма операции

Re: Удаление строки из документа?

victuan
23 - 05.06.2009 - 13:47
:-)

Re: Удаление строки из документа?

Ctrl P
24 - 06.06.2009 - 06:41
я так пользую:
пока тз.найтизначение(0,сСтрока,"количество") =1 цикл
тз.удалитьстроку(сСтрока)
КонецЦикла
имхо самый короткий код... если нулей нет то и обхода не будет лишнего ))
Зы правда это для таблицы значении

Re: Удаление строки из документа?

Ctrl P
25 - 06.06.2009 - 06:51
тест

Re: Удаление строки из документа?

Ctrl P
26 - 06.06.2009 - 06:54
а что должно происходить когда нажимаешь на ссылку номера поста на форуме?

Re: Удаление строки из документа?

Ctrl P
27 - 06.06.2009 - 06:56
а вот че забыл, сСтрока = 0 в цикле надо
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Нумератор в ПУБ.Нужен совет Оформление полисов ОСАГО в v7 »
© 2009 Форум 1С: Одинэс.Ру