Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

Форум 1С: Одинэс.Ру

Найти!

Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

SergeyKa
05.05.2009 - 19:39
Попросили в одном магазине кое-что подправить в конфигурации для работы со сканером штрих-кода. Не знаю,как так получается,что процедура ОбработкаВнешнегоСобытия() возникает только при открытой форме для подбора номенклатуры.В других формах,где только не пробовал - в документах, справочниках, где пытался настроить, вызова процедуры не происходит.Сканер подлючен в разрыв клавиатуры.
Подключение сканера:
Если ЗагрузитьВнешнююКомпоненту("ScanOPOS.dll")<>0 Тогда
     СканерШтрихКода=СоздатьОбъект("AddIn.Scanner");
     Если СканерШтрихКода.УстройствоВключено=0 Тогда
         Если СканерШтрихКода.Подсоединить("Scanner") = 0 Тогда // OPOS_SUCCESS
    Если СканерШтрихКода.Занять(1)= 0 Тогда // OPOS_SUCCESS
СканерШтрихКода.УстройствоВключено=1;
Если СканерШтрихКода.Результат= 0 Тогда // OPOS_SUCCESS
            РаботаСоСканеромШтрихКода=2;
    Предупреждение("Включили сканер");
КонецЕсли;
    КонецЕсли;
         КонецЕсли;
      Иначе
         РаботаСоСканеромШтрихКода=2;
      КонецЕсли;
КонецЕсли;  
 
В чем может быть причина?
К списку тем К списку форумов

Интересные темы

odines.ru
20.01.2021 - 07:00
Смотри также:
Единица и коэффициент в ТиС - загадка для мну...
Амортизация ОС на складе 2ая категория
Подскажите конфигурация по управлению погрузками и доставками (под платформу 7.7)

Re: Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

Gloom
1 - 05.05.2009 - 20:36
scanopos только через rs-232 работает, для клавиатурных сканеров атоловские дрова нужны.

Re: Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

SergeyKa
2 - 05.05.2009 - 20:59
(1)Я раньше и сам подключал атоловские драйвера к базам,и все работало идеально.
А тут пришел чужие труды исправлять,и вот...
Но ведь как-то он в форме подбора считывает штрих-код и передает.

Re: Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

user1C
3 - 05.05.2009 - 21:16
(0)
РаботаСоСканеромШтрихКода=2 есть OPOS_SUCCESS?

Re: Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

SergeyKa
4 - 05.05.2009 - 21:51
(3)Не знаю,я привел тот код со всеми комментариями,который был до меня

Re: Не происходит вызов ОбработкаВнешнегоСобытия() при использовании сканера штрих-кода в разрыв клавиатуры

victuan
5 - 06.05.2009 - 01:54
(2) "Но ведь как-то он в форме подбора считывает штрих-код и передает." Он просто эмулирует клаву и выдает циферки БЕЗ вызова внешнего события, то же самое если сам с клавы штрихкод введешь.
Без атола у тебя ничего не взлетит, 100%

Интересные темы

odines.ru
20.01.2021 - 07:00
Смотри также:
Сравнение баз
Обработка для централизованного принудительного завершение работы &#8203;всех пользователей. Что посоветуете?
Некорректное отображение реквизитов при печати в ТОРГ-12/ 1С 7-ка
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Универсал 2.7 Выписка, счет и счет-фактура »
© 2009 Форум 1С: Одинэс.Ру