Вопрос-баян: получить имя принтера

Форум 1С: Одинэс.Ру

Найти!

Вопрос-баян: получить имя принтера

Чучундер
22.04.2009 - 17:19
а именно: как перед Таб.Напечатать(0) получить имя принтера, на который будет производиться печать? т.е. требуется получить имя текущего принтера в 1С
...???
К списку тем К списку форумов

Интересные темы

odines.ru
21.10.2020 - 16:30
Смотри также:
косяк в справочнике номенклатура
Как вытащить из Парус 4.50 зарплата в 1С Бюджет
Выгрузка в казначейтсво Бух Бюджет 7.7

Re: Вопрос-баян: получить имя принтера

tsd
1 - 22.04.2009 - 17:36
http://www.kuban.ru/forum_new/forum9/arhiv/256931.html
в самом низу 3 варианта

Re: Вопрос-баян: получить имя принтера

Чучундер
2 - 22.04.2009 - 19:06
1-tsd > не... вопрос в том, например, напечатал я этикетки на принтер этикеток, текущим принтером стоит BarCode1, теперь если я печатаю типа обычный лист А4 сразу на принтер - то он вывалится на это принтер этикеток - это не есть хорошо. Стоит задача: например если перед отправкой на печать ТЕКУЩИЙ ПРИНТЕР (не принтер по умолчанию!!!) с именем "BAR" - торможу печать и переспрашиваю принтер.. вот такое хочется...

Re: Вопрос-баян: получить имя принтера

tsd
3 - 22.04.2009 - 19:51
2-Чучундер > ну а в чем проблема то? Получи скриптом имя текущего принтера,если в названии есть BAR и печатаешь не этикетки, то начинаешь грязно ругаться :)

Re: Вопрос-баян: получить имя принтера

КонецЦикла
4 - 22.04.2009 - 21:33
В ПараметрыСтраницы() не пробовал заглянуть? Там можно имя указать

Re: Вопрос-баян: получить имя принтера

Чучундер
5 - 22.04.2009 - 22:09
3-tsd > ок, покопаю ссылку поподробнее, потому как там навскидку под текущим принтером понимают тот, что по умолчанию...
4-КонецЦикла > ээээ! хитрый какой! мне не надо печатать на определенный принтер, мне надо НЕ печатать на определенные принтеры...

Интересные темы

odines.ru
21.10.2020 - 16:30
Смотри также:
УСНпроф->в базовую?
Кто нибудь встречался с проблемой в Предпринимателе 152, не хочет добавлять декларацию за 2008 год
Выводить отсортированными по алфавиту не получается...

Re: Вопрос-баян: получить имя принтера

КонецЦикла
6 - 22.04.2009 - 22:13
Какие-то у тебя задачи все время... как бы сказать что-то необидное :)
В общем угол наклона орудия менять имхо надо, наш паровоз фперед летит...

Re: Вопрос-баян: получить имя принтера

Чучундер
7 - 22.04.2009 - 22:32
6-КонецЦикла > нибздо! все идет пучком! ;-)
просто у мну орудие из-за угла стрелять может! пока разрабатывают БольшуюБерту ;-)
.
...расколись, как бы ты решил следующую задачу:
- в пределах досягаемости оператора куча принтеров - для А4 и для этикеток. соответсвенно этикетки надо гнать только на этикеточные, а печать на А4 - на любой подходящий для А4... при этом для оператора - минимум телодвижений д.б.

Re: Вопрос-баян: получить имя принтера

Друзья зовут меня Курулай
8 - 23.04.2009 - 03:20
(7) правильный ответ дан в (4)
этикетки принудительно отправляй на этикеточный принтер, остальное - куда хочешь
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Возможно ли обращаться к контексту при выполнении процедур в DLL Запуск 1С »
© 2009 Форум 1С: Одинэс.Ру