Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Форум 1С: Одинэс.Ру

Найти!

Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
27.05.2009 - 04:30
Доброго утра! Задача в том чтобы из данных обработки открыть несколько форм документов одного вида, заполнить их, но не записывать.
Если я пытаюсь сделать это в цикле методом ОткрытьФорму("ЗаявкаПокупателя",ПеремКонтекст);
то открывается только одна форма.
Такая задача решаема?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
25.10.2020 - 23:05
Смотри также:
Помогите разобраться с метаданными
не работает Записать(). Помогите!!!!
Проблема с УРИБ.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

roma n
1 - 27.05.2009 - 04:41
Решаема.
Док = СоздатьОбъект("Документ.ЗаявкаПокупателя");
НачатьТранзакцию();
Док.Новый();
Док.Записать();
ОткрытьФорму(Док.ТекущийДокумент(),ПеремКонтекст);
ОтменитьТранзакцию();
======
ЗЫ только вот к результату это не приблизит :)

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
2 - 27.05.2009 - 04:53
(1)всё равно одна форма открывается
РФТЗМагазиновСКоличеством.ВыбратьСтроки();
Пока РФТЗМагазиновСКоличеством.ПолучитьСтроку()=1 Цикл
Если РФТЗМагазиновСКоличеством.Количество<>0 Тогда
НачатьТранзакцию();
ДокЗаявка.Новый();
ДокЗаявка.Записать();                    
ПеремКонтекст="";
ОткрытьФорму(ДокЗаявка.ТекущийДокумент(),ПеремКонтекст);
ОтменитьТранзакцию();
КонецЕсли;
КонецЦикла;

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

roma n
3 - 27.05.2009 - 04:56
Цикл не там.
НачатьТранзакцию();
Пока ... Цикл
Док.Новый();
Док.Записать();
ОткрытьФорму(Док.ТекущийДокумент(),ПеремКонтекст);
КонецЦикла;
ОтменитьТранзакцию();
====
Результат всей этой суеты будет любопытен, но практически бесполезен

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
4 - 27.05.2009 - 05:15
(3)понял, спасибо, получилось, по поводу бесполезности - верно, обратится то к ним нельзя, если я при открытых формах добавляю ручками новый документ, то он берёт номер первого документа из открытого диапазона не видя открытых форм.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

roma n
5 - 27.05.2009 - 05:22
(4) запись этих документов из форм тоже дает интересный эффект - запись в никуда

Интересные темы

odines.ru
25.10.2020 - 23:05
Смотри также:
Можно ли восстановить базу (хотя бы протелепатируйте)
пакетный режим конфигуратора
Подскажите, проблема с печатью отчётности из 1С 7.7

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
6 - 27.05.2009 - 05:23
(5)верно :)
так значит задача не имеет практического решения?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
7 - 27.05.2009 - 05:27
задача имеет практическое решение....

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
8 - 27.05.2009 - 05:32
(7) 1срр здесь не помошник? когда-то боролся с заполнением табл.части без записи документа и без редактирования модуля формы документа, в этом случае 1срр помогла, но там был один документ, а здесь - несколько.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
9 - 27.05.2009 - 05:34
все делается штатно....
можно и табличную часть незаписанного заполнять...
и изменять дату проведенного дока без всяких извратов...

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
10 - 27.05.2009 - 05:35
и без 1с++

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
11 - 27.05.2009 - 05:38
(10)так штатно табл.часть не заполняется же, или речь о каких-то недокументированных методах?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
12 - 27.05.2009 - 05:45
а кто тебе мешает вместо засунуть то, что должно быть в табл части, в параметры, открыть форму нового дока и из самой формы по полученным параметрам в процах ПриОткрытии или ВводНового заполнить табл часть

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Дятeл
13 - 27.05.2009 - 05:47
12-pit > понимаешь ли, когда ты говоришь штатно и без всяких извратов - многие понимают как внешней обработкой без изменения конфигурации..

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
14 - 27.05.2009 - 05:48
(12)так я же и пишу о том что править модуль форму документа - не желательно, хочу обойтись только внешней обработкой без изменения конфигурации.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
15 - 27.05.2009 - 05:48
(13-Дятeл > клювы у них не той системы

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Lexusss
16 - 27.05.2009 - 05:49
FormEx

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
17 - 27.05.2009 - 05:49
14-Looking > тогда ищи шашечки, чтобы ехать... править придется

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
18 - 27.05.2009 - 05:50
16-Lexusss > в формексе появилось открытие нескольких незаписанных форм одного вида?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Дятeл
19 - 27.05.2009 - 05:50
15-pit > не, у них опыта долбления не столько как у тебя :)

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
20 - 27.05.2009 - 05:51
+(14)иногда это желание, иногда необходимость, например для базовой версии - необходимость, для стандарт или проф например бывают случаи когда из программы всех выгнать можно только в конце недели, а начать работать с новым функционалом хочется уже сейчас, ну и доп.движения при обновлении на типовой релиз.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
21 - 27.05.2009 - 05:54
(16)так 1с++ в себе в том числе методы FormEx содержит, но разве эта компонента в этом случае - пмошница?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

victuan
22 - 27.05.2009 - 06:21
Почему эта фраза в устах пита "изменять дату проведенного дока без всяких извратов" звучит бредом?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
23 - 27.05.2009 - 08:49
без всякого формекса и без транзакций - нормальное открытие любого разумного количества форм нового документа одного вида:
http://www.infostart.ru/projects/1969/

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
24 - 27.05.2009 - 08:50
Ну, по крайней мере пару строк в док вставить придется... иначе - я не знаю...

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Looking
25 - 28.05.2009 - 04:58
(23), (24) спасибо! А можно вопрос - почему не работает описатель формы из внешней обработки? Из-за чего его присвоение обязательно нужно в модуль форму документа добавлять?
 
Если ТЗ.КоличествоСтрок()<>0 Тогда
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Если ТЗ.Количество<>0 Тогда
ПеремКонтекст="";            
ПеремИдФормы="#ИД"+СокрЛП(РФТЗМагазиновСКоличеством.НомерСтроки);
ОткрытьФорму("Документ.Заявка"+ПеремИдФормы,ПеремКонтекст);
ПеремКонтекст.Контрагент=РФКонтрагент;
ПеремКонтекст.Договор=РФДоговор;
КонецЕсли;
КонецЦикла;

 
по ссылке из (23) прочёл следующее
"#LLLL"
Для журналов, отчетов, списков в конце строки описателя формы может быть указан символ "#" с некоторым идентификатором: "#LLLL". Это используется для того, чтобы данная форма открылась в новом окне, а не активизировала существующее окно этой формы, если оно открыто. Где, LLLL — идентификатор, который позволяет открыть новое окно или активизировать уже открытое с этим идентификатором. Если идентификатор не задан, то обязательно открывается новое окно.

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Дятeл
26 - 28.05.2009 - 05:17
23-Чучундер > у меня на ТиС 9.2 падает на 100 Чебураш.. тьфу, тараканах :)

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
27 - 28.05.2009 - 06:35
26-Дятeл > массой задавили... Это не на тис падает... точно так же винды можно в аут вывести наоткрывав кучу окон... это пусть лучше специалисты-программисту объясняют.. мне, выдающемуся девелоперу, эти проблемы неактуальны...
;-)

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
28 - 28.05.2009 - 06:36
25-Looking > !!Для журналов, отчетов, списков!!! - документы ГДЕ?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
29 - 28.05.2009 - 06:40
26-Дятeл > Чебурашки - это такой особый вид Чучу... в общем, понятно кого, с большим титановым клювом, гигантскими ушами от слона и крокодиловым хвостом....

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
30 - 28.05.2009 - 06:41
26-Дятeл > вот в (28) он пришел и орет.... ну чистА Чебураш....

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
31 - 28.05.2009 - 06:43
29-pit > еще у меня большое пузо!

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
32 - 28.05.2009 - 06:45
31-Чучундер >  ага... значит, клюв с удлинителем? Иначе до столба не достаешь?

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
33 - 28.05.2009 - 06:53
32-pit > блин, ниче непонимаешь!!! как противовес большому кракодиловому хвосту!

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
34 - 28.05.2009 - 06:57
33-Чучундер > "кракодиловому" ???
 
Бедняжка... Тебе уже и крАкодиловый хвост отрезали на крОкодиловые кошельки? Теперь пластиковый муляж носишь?
 
P.S. Покупайте нОрмальный муляжи!  Они 100% эмулируют хвосты...

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

Чучундер
35 - 28.05.2009 - 07:03
(34) хуже! некоторые извращеннцы кошельки иделают!!!

Re: Открыть и заполнить несколько форм документов из внешней обработки не записывая их

pit
36 - 28.05.2009 - 07:05
понятно... значит, перед нами Искусственный  Чебураш... (дальше почему то цензура окрысилась)
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Ошибка сохранения отчета СикольКо денег стоит создание и настройка базы по 1С ТИС + штрих-М кассир ? »
© 2009 Форум 1С: Одинэс.Ру