Проблема с итогами в отчете в разрезе родителей элемента справочника

Форум 1С: Одинэс.Ру

Найти!

Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
23.07.2009 - 09:50
Есть ТЗ полученная в результате запроса, далее нужно суммы вывести в разрезе иерархии справочника, который является реквизитом для справочника из ТЗ.
 
СправДох=СоздатьОбъект("Справочник.КлассификацияДоходов");
СправДох.ВыбратьЭлементы();
Пока СправДох.ПолучитьЭлемент()=1 Цикл
    Если СправДох.Уровень()>УровеньМах Тогда
УровеньМах=СправДох.Уровень();
    КонецЕсли;
КонецЦикла;
 
ТабИтД=СоздатьОбъект("ТаблицаЗначений");
ТабД.Выгрузить(ТабИтД);
Для i=1 По УровеньМах Цикл
     ТабИтД.НоваяКолонка("КБКРодитель"+i);
КонецЦикла;
ТекУровень=0;
ТекРодитель="";
ТабИтД.ВыбратьСтроки();
Пока ТабИтД.ПолучитьСтроку()=1 Цикл
    Если ТабИтД.КБК.Классификатор.Родитель.Выбран()=1 Тогда
ТабИтД.КБКРодитель1=ТабИтД.КБК.Классификатор.Родитель;
Если СправДох.НайтиЭлемент(ТабИтД.КБК.Классификатор.Родитель)=1 Тогда
    ТекРодитель=СправДох.ТекущийЭлемент();
    Для i=9 По ТабИтД.КоличествоКолонок() Цикл
ТабИтД.УстановитьЗначение(ТабИтД.НомерСтроки,i,ТекРодитель.Родитель);
ТекРодитель=ТекРодитель.Родитель;
    КонецЦикла;
КонецЕсли;
    КонецЕсли;
КонецЦикла;
 
Потом сворачиваем все что получилось по каждой новой колонке и добавляем в исходную ТЗ.
Тока не нравится мне весь этот код, может как попроще можно?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
05.12.2020 - 06:23
Смотри также:
Бух 7.7 и авансы
Остатки по НУ. Количество.
Запуск 1С

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

pit
21 - 27.07.2009 - 07:44
В данном примере - да, был единственный запрос к бухитогам...
Но на самом деле это безразлично, откуда заполнять ТЗ....
это прекрасно работает в ОУ...

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

pit
22 - 27.07.2009 - 07:45
точнее - когда переделывал для ОУ, просто заменил запрос БИ на обычный запрос к регистру остатков. Там правда, пришлось горбатого лепить с партиями...

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
23 - 27.07.2009 - 07:47
21-pit >Подскажи мозгов не хватает как ты иерархию вытащил в запросе?

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

pit
24 - 27.07.2009 - 08:17
я не парился - некогда было.... Тупо прокрутил результат запроса в цикле (там на самом деле еще и кАзелЮзер заполняется для борьбы с дублями). А вот его я точно не смог выдернуть запросом.

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
25 - 27.07.2009 - 08:22
24-pit >В цикле по справочнику?

Интересные темы

odines.ru
05.12.2020 - 06:23
Смотри также:
Как из 1С распечатать сертификаты в формате pdf
Сохранить открытый документ
ПУБ Нереальные суммы корректировки стоимости материалов полученных в переработку и переданных в переработку.

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

pit
26 - 27.07.2009 - 09:24
ошал я чтоли... по справочнику... у меня там чуть ли не 300 тыс элементов...
По результатам запроса....

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
27 - 27.07.2009 - 09:37
26-pit >Я понимаю, что туплю, но добавление иерархии в ТЗ кроме как
ТекстЗапроса = "//{{ЗАПРОС(Запрос1)
|РдСправДох = Справочник.КлассификацияДоходов.ТекущийЭлемент;
|Условие(ТабИтД.КБК.ПринадлежитГруппе(РдСправДох)=1);
|Группировка РдСправДох;
|"//}}ЗАПРОС
;
(применительно к моей проблеме) что-то на ум не идет

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

pit
28 - 27.07.2009 - 09:42
да просто тупо перебери в цикле тз и все....

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
29 - 27.07.2009 - 09:46
28-pit >У меня в запрос (27) вставлен в цикл по ТЗ ТабИтД.КБК.ПринадлежитГруппе(РдСправДох)=1. Т.е. вариантов вытащить иерархию применительно к (0) больше нет?

Re: Проблема с итогами в отчете в разрезе родителей элемента справочника

chief accountant
30 - 27.07.2009 - 09:49
У меня в запрос->У меня запрос
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« помогите с поиском в справочнике ПУБ и поступление материалов через авансовый отчет »
© 2009 Форум 1С: Одинэс.Ру