БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Форум 1С: Одинэс.Ру

Найти!

БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
25.03.2009 - 05:24
Здравствуйте, подскажите пожалуйста! Собираю в отчет основные средства по субконто с 01 счета, еще нужно добавить итоги по амортизации с 02 счета и никак они не выводятся. Как ей сказать чтобы БуИт.СНК она брала с 02 счета. буду очень благодарна за помощь. Это фрагмент отчета:
БуИт=СоздатьОбъект("БухгалтерскиеИтоги");
БуИт.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства,,,0);
БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1);
БуИт.ВыбратьСубконто(1);
    Пока БуИт.ПолучитьСубконто(1)=1 Цикл
         Субк=БуИт.Субконто(1);
Амортизация=БуИт.СНК("С");
    КонецЦикла;
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
22.10.2020 - 20:37
Смотри также:
выгрузка в DBF формат
Как вытащить из Парус 4.50 зарплата в 1С Бюджет
Дебилизм какой-то..

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

VZ
3 - 25.03.2009 - 05:47
А почитать ЖКК (желто-красную книжку)? Со страницы 2-499?

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
4 - 25.03.2009 - 05:53
(3) Да читаю весь день, уже не соображаю ничего, чтото я не так делаю :((

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Duke1C
5 - 25.03.2009 - 05:55
А конструктором бух запросов в Конфигураторе пользоваться не пробовали?

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
6 - 25.03.2009 - 05:57
(5) Нет, не пробовала

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

VZ
7 - 25.03.2009 - 06:07
Сначала счета надо выбирать. Уж потом - субконто.

Интересные темы

odines.ru
22.10.2020 - 20:37
Смотри также:
ПБОЮЛ. Книга продаж.
УСН (160-161), после обновления спр.ВидыВычетов стал пустым, помогите!!!
Открыть диалог нового документа через расшифровку ячейки возможно?

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
8 - 25.03.2009 - 06:18
(7) Если б вы еще подсказали как это сделать, я была бы счастлива :). Я уже пробовала, не получилось.

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
9 - 25.03.2009 - 06:28
Почемуто Амортизация2 = БуИт.КО по 02 выходит, а СНК и СКК нет, что не так не пойму

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

VZ
10 - 25.03.2009 - 08:51
Потомушто счет пассивный.

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

Anonymous
11 - 26.03.2009 - 03:15
Ураа! заработало!!:))
 
Сч02 = СчетПоКоду ("02");
Пока БуИт.ПолучитьСубконто(ВидыСубконто.ОсновныеСредства) = 1 Цикл
    
     БуИт.ВыбратьСчета(1,0,1,0);
Если БуИт.ПолучитьСчет(1,Сч02) = 1 Тогда
        Амортизация=БуИт.СНК();
Амортизация2=БуИт.КО();
Амортизация3=БуИт.СКК();
            КонецЕсли;
 
Таб.ВывестиСекцию("Строка");
 
КонецЦикла;
 
Всем спасибо :))
 

Re: БуИт.ВыполнитьЗапрос('01.01.2008','31.12.2008',"01,02",,,1,,1); Как вывести в отчет итоги по 02 счету

pit
12 - 26.03.2009 - 03:24
VZ - дохтур?  Я в шоке....
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« УСН v7.7.162 - не заполняется док. "Инвентаризация" Бюджет редакция 6.1 - учет казны »
© 2009 Форум 1С: Одинэс.Ру